Can't get Ubuntu MATE to boot on Raspberry Pi 3 B, no way, no how

Tried different downloads, different USB keys, multiple writes, no luck. Just won’t do anything. Only thing I can get to boot is Raspbian.

Not much to go on there.
Which image are you using - I see there is a 16.04.03LTS now, but I’ve not got beyond 16.04.02LTS.
What peripherals?
What PSU - that can be critical, as I suspect the current draw for UbMate is higher than Raspbian?
Have you observed the LEDs while it boots, and do you get the multi-colour screen at the start of the process?

PS I just looked and there is not a link for the .03 binary yet

I’m using the download on the Raspberry Pi site. I’m using the best power supply I could get, designed for Raspberry Pi, 3.0 amps. The only things plugged in are a USB mouse and keyboard. The LEDs do nothing, the red one lights, but that’s it, no activity on the other. The monitor does not show anything, but has a signal. There is no rainbow pattern. Like I said, the only thing that works is Raspbian. I’ve even used the exact same thumb drive as Raspbian is on to try Ubuntu MATE, no go. Like I’ve said, I’ve tried several new flash drives and several different downloads.

I followed the directions here. The gnome disk utility method works for me every time.

When you say, “thumb drive”, you actually mean a Micro SD drive correct?

No, I mean USB drive. USB booting is enabled. Raspbian is installed on a USB flash drive. I’m using Win Disk Imager, maybe that’s the issue. I’ll do a Linux setup on a spare drive and try it from there, though I’m not sure why that would make a difference, since I wrote the Raspbian drive under Windows.

Well done steven - I missed that one!
guyonearth - you’ll be doing well if you can get UbMate to boot from the usb drive. The nearest I got was a partially completed boot with fatal error messages.

1 Like

Well, others have done it. What’s the secret? I wrote another drive under Linux with Etcher, still no go…this is getting absurd. Maybe they changed something on the Pi itself? It’s a brand new one.

Maybe what I read was outdated, but I thought booting a Pi from a USB drive was experimental. Is there a particular reason you prefer not using a Micro SD?

No, you can enable USB booting, but what I’ve discovered is that only the Raspbian image is properly configured to work reliably it seems. Once I got a new SD card, Ubuntu Mate, OpenSuSE, even Windows IOT all booted up fine. I guess I thought USB would be faster, though I doubt it’s noticeable.

1 Like

Well, it was working, now it's doing this after a few hours...locks with a flashing screen, when you reboot you get a kernel panic...

Booting off a USB drive?

No, this is an SD card.

Ending up installing MATE on Raspbian, doesn’t work perfectly though.

1 Like

That I’ve never tried, interesting.

Not ideal, you have to completely uninstall lxde first or you’ll have no way to choose a new session, as far as I can tell. Doesn’t seem to be any way to switch sessions.

The only advantage I can see to booting of anything other than the onboard Micro-SD is the possibility of avoiding SD card writing (and reading) fatigue. The underlying speed of all the “disc-IO” on a RPi is the USB bus. So picking a storage system that is about as fast as the underlying USB speed, is about as good as you can get, regardless of whether is is micro-SD, USB thumb drive, or a mSATA SSD drive. However having said that I would like UM to be able to facilitate this option smoothly as I run a website with my RPi3 and I would like to use an mSATA SSD drive to mitigate wear rather than worry about speed.


I found that the display out had a big impact, had to go into the boot config file and changed from HDMI to DVI. Are you using a DVI screen? @guyonearth