Cd/dvd rom drive will not mount

I can’t get mine to mount. using 16.04 and the computer recognizes the drive but keeps saying there is “no medium found on /dev/sr0.” ?? I have read and tried many things. ?? Help!! This is just a audio cd not a boot disk. DVD’s won’t work either.


Hi @dsoren00,

in our other correspondence; I forgot to ask as to whether or not you actually removed the drive and booted the PC without it?, once you boot at least once, shut down again and replace the drive and see what happens!. :smiley: :thumbsup:

yes I did that.


Have you cleaned it yet although I personally don’t think it will help much!. :confused:

the only thing I can think of is I did the fstab file wrong. Can you walk me through that? I have only messed around in that file a couple of times and just about each time, I have had to reinstall the OS. I am scared to go into that file alone. It’s like going into the scary basement.


Hi Dave,

soory but I don’t mess around with such things as I have never found the need to do so, take a look here for more info and maybe @lah7 can help on this one:

I’ve got some questions that would better understand the problem:

  • What model and manufacturer is the driver?

    • Perhaps this is a known problem in Ubuntu.
    • This can be seen in Disks.
  • Does the disc spin at all?

  • Can it boot discs?

  • Did it use to work before?

  • In a live session (boot from disc), is the medium detected in Disks when changing to your music CD?

    • If so, then it might be a problem in fstab, please post the output here:

          cat /etc/fstab

Some devices (Apple USB iDrive) refuse to read discs without a special combination sent to the drive, but I doubt there is a “lock out” happening here.

Hi Luke,

it is an oldish problem but there is one solution here (last answer) which might help?:

I have had this problem too and I found simply re-booting several times works as it springs back to life!, a rather tiresome method but it does work with patience!. :thumbsup:

It is a pioneer DVDRW, DVT-K17B. It did work. I spins. I don’t know if it will boot because I booted from a USB. It is an old HP Pavilion.

here is the fstab:

# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
/dev/mapper/ubuntu--mate--vg-root /               ext4    errors=remount-ro 0       1
# /boot was on /dev/sda1 during installation
UUID=e290ba7c-d0a7-4863-983e-b0f3707a1acc /boot           ext2    defaults        0       2
/dev/mapper/ubuntu--mate--vg-swap_1 none            swap    sw              0       0

I tried adding what others have suggested in several posts on the internet and I must of done something wrong because after, nothing worked right. If you can walk me through it I would greatly appreciate it. I know the sr0 mounting stuff is not there, but when I tried it, I messed it up. This is the new OS install.

Thanks for your time,

Your fstab doesn’t show any disc drives, so we can rule out that as being the problem.

Is it possible for you to mount the drive anyway? What does the error say exactly?

sudo mount /dev/sr0 /mnt

Even better, check the Disks program if the drive reads “No medium” or “Unknown” when a disc is inserted.

Otherwise, you say it’s an old HP Pavilion … I presume a desktop tower? If so, you could try connecting the drive to a different SATA port.

If it’s the older IDE type of drive, there may be jumper switches for “Master” and “Slave”… “master” being the one it should be set to.

You may also want to check the BIOS settings for the drive.

If nothing above works, tell us a bit more about this drive:

sudo lshw -C disk

The worst case scenario (and potentially the case) is that the drive is physically unusable, like the laser was burnt out, and the drive needs replacing.

It is a HP Pavilion laptop. I had read that I need to add a line to the fstab file. I am just scared to try again. When I try to mount the drive, it says "no medium found on /dev/sr0. Here is the lshw output for the cd/dvd rom:

description: DVD-RAM writer
product: DVDRW DVR-K17B
vendor: PIONEER
physical id: 0.0.0
bus info: [email protected]:0.0.0
logical name: /dev/cdrom
logical name: /dev/cdrw
logical name: /dev/dvd
logical name: /dev/dvdrw
logical name: /dev/sr0
version: 1.02
capabilities: removable audio cd-r cd-rw dvd dvd-r dvd-ram
configuration: ansiversion=5 status=ready
physical id: 0
logical name: /dev/cdrom

The only thing that I can still think of is adding the line to the fstab…but I don’t know what it is and I am scared to try again.

Thanks again,

I found several sites that stated I needed to add something to the fstab file. Something like this:

/dev/sr0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0

No, you don't need anything in your /etc/fstab file -- fuse (File System Services in User Space) should mount the CD or DVD for you at /media/your_login_name/Volume_name-or-UUID.

Pioneer drives are usually very good -- however this particular model may suffer from the "bad capacitor problem" where capacitors swell up and/or leak.

A good tool to see what is going on with the drive is QPxTool. You can see drive information and request media information as well. Note that loading media and identifying the type and capabilities of the media is a drive function and doesn't have anything to do with Linux.
To install:

sudo apt install qpxtool

Once you insert media and the drive recognises it, you should see (in my case DVD-R made by RITEK):

If QPxTool won't show any media then (1) the media is bad, or (2) the drive is bad.


here is the results

So the drive does not detect the media :cry:

My panel has the toolbar enabled (right click in menu area) plus the sidebar (View/Show Sidebar).

The drive supports SMART so let’s see what it says about the drive and media. You will need to install smartmontools:

sudo apt install smartmontools

Now insert some media, wait for the drive lights to stop flashing, and then run:

sudo smartctl -aA /dev/sr0

You may need to add ‘-T permissive’ if the drive returns certain types of errors. Also try both CD and DVD media as I have seen cases where the drive will quit reading CD media (possible laser failure?).

1 Like

Since this question was originally about "mounting" an audio cd, here is what an audio cd shows in caja when automounted:

The process/daemon responsible for automounting is gvfsd, specifically /usr/lib/gvfs/gvfsd-cdda.

if I look at the properties of that gvfsd-cdda file, it says I am not owner…root is owner. One time, just once in all of this, the system told me I did not have permission…???


when I run the smartmontools it tells me to use -h here that is: I have no idea how to read it.

I ran sudo smartctl -H /dev/sr0 and this is the output:

“sudo smartctl -Aa /dev/sr0” didn’t work?

[email protected]:~$ ps ax | grep gvfsd
 1399 ?        Sl     0:00 /usr/lib/gvfs/gvfsd
 1404 ?        Sl     0:00 /usr/lib/gvfs/gvfsd-fuse /run/user/1000/gvfs -f -o big_writes
 1497 ?        Sl     0:00 /usr/lib/gvfs/gvfsd-trash --spawner :1.9 /org/gtk/gvfs/exec_spaw/0
 1679 ?        Sl     0:00 /usr/lib/gvfs/gvfsd-metadata
 5538 ?        Sl     0:00 /usr/lib/gvfs/gvfsd-cdda --spawner :1.9 /org/gtk/gvfs/exec_spaw/1
 5547 pts/0    S+     0:00 grep --color=auto gvfsd

gvfsd should run gvfsd-cdda on your behalf. You don’t have to run anything. You can check gvfsd by running the ps command and piping the results through grep as above.