Compiz as windows manager leads to empty desktop and missing menu bar (Wobbly windows wanted)

Hey there,

I got a new AMD 7950X3D and today I started to install Ubuntu MATE 23.10 - and I know, there's lots of work to do until it will run as I want it. One thing I very loved was the wobbly-windows effect on the Compiz windows manager. On 22.04 LTS it was easy to get it running. I tried the same on 23.10 and with the next login/reboot I got a blank desktop background and no menu/task bar. Hitting the Windows key and typing "tweak" did let me start MATE-Tweak where I could replace Compiz with Marco. After this my session was usable again but I had no wobbly windows effects, of course.

Any ideas how I could get at least a wobbly windows effect on 23.10? I read that there's a GNOME extension but I couldn't figure out how to use GNOME instead of Marco.

GNOME extensions only work on GNOME-shell. MATE can not run GNOME extensions.

Often even GNOME can not run GNOME extensions (especially after a new GNOME-shell release) due to a highly unstable API. :wink:

The only way to run GNOME extensions is to run GNOME-shell.
(That means: also replacing your whole graphical stack, however there is an option to keep Xorg if you really need to)
The easiest way to do that is to uninstall Ubuntu-MATE 23.10 and install the regular Ubuntu 23.10

Remember that both are the same operating system. The only difference is the deployed desktop.

This is how GNOME is structured:

1 Like

Thank you for your reply. Ok, got it. Changing to Ubuntu MATE 23.10 is not an option for me, the reason why I am on MATE is that it has a classic menu structure. I am using a PC and not a tablet.

So I'll have to try to get compiz working which currently results in an empty desktop and no menu bar. Can you help with that or would this be a senseless try for me to get it working?

I really appreciate your help.

1 Like

Unfortunately... :worried:

At the moment I don't have any computer running 23.10 so I can't test anything.
My desktop computer (which I am using to write this message) runs 22.04 LTS and has a AMD RX570 GPU which runs everything I throw at it, including Compiz.

My worklaptop is running 22.04 LTS
My homelaptop is running 24.04 LTS pre-alpha which is to come out in april this year.
So at the moment there is nothing I can try or test.

It is absolutely not senseless to try to get it running. There haven't been that much changes to Ubuntu-MATE.

There is something that you can try:

  • Check in CCSM if MATE-compatibility is enabled

  • If Compiz works, but fails after a reboot, try a different displaymanager, or at least display-greeter. I had some problems with arctica-greeter setting up a desktop session which disappeared when i swiched to slick-greeter.

  • Try to get something going on the empty desktop, and I mean anything. A terminal would be already a big win because from there on you can start things and read errormessages.
    (Use CCSM to create a hotkey to start terminal for instance)

  • If all else fails: Try a differend GPU driver by switching to another kernelversion.
    I once had a problem (long ago) with AMD depth rendering (it was confused what to place in the foreground and what to place in the background, a driverchange fixed it)

That is all for the's not much but it's at least a start.

Oh, btw, you can always go back to 22.04 LTS. It's not bleeding edge but at least it's stable and long term support ( or wait for the next LTS )


This is the same problem in ubuntu mate 24.04. ㅠ.ㅠ

1 Like

Welcome @mymy49 to the community!

1 Like

I have three computers. All three have the same symptoms. The specifications of one of them are as follows.

Lenovo ThinkPad T495
CPU: quad core AMD Ryzen 5 PRO 3500U w/ Radeon Vega Mobile Gfx (-MT MCP-)
speed/min/max: 1393/1400/2100 MHz Kernel: 6.8.0-31-generic x86_64 Up: 10m
Mem: 1.98/5.67 GiB (34.9%) Storage: 744.1 GiB (40.9% used) Procs: 309
Shell: Bash inxi: 3.3.34

Oh, no! I was about to upgrade from 22.04, but compiz for me is a must have. I hope this gets analyzed and fixed. I'll stick to 22.04 until this is ironed out. Please people help solve this! Can somebody with the problem file a bug?

Alerted by your posts, I just installed compiz on my T420 and on my Toshiba craptop

@mymy49: Although I do not know what the symptoms are that you are experiencing, compiz should work flawlessly on your computer. Did you actually try to install it ?

Since it works (albeit a bit slow) on my crappy 13 year old half-destroyed toshiba which has a E-350 APU with build in Radeon HD 6310, it will probably work on newer, faster and healthier AMD powered computers too, and probably much much better (like your T495).

If it doesn't work for you, try a fresh install because something in your settings is probably borked.

@Marco_Boneff: Compiz is in the repo and it seems to work....on both my portable pompeii called Toshiba C670D (AMD) and on my old Stinkpad T420 (Intel) it does.

How to install compiz:

sudo apt-get install compiz-mate compizconfig* compiz-plugins*

or use synaptic if you want a GUI


Compiz-mate is not installed on my PC, so I just installed it. However, the symptoms appear the same.

FYI: I'm not a developer nor part of the ubuntu-mate team, I'm just another user :slight_smile:

I had the same symptoms on Marco when I used the standard Arctica-greeter. I replaced Arctica-greeter with Slick-greeter and the symptoms were gone.

You could try and see if that works.
Whatever the outcome: file a bug against ubuntu-mate here:


While searching to find out a solution to the symptom, I came across this article and was happy to leave a comment.

I'm not good at English, so it's hard to see difficult sentences. That's why I don't understand the bug reporting system ^^;

I will just wait for the Linux developers to fix it as usual^^