Date formating on panel, and unable to set firefox in preferred applications

Hello there,

i installed ubuntu mate few months ago, and today i encountered quite annoying bug.

I don't like snap, and im only using it because [insult] at ubuntu decided to push this garbage. Because of that i installed firefox from official firefox repo (not with the default firefox package that only install it as snap package).

But for some reason "preferred applications" does not recognize it. I can not add this application myself, because i guess developers like "the modern design" of limiting user options.

Thankfully there is help button, that is completely useless. It does not have any information what to do if application is not showing up. To be honest it does not have any information.

So what should i do? Do i need to run some weird program to register firefox? Change some arcane file god knows where?

Second issue is related to date formatting in indicator bar? (or whatever it is called) you know, on top right of the screen.

In polish locale it displays wonderful: "2022:27". Which i invite everyone to guess what this could mean? I wanted to ask how this got pass the QA, but the obvious answer is that nobody cared.

At least for this, there is workaround: in "indicators" application you can set to show seconds, which turns on alien date format of: "hour:minute:second".

$ lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 22.04.1 LTS
Release:	22.04
Codename:	jammy

The issue with Polish date/time can be found here: Incorrect clock display in Ubuntu MATE 22.04

Sorry not sure about Firefox, I would think if it resides in /usr/bin then it should show up in the menus. Have you tried adding Firefox in manually to the menu?

1 Like

As i wrote, turning on seconds fixes this format for me.

I added it some time ago, preferred applications did not pick it up. Unless i need to add it in some specific way


$ which firefox

Day 1 removed snap and used the Tarball from Firefox. Works great. It sorta showed in preferred apps. What you have to try is in Firefox settings set as default. In my system it now shows. Also Thunderbird was showing only Vivaldi in preferred even though not using it as main driver. Seems like the preferred application sees the Vivaldi because it was installed via deb and Thunderbird and Firefox installed via tarball and thus may have to set in those apps for system to see. Worth a try.

Mea culpa. I guess too early in the morning, missed the "seconds" part as well as "preferred" Again, sorry about that

Sorry for not responding, i have other things to do. But going back to topic.

I did, what you had in screens, and i manage to add firefox as browser (yay), but it doesn't work (boo). When i click any link, it will open firefox, but won't open any link.

And now after restart, firefox report that it is default browser, but in preferred applications is not listed any more.


Any idea, what do do now?

I am using Tarballs from Firefox and Thunderbird and you are correct in my system method shown above does not retain the information from the tarball. Example add email to system integration on T-bird and check and it in the system integration box but only shows Vivaldi in preferred applications. At a loss just tried. FF 107.0 TB 102.5.0. Sorry.