Disappearing mouse cursor

Since I installed 16.04 x64 I have been experiencing occasional disappearances of the mouse cursor. This is fixed by logging out and back in.

Has anyone else experienced this?

No. Not happened to here - Compiz, NVIDIA drivers.

Which window manager and graphics drivers are you using? Does it happen under certain conditions?

Compiz (Advanced GPU accelerated desktop effects). My graphics is Intel.
I’m going back to Marco (Software) to see if that makes a difference.

Hi Steve,

I use Marco on both Nvidia and Intel rigs, no problems here!. :smiley:

Thanks @lah7 and @wolfman.

I’ve switched to Marco (Software) and no more problems as of yet. I’ll keep Marco for a few days then switch back to Compiz to see if problem returns.

I’ll report back.

In my case mouse cursor disappear when I use Compiz and press switch user

Yes! This is exactly what happened to me. After switching user, the mouse cursor disappears. The problem doesn’t exist with Marco.


Actually it does exist with Marco.

It’s the switching that does it.

Confirmation from other community members would be useful.

Window Managers = Not the culprits here.

Sadly, I couldn’t reproduce the problem on either. :confused: – Whether it was switching users via Log out dialog or via lock screen – my cursor is there when I log back in.

This sounds like a bug to report to Launchpad and probably affects other flavours and/or certain hardware (Intel?). Bug 1540157 could be related if this is an upgrade.

Does it reappear if you switch to a console then back again? (CTRL+ALT+F1 then CTRL+ALT+F7)
If so, this looks like a solution.

me to :wink:
had/have this problem with an old Computer I installed with UM16 beta about 1 month ago. Because this machine is not connected to the internet until now, the problem exist untill now. In some weeks i’ll update it. Hope it helps.

In the moment it helps to place the invisibla cursor on the upper edge of the screen. Here I placed an Icon for configuring the mouse (from Properties). You can see the changin colors of the icon on mouseover even withou cursor > start Program > cursor gets visible…

Mine was a clean install @lah7.

I’ve tried switching to a console and back again but this doesn’t cause the problem.

I’ll keep an eye on this to see if I can determine the exact circumstances that cause it.

I have the same problem on a i7 laptop, with 12Gb ram 8xcore CPU with both Intel Haswell and Nvidia GTX860m GPUs.
Ran into the same problem whichever Gfx card and Window managers are used. Problem is repeated with a USB mouse.

The only fix for me thus far is in the terminal :blush: gsettings set org.gnome.settings-daemon.plugins.cursor active false

1 Like

I think this may possibly be an xserver-xorg situation at play. There have been a lot of similar cursor issues throughout the xorg (MATE, and more) world lately. :neutral_face:

1 Like

After much deliberation, I think I have identified the sequence of events that leads to the disappearing mouse cursor.

If I leave the computer without logging out, eventually it will sleep and require a password to get back in to my desktop.
However, in the meantime, my son wakes the computer and sees it requesting my password.
However, he switches user to himself, logs in, does some work and eventually logs out.
I come back and find I am still logged in, but have to enter my password. I do so and get my desktop, but no mouse cursor. I can move the mouse up and it does activate the menu (though the mouse cursor is still not available). I manage to logout and then log back in, at which point everything is fine again.

A strange effect from a set of circumstances that has been common for the last couple of years. I don’t recall this happening on 14.04, 14.10, 15.04 or 15.10.


My tip there Steve is to simply log out and don’t use suspend or hibernate!. :smiley: (I hate screen-savers & hibernate functions but don’t ask me why?). :smiley:


I agree @wolfman. I sometimes just get up from the computer to get a cup of coffee etc., and get distracted by something else. Logging out is the answer. But it’s still a bug :smile:

1 Like

Just add it to the 2600 + something bug list @Steve!. :smiley:


1 Like

Yep, regardless of which of these similar issues we've been talking about lately, a great deal of them seem to have something to do with X.Org/LightDM, I am finding (either directly or indirectly).

With some of the cursor issues Compiz gets tangled up in the mix, but X.org stuff is always at play; and some of these same bugs surface on Marco anyway (I cannot speak for Compton).

Also, a large enough portion of the recent startup issues, blamed on the booting process, are really just easy LightDM tweaks; I know this from my own PC and laptop bug/fix adventures, as of late. :smile:

Anyway, @wolfman's tip to @Steve is golden: "simply log out and don't use suspend or hibernate;" because this wisdom prevents almost every one of X.Org/LightDM's relevant headaches! :innocent:


I’ve just experienced this while switching to my dummy user to try out something.
Got cursor back by switching to tty1 and back.
Using Marco+Compton (but if I read @lah7 correctly this is unrelated.)
I did a release upgrade from Beta2, not sure if that has the same kind of impact as any release upgrade.
I’m using Intel integrated graphics and if I need to edit xorg.conf as per @lah7’s recommendation to get it fixed I’ll do it.
However, has anyone located a valid bug report for this?


I’ve looked and can’t find a valid bug report.
My graphics are also Intel integrated.
This isn’t related to upgrades from Beta. My installation was completely fresh with the release that came out on 21 April.
I haven’t tried the xorg.conf edit yet, but will give it a go.

I think this is the bug report:


A bug report for a Ubuntu MATE 16.04 user reporting the same problem was classified as duplicate of this one bug.

Gonna mark myself as affected.