Double Lock Screen after installing unity desktop

Hi, So I installed ubuntu mate on my laptop and used it for a couple weeks and got everything working how i liked it. I decided to switch to unity for the time being however i didnt want to reinstall so I just installed unity over ubuntu mate. The problem is that I get prompted for my password twice. Once for the MATE login screen and once for the unity login.

Any ideas?

Thanks so much!!!

If for the time being means that it’s temporary remove unity

@pfeiffep thanks for the reply but I am probably going to end up using this as my main desktop environment

There are many experienced folks posting here :slight_smile:

Of course save your documents, pics, music etc and just install Ubuntu vanilla is another suggestion.

But if you’re not in a hurry just wait and I’m certain someone will have a more elegant answer.

Hi backspacer

Mixing Mate and Unity can work out very bad, looks like you got off cheap :slight_smile:

It sounds like your display manager (lightdm) which controls both desktops when you log in from boot.

But you may mean from lock screen, on the desktop its self. Which one?

First try a update and fix broken packages that can be found in the welcome screen in software, last tab.

1 Like

I’ll try that in the morning. A question however, if I choose to use unity, can I uninstall both and then reinstall unity?

The best way is to do a complete reinstall of whichever one you choose.

Hi @backspacerr,

I would have installed Unity Ubuntu first and then the Mate packages on top, you can do a fresh install and keep your data (possibly) intact if you follow this guide:

Thanks @wolfman , i’ll give that a try. I’ll backup my files anyways because i have my home drive encrypted and I dont know how it’ll handle that :slight_smile:

I suggest you don’t use encryption but that is my personal choice!. :smiley:

Thanks everyone for your help. I ended up doing a re-install. I have to reinstall and re configure all my applications and preferances but it is way cleaner like that.

Thanks again for the help :slight_smile:

1 Like

I figured this one out. The answer is in dconf editor.

  1. org->gnome->desktop->lockdown. Check the box “disable-lock-screen”. This will turn off the second log in screen but the screen will still go dark when you sign in, but you can dismiss it simply by hitting the keyboard. I was unable to find a setting that fixed this despite coming across several that appeared to.

The answe is very simple. For the unity desktop remove mate-screensaver from autostarts. For mate desktop remove gnome-screensaver from autostarts . I can’t test my solution couse if I installed them both I would get lots of unesesery dependencies installed I suggest adding this to your .bashrc in your home folder

if [ $DE == “gnome” ] || [ $DE == “unity” ]; then
pkill mate-screensaver
pkill gnome-screensaver

And finally if you do not have pkill
sudo apt-get install pkill


Yes it is, good choice :slight_smile: Please check your solution.


This worked well for me thanks!