Driver wifi Ralink RT5370

Hello every one.

I have been looking for days a driver for the following wifi dongle to work on Ubuntu Mate 15.10 in my Raspberry pi 2 but every solution that I have tried is worthless, I am really desperate to find a real and structured answer for this problem
this is the wifi dongle:

What I know about this device:
it uses MT7601U
Chipset Ralink RT5370
lsusb: "Bus 001 Device 004: ID 148f:7601 Ralink Technology, Corp. MT7601 Wireless adapter"

And these are some of the solutions I have tried:

Thank you for advance


connect to the internet with a network cable and then add this command via the terminal and then restart with the dongle plugged in:

sudo wget -O /lib/firmware/mt7601u.bin && sudo modprobe -r mt7601u && sudo modprobe mt7601u

If it doesn’t work first time, paste this command and restart again:

sudo apt-get update && sudo apt-get install linux-firmware

If that fails, connect to the internet with a cable connection and run the following 2 commands:

sudo apt-get --fix-missing install

The above command downloads and installs any missing packages on your system.

sudo apt-get --fix-broken install

The above command downloads and installs any broken dependencies on your system.

1 Like

WoW I am really thankful for what you have done for me today, the first line did all the job for me and now it is working fine, Wish you a very nice christmas and thank you again for what you do to help others.

1 Like

Excellent news, please mark as [SOLVED] so it helps others!. :smiley:

Merry Xmas to you and your family!. :smiley:

I followed commands and didnt get any error but wifi is still not working. Do i need to install network manager to configure wifi?


if you have a network cable connection, run "dpkg" per the update guide and see if that helps?: