DropBox on the encrypted drive does not work

Hi, probably most users have already found out that Dropbox does not work on encrypted drives in Ubuntu MATE.

I am curious if this bug is being fix or will it be fixed on Ubuntu MATE 20.4.

Thank you,


Can you please provide some more details or a link to a bug report?

I am using Dropbox in various versions of Ubuntu MATE with an Encrypted drive without issues.

Hi, franksmcb,

I am attaching a screenshot. It shows en error with pCloud. After having many similar errors I completely uninstalled DropBox.

The error with pCloud and DropBox was the same.

The error occurs when I click the "Open Drive" menu.

I found a script on internet that was supposed to change the privileges of the given directory but it did not work.

Hopefully you can help me.


So this issue effects more than just Dropbox.

Is this on your GPD Pocket 2?

Can you run this command and paste the output here using these tags </> tag.

inxi -Fz

If inxi is not installed please install it.

</> tag
Host: centurion-Default-string Kernel: 5.3.0-26-generic x86_64 bits: 64
Desktop: MATE 1.22.2 Distro: Ubuntu 19.10 (Eoan Ermine)
Type: Laptop Mobo: N/A model: N/A serial:
UEFI: American Megatrends v: 0.22 date: 12/07/2018
ID-1: BAT0 charge: 26.2 Wh condition: 27.0/25.8 Wh (105%)
Topology: Dual Core model: Intel Core m3-8100Y bits: 64 type: MT MCP
L2 cache: 4096 KiB
Speed: 700 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 700 2: 700
3: 700 4: 700
Device-1: Intel UHD Graphics 615 driver: i915 v: kernel
Display: x11 server: X.Org 1.20.5 driver: intel resolution: 1200x1920~60Hz
OpenGL: renderer: Mesa DRI Intel Amber Lake (Kabylake) GT2
v: 4.5 Mesa 19.2.1
Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel
Sound Server: ALSA v: k5.3.0-26-generic
Device-1: Intel Wireless 3165 driver: iwlwifi
IF: wlp1s0 state: up mac:
Local Storage: total: 593.20 GiB used: 13.50 GiB (2.3%)
ID-1: /dev/mmcblk0 model: DA4128 size: 116.48 GiB
ID-2: /dev/sda type: USB vendor: Generic model: SD MMC size: 476.71 GiB
ID-1: / size: 111.96 GiB used: 13.30 GiB (11.9%) fs: ext4 dev: /dev/dm-1
ID-2: /boot size: 704.5 MiB used: 195.8 MiB (27.8%) fs: ext4
dev: /dev/mmcblk0p2
ID-3: swap-1 size: 976.0 MiB used: 0 KiB (0.0%) fs: swap dev: /dev/dm-2
System Temperatures: cpu: 33.5 C mobo: N/A
Fan Speeds (RPM): N/A
Processes: 243 Uptime: 3m Memory: 7.70 GiB used: 1.10 GiB (14.3%)
Shell: bash inxi: 3.0.36
</> tag

I just posted the output from the infix -Fz command. I am not sure if used the tags correctly.

Hopefully, the output helps to track down the problem. To answer one of the previous questions - yes, all these troubles happen on GPD Pocket 2.

On the other laptop, I am using Peppermint OS 9 with no problem.

Just an FYI when you hit reply you will see some icons, the </> is the one I was referring to.
But we are still able to see the information.

I do not have access to a GPD Pocket to test but am able to test LUKS encryption and Dropbox without issues.

How did you install these applications?

Hi, both were installed via Synaptic.

HI, guys,

No one seems to care about this glitch any more.

So, no hope for me?

Should I ask for help elsewhere?

Thank you,


Here is what I found on this forum:

The BulletDust said:

Blockquote Bear in mind that Dropbox only supports unencrypted Ext4 now, nothing else, not even encrypted Ext4.
What file system are you running? > Blockquote

That post was made on August 2018.

At the same time, franksmcb says has that DropBox works on the encrypted ext4 drives.

Was the problem fixed since August 2018?

If so, what was the solution?

How can I apply it to my system?

Can anyone help me please?

Thank you,


Tried these scripts but they have not worked. Were they created to fix a different problem than mine?


Hi, all,

To narrow down the problem I have installed Ubuntu MATE 19.10 and Ubuntu MATE 19.10 for GPD Pocket 2 in the VirtualBox.

Both virtual machines have hard drives encrypted with LUKS.

Caja-DropBox installed on both Ubuntu virtual machines without a problem.

In both cases, raja-Dropbox works without glitches.

So, in case of GPD Pocket 2 there might be something hardware-related.

What is the best way to pinpoint what is causing the problem?

Please help.