Dual boot w/ Windows 7 and MATE 16.04 LTS fails on Compaq nx6325

Okay perfect, now let’s do the install.
I’m assuming you have a standard unmodified Live USB, if it’s not the case, please burn your USB stick again using the Ubuntu MATE 16.04.1 LTS .iso and unetbootin.

Please respect the following steps:

  • Unplug the network cable, we don’t want your machine to be connected to the Internet as it will use time for nothing doing the updates if the install fail.
  • Boot your machine using the USB stick into install mode
  • Check install flash, mp3 etc
  • Uncheck “Download updates while installing”
  • When it gives you install options pick “Something else” so you can edit the partitions yourself
  • Create the following partition layout using only the free space (Select the free space, then hit the gren “+” sign:
MountPoint  Type        Size
/           ext4        40000MB
            swap         3000MB
/home       ext4        [All Remaining Space]
  • Where it says “device for bootloader installation”, make sure “/dev/sda” is set.
  • Click install now and let it run, when it reaches shutdown if it gets stuck try the MagicSysRq trick I mentioned in the other thread

In case you encounter a problem, please note precisely the step you’re at and what the error message is (if any) and don’t take further actions, immediately stop and post about it here.


That’s not fair.
Installing Linux is easy when you don’t have to preserve an already installed OS and set up a dual boot. If it was possible to install Windows after Linux I’m sure it would be a headache too.

I’ve installed Ubuntu MATE 16.04 on a 32bit computer with lower specs than this one.

1 Like

First I was using rufus to create my live USB and it paused at a screen that had toe large white boxes one entitled Try Ubuntu, the other was Install Ubuntu

Using unetbootin it pauses at a screen that has lots of options of which Install Ubunto is one of the many options.

I made it to: [quote=“ouroumov, post:21, topic:7698”]
Create the following partition layout using only the free space (Select the free space, then hit the green “+” sign
[/quote]

At which point I could only do the very first one of 40,000MB. It created the partition, it showed up on the status bar, showed up in the list and that was it. I could not select free space again it just sat there. Was I supposed to enter them all at once or something? I don’t think I could, because the popup disappeared.

Remember I am a NOOB and don’t know what I am really doing. I will try it again in the morning and take a picture of the screen and send it.

What now?

Hi Fred,

take some time to read through the following guides and make sure you have followed all the tips please!:

For your disk install, did you follow this advice?:

For Unetbootin (USB stick):

And a complete (as best as I could put together) beginners guide:

Everything worked fine today. It booted off the live USB did not have the first error, showed the big blue screen with selections, I modified the partition layout as you said, ran to completion, prompted for a reboot and then the fist thing wrong happened. It totally shut down the fans, screen, USB access and SSD access, BUT it left the power light and the speaker mute light illuminated.

This is where I totally blanked on your above instructions “when it reaches shutdown if it gets stuck try the MagicSysRq trick” So, like an idiot I held down the power key for ~5 seconds and it turned off and then I hit the power key and it rebooted to:

error: attempt to read or write outside ‘hd0’.
Entering rescue mode . . .
grub rescue>

So I will reset to zero again and start over.
My really bad…
Be awhile, before I am back.

Wait. Don’t try and reinstall as it is, I think we’ve got a problem with your drive here.
If I’m reading this right, grub is saying that it’s attempting to write somewhere outside what he believes is the drive.
As in: grub might be thinking that the drive is 60GB and attempting to read something from around 70GB offset from the beginning of the drive.
I’m wondering if this is due to the imaging process you used.
Can someone weigh in on this? This is way outside my area of competence.

At this point I am just getting it back to the two partitions with W7 installed and booting off the first. I will stop there and wait for further advice.

Meanwhile Ubuntu has gotten its hands on the Broadcom board and now neither WiFi or Bluetooth work in Windows last time I checked.

That can’t be Ubuntu’s fault. Things don’t work like that.

Prior to trying this experiment, they both had worked since 2006. From XP to Windows 7
Now they don’t when I go back to Windows using my original drive.
Cause and effect are pretty strong in this case.
I would say that Ubuntu is setting some switches on the Broadcom card that Windows doesn’t look at.

I have turned the machine on and off probably 20 times during this episode. Sometimes with my original 120GB SSD drive, sometimes with my new 250GB drive. I clone my original W7 drive over to the new drive, so both drives should be identical. The WiFi and Bluetooth used to work with the original drive, they don’t now.

Yes, it could be failing hardware, BUT what are the chances that both of them failed to work under Windows, BUT I can get the bluetooth to work under MATE.

I am not trying to bash UM, I am desperately trying to get it to work and all the other people on this thread are doing their best also.

Have you checked your BIOS settings or did you make any changes there?:

Hi All,

I have backed off even further and have switched from the dual boot on an SSD to MATE installation on a normal HD. Maybe this should be a new topic, if any of you think so please move it; since I do not know how to do that.

I built my install USB with unetbootin (previously using rufus) used the i386 version because the nx6325 can only use 2.87GB of the 4GB ram. (Apparent bug in the BIOS, which they never fixed.)

Everything went according to plan (I did not do any additional partitioning) as I let the program handle the whole thing. BUT, when I got to the time to reboot to use your new system, it shut down with the power light and the sound off LEDs illuminated, as well as the hard drive spinning and the fan occasionally turning on to cool the system.

I went to the Magic SysRq key set as instructed by @ouroumov previously and it would not respond to any of the commands. I tried p, t and o both with and without the blue Fn key held down, always holding Alt and SysRq keys. So I gave up and held down the power key until it turned off.

I started it back up and it has been constantly accessing the HD with a black screen. It has been doing that the whole time I have been entering this message.

Then I restarted a live session and it booted up to the welcome screen. The only thing I did was have it find my Bluetooth mouse and then did a shutdown using the top right icon. It shut down normally.

Next I booted up again and chose Boot from first hard drive. It started loading and then executed lots of commands and ended up as below:

Notice all the errors. I am obviously totally lost.
Help, please. -- fey42 :confounded:

Hi Fred,

did you run a test of the USB first to see if there were any problems running it on your current device?, and if so; did you have any problems, please let us know!. :thumbsup:

Have you tried running “dpkg” (a network cable connection is required) per the update guide?:

I did not test it, since it is brand spanking new. But nothing hick-upped as it was installing. How do I do that, back in Windows or live? I have been reading your tome “Ubuntu beginners guide” and didn’t see that step. I missed it somehow.

Next, have I gone too far since I have not managed ever to establish WiFi from a live session? (from your guide).

Last my nx6325 meets all of the “recommended requirement” except it is a 4X3 screen with 1400X1050 resolution. Which most older laptops will have a 4X3 screen.

Thanks, Fred
PS, Just checked the USB in Windows (chkdsk) it was fine.

Just ran check disk from the Unetbootin splash screen and it was fine.

Sorry wolfman, I missed your post earlier. Yes I checked my BIOS settings and even changed them back and forth to cycle them. It did not help.

BUT, in the meantime in Windows 7 I have managed to get the Wifi backup and running. HP never wrote drivers for 7, so we have to use drivers for Vista. It reported that both the WiFi and the Bluetooth were turned off. Got Wifi up, but not Bluetooth yet.

Since I have dropped out the dual boot “need”, I’m not working on that now.

Do I need to do this since I am installing LTS and not updating?

Hi All,

It still does not show any WiFi networks available. I seem to be chasing my tail, since this is where I started out in a previous thread and went to installing instead vs. live USB thinking that might be the problem.

@larryb showed me the rfkill sequence to make sure everything is up, so I ran it and below are the results. Does this require a reboot or should it take effect after it is issued?

[email protected]:~$ sudo rfkill list
1: hp-wifi: Wireless LAN
Soft blocked: yes
Hard blocked: no
2: hp-bluetooth: Bluetooth
Soft blocked: no
Hard blocked: no
3: hp-gps: GPS
Soft blocked: yes
Hard blocked: yes
4: hci0: Bluetooth
Soft blocked: no
Hard blocked: no

[email protected]:~$ sudo rfkill unblock 1

[email protected]:~$ sudo rfkill list
1: hp-wifi: Wireless LAN
Soft blocked: no
Hard blocked: no
2: hp-bluetooth: Bluetooth
Soft blocked: no
Hard blocked: no
3: hp-gps: GPS
Soft blocked: yes
Hard blocked: yes
4: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
[email protected]:~$

Results of network search:
[email protected]:/home/ubuntu-mate# nmcli dev
DEVICE TYPE STATE CONNECTION
enp2s1 ethernet connected Wired connection 1
lo loopback unmanaged –
[email protected]:/home/ubuntu-mate#

I found this in the Official Ubuntu Documentation MATE 16.04: under Wireless network troubleshooting

“Click the network menu on the menu bar and make sure that the Enable Wireless setting is checked.”

I assume the menu bar is the bar across the top and the network menu is the symbol that shows whether you are connected. If so, there is no Enable Wireless setting to check. I also looked other places and could not find it. Perhaps the documentation is lagging the actual OS? Perhaps I am too dense to use MATE?

Some more leads to follow:

https://wiki.ubuntu.com/LaptopTestingTeam/Old/HPNX6325

2 Likes