Dual boot w/ Windows 7 and MATE 16.04 LTS fails on Compaq nx6325

I have Windows 7 on my Compaq nx6325 with an AMD Turion64 X2 (dual core), 3BG of RAM.

I first tried letting MATE (i386) do the partitioning, but the advanced formatting options would not come up. So I dropped back to Windows and did the partitioning there instead.

Booted into Ubuntu (from a live USB stick), did the install, chose the two update options at the beginning, answered all the questions (location, keyboard). Let it run
to completion and tried to shut down. It shut down, but left the power
button lit and the sound mute button on. I waited 5 minutes, with no disk or memory action – then

Held down power til it turned off, restarted and it never made it to the chose which OS. Instead I was greeted by
error attempted to read or write outside of ‘hd0’
entering rescue mode
grub rescue> _

Figuring I screwed up by forcing the shut down I tried it again and it shut down this time, but still the same error message.

Did a bunch of searching and found somewhere “it might be” doing the install from a live USB. So I tried installing with option 1 (updates I think) which gave me anther error – failed trying to update old packages – or something like that.

Next I tried option 2 – erase MATE and reinstall – which gave me the same error message.

What to do is my question to get past this?

Did you install MS Windows first and UM second?

If so, can you confirm the exact version of windows and UM and I will do a dummy run inside a virtual machine and see if there are any issues

On the other hand, if you have managed to install both of then, but grub is misbehaving, have you tried booting in with a Live Um disc and then installing and running Boot Repair?

You can install and run boot repair from a live session by typing the following into a terminal:

sudo add-apt-repository ppa:yannubuntu/boot-repair
sudo apt-get update
sudo apt-get install -y boot-repair && boot-repair

Make sure your live CD is the same architecture as your installed UM OS.

https://help.ubuntu.com/community/Boot-Repair

1 Like

Yes, I did Windows 7 Pro 32bit first and then i386 MATE 16.04 LTS second.

At this point I can’t prove I have either installed. I will fire it back up and try your “magic”

Thanks, Fred

The first two commands worked. the last one gave this:

Sorry, I just learned how to get the whole session.
Here is the total run:

[email protected]:~$ sudo add-apt-repository ppa:yannubuntu/boot-repair
 Simple tool to repair frequent boot problems.

Website: https://sourceforge.net/p/boot-repair/home
 More info: https://launchpad.net/~yannubuntu/+archive/ubuntu/boot-repair
Press [ENTER] to continue or ctrl-c to cancel adding it

gpg: keyring `/tmp/tmpdimxhp7p/secring.gpg' created
gpg: keyring `/tmp/tmpdimxhp7p/pubring.gpg' created
gpg: requesting key 60D8DA0B from hkp server keyserver.ubuntu.com
gpg: /tmp/tmpdimxhp7p/trustdb.gpg: trustdb created
gpg: key 60D8DA0B: public key "Launchpad PPA for YannUbuntu" imported
gpg: Total number processed: 1
gpg:               imported: 1  (RSA: 1)
OK
[email protected]:~$ sudo apt-get update
Ign:1 cdrom://Ubuntu-MATE 16.04 LTS _Xenial Xerus_ - Release i386 (20160420.1) xenial InRelease
Hit:2 cdrom://Ubuntu-MATE 16.04 LTS _Xenial Xerus_ - Release i386 (20160420.1) xenial Release
Hit:3 http://security.ubuntu.com/ubuntu xenial-security InRelease              
Hit:4 http://archive.ubuntu.com/ubuntu xenial InRelease                        
Get:5 http://ppa.launchpad.net/yannubuntu/boot-repair/ubuntu xenial InRelease [17.5 kB]
Hit:6 http://archive.ubuntu.com/ubuntu xenial-updates InRelease                
Get:8 http://ppa.launchpad.net/yannubuntu/boot-repair/ubuntu xenial/main i386 Packages [1,864 B]
Get:9 http://ppa.launchpad.net/yannubuntu/boot-repair/ubuntu xenial/main Translation-en [2,092 B]
Fetched 21.5 kB in 4s (5,187 B/s)         
Reading package lists... Done
[email protected]:~$ sudo apt-get install -y boot-repair && boot -repair
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  boot-sav boot-sav-extra glade2script pastebinit
Suggested packages:
  mbr mdadm clean-ubiquity boot-info os-uninstaller
The following NEW packages will be installed:
  boot-repair boot-sav boot-sav-extra glade2script pastebinit
0 upgraded, 5 newly installed, 0 to remove and 415 not upgraded.
Need to get 621 kB of archives.
After this operation, 2,831 kB of additional disk space will be used.
Get:1 http://ppa.launchpad.net/yannubuntu/boot-repair/ubuntu xenial/main i386 glade2script all 3.2.3~ppa1 [36.8 kB]
Get:2 http://archive.ubuntu.com/ubuntu xenial/main i386 pastebinit all 1.5-1 [14.6 kB]
Get:3 http://ppa.launchpad.net/yannubuntu/boot-repair/ubuntu xenial/main i386 boot-sav all 4ppa38 [416 kB]
Get:4 http://ppa.launchpad.net/yannubuntu/boot-repair/ubuntu xenial/main i386 boot-repair all 4ppa38 [11.5 kB]
Get:5 http://ppa.launchpad.net/yannubuntu/boot-repair/ubuntu xenial/main i386 boot-sav-extra all 4ppa38 [142 kB]
Fetched 621 kB in 2s (222 kB/s)     
Selecting previously unselected package glade2script.
(Reading database ... 202843 files and directories currently installed.)
Preparing to unpack .../glade2script_3.2.3~ppa1_all.deb ...
Unpacking glade2script (3.2.3~ppa1) ...
Selecting previously unselected package boot-sav.
Preparing to unpack .../boot-sav_4ppa38_all.deb ...
Unpacking boot-sav (4ppa38) ...
Selecting previously unselected package boot-repair.
Preparing to unpack .../boot-repair_4ppa38_all.deb ...
Unpacking boot-repair (4ppa38) ...
Selecting previously unselected package boot-sav-extra.
Preparing to unpack .../boot-sav-extra_4ppa38_all.deb ...
Unpacking boot-sav-extra (4ppa38) ...
Selecting previously unselected package pastebinit.
Preparing to unpack .../pastebinit_1.5-1_all.deb ...
Unpacking pastebinit (1.5-1) ...
Processing triggers for man-db (2.7.5-1) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu5) ...
Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20160415-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for mime-support (3.59ubuntu1) ...
Setting up glade2script (3.2.3~ppa1) ...
Setting up boot-sav (4ppa38) ...
Setting up boot-repair (4ppa38) ...
Setting up boot-sav-extra (4ppa38) ...
Setting up pastebinit (1.5-1) ...
No command 'boot' found, did you mean:
 Command 'brot' from package 'fortunes-de' (universe)
 Command 'boog' from package 'alliance' (universe)
 Command 'hboot' from package 'lam-runtime' (universe)
 Command 'boom' from package 'prboom-plus' (universe)
 Command 'boom' from package 'alliance' (universe)
 Command 'boom' from package 'doomsday' (universe)
 Command 'root' from package 'root-system-bin' (universe)
 Command 'booth' from package 'booth' (universe)
boot: command not found
[email protected]:~$

You added a space before the dash.

Hate it when computer do what I tell them and not what I want
Went through the gyrations and here is where I am.
I need to knock off and pick up someone at the airport.

The Configuring grub screen did not pop up

.

Okay, what do you say we start fresh?

Can you please:

  • Restore the drive from your Windows-only backup image
  • Resize, using Windows, the partitions to make room for Linux (Something like 120GB free space)
  • Boot the live USB, run the command lsblk in a terminal and give us the output of that command
  • While we’re at it, provide the output of the command: inxi -ACDSMNGI
  • Not do anything else

PS: I’ve edited the title of this thread to better reflect the issue at hand.

2 Likes

Hi @fey42,

have you also taken a look at the partitioning guide?:

See also (for pre-created partitions):

Restore the drive from your Windows-only backup image
Resize, using Windows, the partitions to make room for Linux (Something like 120GB free space)
Boot the live USB, run the command lsblk in a terminal and give us the output of that command
While we’re at it, provide the output of the command: inxi -ACDSMNGI
Not do anything else

Did all of the above.

Results:
[email protected]:~$ lsblk
NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT
sda 8:0 0 232.9G 0 disk
├─sda1 8:1 0 100M 0 part
└─sda2 8:2 0 119.1G 0 part
sr0 11:0 1 4.4G 0 rom /cdrom
loop0 7:0 0 1.5G 1 loop /rofs

[email protected]:~$ inxi -ACDSMNGI
System: Host: ubuntu-mate Kernel: 4.4.0-21-generic i686 (32 bit)
Desktop: MATE 1.12.1 Distro: Ubuntu 16.04 xenial
Machine: System: Hewlett-Packard product: HP Compaq nx6325 (EN191UA#ABA) v: F.04
Mobo: Hewlett-Packard model: 30B0 v: KBC Version 40.15
Bios: Hewlett-Packard v: 68TT2 Ver. F.04 date: 11/06/2006
CPU: Dual core AMD Turion 64 X2 Mobile TL-60 (-MCP-) cache: 1024 KB
clock speeds: max: 2000 MHz 1: 800 MHz 2: 800 MHz
Graphics: Card: Advanced Micro Devices [AMD/ATI] RS482M [Mobility Radeon Xpress 200]
Display Server: X.Org 1.18.3 drivers: ati,radeon (unloaded: fbdev,vesa)
Resolution: [email protected]
GLX Renderer: Gallium 0.4 on ATI RS480 GLX Version: 2.1 Mesa 11.2.0
Audio: Card Advanced Micro Devices [AMD/ATI] IXP SB4x0 High Definition Audio Controller
driver: snd_hda_intel
Sound: Advanced Linux Sound Architecture v: k4.4.0-21-generic
Network: Card-1: Broadcom NetXtreme BCM5788 Gigabit Ethernet driver: tg3
Card-2: Broadcom BCM4311 802.11a/b/g driver: b43-pci-bridge
Drives: HDD Total Size: NA (-)
ID-1: /dev/sda model: Crucial_CT250MX2 size: 250.1GB
Info: Processes: 168 Uptime: 13 min Memory: 273.4/2900.0MB
Client: Shell (bash) inxi: 2.2.35
[email protected]:~$

I am trying to see if Lunix has made it to the point of being a somewhat hands off install and so far it is not looking good. I am letting the “Install Ubuntu Mate” handle everything and it wouldn’t even partition the disk properly. I had to do it back in windows, which is very easy. I seriously want to get away from Windows…

Or else it is me not understanding the verbiage. Couldn’t be that :slight_smile:

I can honestly say I have found Ubuntu Mate to be a hands off install.

I already run a dual win7/UM dual boot, but I am also going to run this as a simulation in virtual box with the latest UM and video it and see if I can replicate any of your issues.

You can see this is an older machine and it is an AMD. In my research I read that if you want the best experience stick with Intel.

Besides this dual boot problem, it can’t find WiFi, loses the Bluetooth mouse, doesn’t shut down without throwing out an error message about some process still running, Firefox also has constant error messages about a non-responsive script, the fan runs constantly at high speed and MATE Terminal does not use standard keyboard shortcuts (why?).

This is from only using it sporadically for 2 hours. I have tried both live CD and live USB.

In my long years of experience running simulators they never give accurate results; they try to, but they fail. Nothing beats the real thing.

How old is your machine and what is its precise specification please?

Look back at message 10, I did a inxi -ACDSMNGI for @ouronmov

Okay, having looked up your model on a few sites, I would say. (though others may disagree), that your machine is pushing it to work well with Ubuntu Mate. If it were me, I would use Lubuntu. Indeed, I do use Lubuntu on both my notepad and laptop. The laptop being an old Acer Aspire and the Notepad being an Acer ONE. I use UM on my main rig.

I realize this is a side issue to your initial OP. But, I thought I would mention it.

I thought it would be a good one, since it handles Windows 7 32bit Pro absolutely perfect. From the “press” I read it sounded as though it would be fine. But I know nothing and freely admit it. Total Lunix NOOB.

ouronmov, wolfman would you both please weigh in on this. I do not want to beat a dead horse and be spinning every bodies wheels for naught.

Thanks for you opinion, let’s see if we get a consensus. I will switch, not a problem.

1 Like

Yes, definitely don’t just take my word on it. I am sure other will give their opinion.

We shall see.

So what is the major difference between the two or is that a hard comparison?

They both use a traditional desktop metaphor. However, with some light tweaking, Lubuntu can be made to look and feel like UM.

Lubuntu’s biggest drawback is that the main menu is well-nigh impossible to edit for a new Linux user. So, wherever Lubuntu decides to place your newly installed application in the main menu (which is usually a sensible choice, by the way), you will need to live with that choice.

In performance terms, Lubuntu is very lightweight compared to pretty much any other mainstream Linux distro out there which is why I run it on my old notepad and laptop.

See below for a short video I did for someone showing how Lubuntu can be tweaked to look and feel like UM