Dual Monitor NVidia Settings not persistent

Hi :hugs:
I have two monitors set up a Rog 3440*1440 and an LG 1366+768, both monitors are recognized correctly by the NVidia X server settings. At startup the LG, which is placed left in the set up, is always chosen as the primary monitor, which! results in severe screen tearing in the ROG. When I adjust everything in the server settings and save it to the xorg.config (which I had to create in /etc/X11), the changes are not persistent, still the LG as main monitor at startup.

Spend some hours mining Google but found no solution, please help, because it's quite annoying to reset it every time I start :roll_eyes:
PS : I`m a noob to Linux, but determined to get rid of Windows :face_with_hand_over_mouth:

Welcome! If it's just to adjust the primary display / position, the easiest way out would be to open Displays in MATE, make adjustments and click "Apply" and "Apply changes system-wide". No Xorg config faffing needed.

If this still causes screen tearing, then to eliminate this, a Xorg needs to be created but just needs to enable "Force Full Composition Pipeline".

There's a multitude of solutions here - I'm not sure what you've tried:

I would guess the Xorg file is being read, but something else "overrides" these settings later in the boot process. It's been a while since I had to mess with Xorg config files so I'm quite rusty with this.

One solution suggests unchecking "Include X Display Names in the Config File" and save again (both NVIDIA user settings and X config)

A workaround is to enforce these settings as soon as you login. This suggests pulling out data from the /etc/xorg/xorg.conf (that would be written) into a script file:

For example: /home/crispi/nvidia-login.sh

nvidia-settings --assign CurrentMetaMode="DVI-D-0: nvidia-auto-select +0+0, DP-0.1: nvidia-auto-select +1920+0, DP-0.8: nvidia-auto-select +0+0, HDMI-0: nvidia-auto-select +1920+0" 

Mark it as executable (right click → Properties → Permissions) and then add it to MATE's Start-up Applications.

1 Like

Thanx, I'll try it out :wink: