DVD playback in 16.04

How do I enable DVD playback in 16.04? Restricted extras installed and VLC is preinstalled, but I get this:

[email protected]:~$ sudo apt-get install libavformat-extra-54 libavcodec-extra-54 libdvdread4 -y; sudo /usr/share/doc/libdvdread4/install-css.sh
[sudo] password for self:
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package libavformat-extra-54
E: Unable to locate package libavcodec-extra-54
sudo: /usr/share/doc/libdvdread4/install-css.sh: command not found
[email protected]:~$

when I try to install the rest, it was different files going from 12.04 to 14.04 too

I get the safety-cone when I try to play a DVD in VLC

1 Like

Hi

Head over to the software boutique, section sound and video and install libdvdcss2:

3 Likes

Ah thank you, very much appreciated! :grin:

I am running 16.04 with the latest updates and that package is not listed.
Now what?

Try sudo apt install libdvdcss2 Fred. I think that libdvdcss2 was superceded by the Codecs Pack in the Software Boutique.

My present 16.04 Software Boutique version is 17.10.15~xenial1.1 and like yours, doesn’t contain libdvdcss2.

Just a heads-up, get all the things you need from software boutique BEFORE you do your first update, because the boutique no longer has some of these items afterwards…seriously disappointed with the Software Boutique…and it’s the reason I don’t have 18.04 installed on any of my machines

@mdooley That got me part of the way and then it started throwing more things to do, wouldn’t let me progress.

The last thing I tried was:

[email protected]:~$ sudo dpkg -reconfigure libdvd-pkg
dpkg: error: conflicting actions -e (–control) and -r (–remove)

Type dpkg --help for help about installing and deinstalling packages [*];
Use ‘apt’ or ‘aptitude’ for user-friendly package management;
Type dpkg -Dhelp for a list of dpkg debug flag values;
Type dpkg --force-help for a list of forcing options;
Type dpkg-deb --help for help about manipulating *.deb files;

I did something wrong, but no idea.
Thanks, Fred

See my reply to your other thread - No password == no updates 18.04

@fey42 So Fred, are you up and running in DVD land?

Nope, I am hung at my last step. I stopped trying to do it in 16.04 and switched to 18.04.

Well I’m sure that I’ll be seeing your posts a lot more. Good luck Fred.

You are right, cause here I am. Thanks for the post in No password == no updates 18.04. That solved the problem in one machine, the other seems to be a BIOS problem.

I am switching horses now to a philosophy question that has/is bothering me.

When Ubuntu arrives with pre-installed apps, such as, VLC, that don’t work they are doing a giant disservice to their new users. Yes, it can be made to work by switching over to terminal mode and entering commands, but why?

It is akin to going into the new car showroom ordering your new car and then discovering you have to buy and install the driveshaft. Or even worse, it is like you can only play in my sandbox if I will allow you and I give you the secret password.

Everyone on this forum has been so helpful in getting me up and running and I REALLY appreciate it. But “corporate” is hamstringing new users by pulling stunts like that. Plus let’s throw in the fact that previous fixes don’t work and you need the new secret “fix” it get it to run.

Do you have any idea why this mindset persists? Is this a Wimpy question?

Another giant mistake is allowing the install of 18.04, and maybe earlier versions, with no password required. Why would they allow that to happen? You can’t update the software to begin with and it goes downhill from there.

Obviously I don’t think I am whining, but maybe I am. I would love to see more users, but the learning curve is steep.