Enable automatic login in Ubuntu Mate 16.04 for Raspberry Pi 3

I would like to disable the auto login.

I have allegedly disabled it by going to

System -> Control Center

and under Administration I clicked on

Users and Groups -> -> Change button (next to the password)

and then I clicked on the radio button labeled Don’t ask for password on login.

However, I still get a pop up window showing my name and a “Log in” button
to press to full boot into the GUI. How can I get rid of this window and button?

Again, I am using Ubuntu Mate 16.04 on a Raspberry Pi 3.

Thank you ahead of time for anyone who can successfully help me through this.

I’ve encountered this before, I believe I solved it by entering a new (but different) password. Afterwards, change the password again and uncheck the “Don’t ask for password” option.

Then the greeter showed the text box for the password field.

1 Like

I apologize but perhaps I have misread your answer or you have misread my original question.

In the end I do not want a greeter asking for a password field. I would like the OS to boot directly into the UI with one of my logins without user interaction. This is important to me if I want to reboot the Raspberry remotely and have the LAMP server up and ready; the greeter in Ubuntu Mate 16.04 prevents me from doing this.

I apologize if my questions was originally unclear.

Ah. You mean you’d like to enable (not disable) automatic login? No login window, no password… See here:

This worked!

Thank you.



1 Like

That’s worked for me too on my odroid. Thanks Man!

This works great! Note (it seems), to put the autologin-user=YOURUSERNAME command on a new line, if I didnt it would fail to start in the regular GUI mode and would start in command line…which was not what I wanted.

That worked for me on Mate 16.04, Thanks!

I’m quite new here. I put on the same line and it stuck at ubuntu mate logo loading screen.
i would be appreciated if you could help me out.

I have the same problem as dope. After adding the line with my username to the /usr/share/lightdm/lightdm.conf.d/60-lightdm-gtk-greeter.conf file, it stucks at the ubuntu mate logo loading screen. Are they any solutions?