Files in Desktop folder not showing on Desktop

The title says it all. I have a number of documents and other stuff in the Desktop folder, but they are not visible on the Desktop.

Used to use Cupertino interface. have now changed to Ubuntu MATE to see if that would cure the problem but no. Still no icons. Any suggestions?

Could they be hidden behind another icon? I have seen this happen a few times.

This might sound silly, but try Mate Tweak>Desktop and make sure that Show Desktop Icons is checked. This happened to me once: I’d apparently accidentally unchecked it.

1 Like

Thanks, Jaybo, but no. There are no icons on the Desktop.

Thanks, Grenouille, but I already found that. It didn’t work. Sometimes when I click on a file in the file display program whose name I don’t remember (I’m answering from my Mac right now), all the files will come up, but not recently.

Hi @James_Wilde,

Going on a hunch, open ~/Desktop in Caja and drag an item onto your desktop. Does it show?

If not, move it to any other folder THEN drag it from there to your desktop. Does it show?

What happens on a new folder created on the desktop?

I’ve seen a situation like the desktop coordinates get screwed up so everything is off-screen if you get the idea. You might try removing everything from the desktop, boot with an empty ~/Desktop folder, see if it gets in sync.

Otherwise, it can also happen with another installed file manager set to “control your desktop” like Nautilus or PCManFM.

Thanks, Bill_MI. Your comment reminded me that once I had found my icons on another desktop - you know one can have as standard four desktops and choose them from an icon at bottom right. So I cycled through these four without finding anything now. Then I tested each of your suggestions.

Dragging from ~/Desktop, the file icon merely returned to its place in the folder.

Dragging from another folder gave the same result, but the file could be found in ~/Desktop.

I can’t create a new folder on the desktop. In fact when I right click on the desktop I get no menu at all.

Finally I created a new text file and tried to save it to the desktop. Again, it did not appear, but I could find it in ~/Desktop.

I like Ubuntu-Mate, which is how Ubuntu was before they started with the Unity interface, but it has to work without any hassle. One thing I haven’t tried yet, and that is to shut down the computer and restart (ie not a restart). That has sometimes solved strange problems.

I was wondering where ~/Desktop was defined as the location but I guess there’s no doubt the location hasn’t changed by your tests.

I run conky and it will remove icons behind it. Could something be running obscuring them?

F5 refreshes a directory including the desktop. Any flash of normalcy?

I’m wondering if changing things, like panel themes, regular themes or background images could snap things right. One in particular might be Caja’s Icon View default setting. The idea is see if some corrupted setting gets corrected/initialized.

Just thinking out loud hoping something may give it a kick.

Thanks for your continued interest, Bill. It is frustrating, but not - yet - critical. I can do things with and to the files by opening the desktop folder in Caja. I wonder if another file manager would act the same. Maybe I should try loading Nautilus. Trouble is, the point of placing files on the desktop is so that they are easily got at!

How stupid of me! Just tried installing Nautilus. Naturally I can see the files in ~/Desktop there also, but not on the desktop.

What is conky? F5 does nothing that I can see. As far as themes are concerned, I had Cupertino selected, but changed back to Mate Default when the problem became acute. My desktop background is the blue one with all the birds on it.

Hm, just going through the section on Look and Feel, came to Mate-tweak and went into Interface, went in to see the list of alternatives for Panel, selected Ubuntu-Mate and pop, up came my icons on the desktop. Strange thing is I know I did that yesterday, or was it the day before, for I changed from Cupertino back to the standard.

So problem solved, but I still don’t know what the problem was!

Later the same evening: They’re gone again! Tinkering with the theme doesn’t bring them back this time.

Conky places system info on the desktop. I see CPU, disk and network activity constantly. If I drag an icon to the conky area it disappears.

Did you try emptying out ~/Desktop? I still think there’s a poison value that might get eliminated if it starts empty.

Interesting you had it for awhile. I’m not the least surprised as I’m a traditionalist and will stay clear of most the themes and panels others say they use. Some look corrupted when they’re working right. :grinning:

1 Like

Hm, good idea, Bill. I hadn’t thought about that.

I created a new folder called ~/DT under home, and moved all my files from ~/Desktop there. Then I tried to drag one of the files from DT to Desktop. Wouldn’t go. Then I tried to drag a file from DT to the desktop. That wouldn’t go either. I guess I’ll just have to get used to opening Desktop - or DT since there’s no point in moving them back - when I want a file I use regularly or that’s easy to get to.

One other thing I might try: since I have the system on one partition and home on another, I suppose I could try updating the system partition, as long as I don’t lose all the bits and pieces I have added. I’m still on 16.04, so I could update to the newest version and see if it puts whatever is broken back the way it should be. I must admit I’m not so sure it will work. :worried:

Another thing which is strange: sometimes when I click one of the close/minimize/maximize buttons instead of the system doing what it is supposed to, I get a menu up, as if I had right-clicked on the button.

Wouldn’t go… you mean it didn’t move the file/directory?

Good convention, Desktop vs. desktop. I knew what you meant. :slight_smile:

Hidden files and permissions of ~/Desktop and contents.
Hidden: Ctrl+H toggle in Caja, ls -al in terminal.
Anything unexpected?

MATE Tweak “Windows Manager” change anything?

Wouldn’t go - yes, it allowed me to drag but when I dropped it, it returned to where it had come from. Hidden files, looked okay when I clicked it, but I must admit, I didn’t look at all the files. At the moment I’m testing a new installation which I had begun on an external disk some time ago, as I had some very strange events today with the installation we are discussing. Suddenly it gave up on networking. Have now got the usb version - also of Ubuntu-Mate - up and running and it is not showing any of the problems of the version on the internal disk. Networks ok. I can see an icon on the desktop. I can create a folder on the desktop. So I guess I’ll just have to continue configuring the version on the USB, and use that instead. I can always install the disk in the machine, or dd everything over when it’s working right.

It’s a PITA, as I have a good deal of extras added to the wonky version which I’ll have to look at and probably install on the clean one which is working. If you come up with any other ideas, let me know. I’m always willing to try something.

This suggests that your desktop is not being handled by caja. In MATE Tweak, be sure to have "Show Desktop Icons" check marked and, for good measure, check mark "Mounted Volumes" or one of the four others.

Really, this should work. Good luck JW.

Edit: Addtionally, check Preferred Applications in the System tab, your File Manager should be Caja.

Good try, MDooley, but no cigar. Caja is set as my default file handler, show icons is checked and all options thereunder.

But thanks anyway for your interest and suggestions.

Rats! No gold brass ring for me. If you’ve made notes on your install, I’d install again.

You have a second install on a non-fixed drive of some sort, don’t you? Comparing the two systems would be the way to go but would take an inordinate amount of time.

Hi @mdooley, I was looking for control of Desktop, too. It used to be a major setting but I don’t see it and I don’t think default filemanager is the same thing. It could be a figment of our past or the key to this problem.

For example, I usually install lean-and-mean PCManFM but it has no such setting like it used to.

See is you have all the keys in the “org.mate.background” schema

Opet the terminal and run

gsettings list-keys org.mate.background

You should get a list of keys like this:
show-desktop-icons ⠀⠀⠀⠀⠀⠀ << ⠀This is the key that handles appearance of the desktop icons

Check if the “show-desktop-icons” key is set to false

gsettings get org.mate.background show-desktop-icons

If it is false change it to true

gsettings set org.mate.background show-desktop-icons true

The icons should appear


Also you can check the mime-type

xdg-mime query default inode/directory

It is suppose to be “caja-folder-handler.desktop”

Thanks, Misco_2083. I did all this, and found that the value was true, and the xdg_mime thingy was as it should be. Then I had a stroke of serendipity. Although the gsettings get org.mate.background show-desktop-icons was true, I set it to false and then set it back to true and guess what happened: all my icons appeared. I don’t know how long it will last, but at least I can make them appear. So now I’m going to put this command in a file on my desktop ready to be used whenever it disappears.

So I think Misco_2083 gets the cigar, I can stop transferring all my files under home to a holding place whilst I do a full reinstall of both partitions, and then I’ll take another full backup.

I’ll wait 24 hours before I mark this thread as solved, in case it blows up again.

But my thanks not just to Misco, but to all you guys who gave me your 10 cents worth in the belief that it might be what I needed. It’s communities like this that make linux and ubuntu what it is.