Firefox 55.0.2 doesn't start crashes on Ubuntu Mate RaspberryPi 3

Hi guys, I really tried everything to make that automatically updated Firefox Version 55.0.2 run - no chance.

Workaround: Downgrade it to lower versions (i.e. 50 or 45) … you’ll find the files here: http://ports.ubuntu.com/pool/main/f/firefox/

1 Like

Same here, as soon as the upgrade was complete, FF crashed and will not launch.

Does any body have a quick quide on how to roll back to 52.xx.xx on a RPI 3 running ubuntu mate?

1 Like

I went to the link provided above. It is a bucket. Not sure what I was looking for exactly. I found 100s and 100s of files relating to FF. I figured it out eventually from file size. I knew that late versions of FF were pushing 50mb. Guess where they were! Of couse, at the very bottom where they belong. page after page of scrolling.

I installed firefox_52.0.2+build1-0ubuntu0.12.04.1_armhf.deb and it works perfectly.

1 Like

Here a small guide that I created that I hope will help others.

So the fix for the moment for me was to rollback to the last version before 55.0.x which is 52.0.2…armhf.deb

First! make a backup of your /home/(username)/.mozilla/firefox directory. This holds your profile, bookmarks, history, etc.

I assume you all know how to make a backup of a directory and even a hidden directory(from either the gui or cli) if not Google is your Friend

Now this is what I did to get back a working version of Firefox, (this is utilizing both gui and cli):

Launch Filezilla and go to ftp://ports.ubuntu.com (anonymous login), in the Remote site: window type in /ubuntu-ports/pool/main/f/firefox
if you don’t have Filezilla installed you can install it or use ftp from the CLI(terminal window).

Next scroll down and find firefox_52.0.2+build1-0ubuntu0.12.04.1_armhf.deb,(scroll to the bottom)
click and drag the file over your home directory(ex. /home/(username)/Downloads)
(If you use ftp from the command line I am assuming that you know how to make your way to the directory and file that I specified above and the commands to download the file.)

Open a terminal window and go to the directory that you use to download the file from above.

Now we have to remove the existing bad version of Firefox before we can install the package we downloaded…
sudo apt-get purge firefox

From the download directory where the firefox.xxxx.deb file is stored run the following command,
sudo dpkg -i firefox_52.0.2+build1-0ubuntu0.12.04.1_armhf.deb

After the dpkg was finished with the installation I launch Firefox from the command line.
firefox & while it was launching it complained about the language pack addons not being compatible… just ignore these messages, they are just warnings. Firefox should launch correctly
and open with the two default Ubuntu tabs. Close down Firefox and now
the icon for Firefox should have been installed on your Menu bar. Click on it to open Firefox again, but this time it should open with your profile so your bookmarks and preferences should still be okay. (For me
this was the case.)

3 Likes

A few days ago I encountered this issue with FF 55.x.x. Relatively quickly I found the fix and rolled it back. Since then, I have been having a related issue. Not sure if I should start another thread.

One day after rolling back FF to 52.0.2… FF crashes and exhibits the same issues as 55. With a little examination I find that it is 55! How did that happen? I have all updates turned OFF. I mean ALL! In order to avoid this very thing. My system has never auto updated EVER. Auto checking and updating has always been turned off.

So I find that there is an apt function called unattended-upgrades. I have never paid much attention to it. Never configured or disabled it. It has a white-list and a black-list. From reading the logs, it apparently triggers any time it wants to but about once per day. It happened yesterday and again a little after 6am this morning I get this:

2017-08-21 06:12:32,399 INFO Initial blacklisted packages:
2017-08-21 06:12:32,402 INFO Initial whitelisted packages:
2017-08-21 06:12:32,403 INFO Starting unattended upgrades script
2017-08-21 06:12:32,404 INFO Allowed origins are: [‘o=Ubuntu,a=xenial’, ‘o=Ubuntu,a=xenial-security’, ‘o=UbuntuESM,a=xenial’]
2017-08-21 06:12:53,892 INFO Packages that will be upgraded: firefox
2017-08-21 06:12:53,898 INFO Writing dpkg log to ‘/var/log/unattended-upgrades/unattended-upgrades-dpkg.log’
2017-08-21 06:14:06,478 INFO All upgrades installed

Now, what I want to know is, Who the hell decided that FF needed to be updated every day? Especially when FF 55 is broken and causing wide spread havoc on RPI platforms. How is it possible that some ■■■■■■■ slipped in a script during some previous upgrade or patch to make sure that my system was updated every day? Is there no one that makes sure that this crap is not passed through to every user in the world with out approval? That is an unacceptable security risk. I decide what is installed on MY computer. Why is there a mechanism allowed to over ride my choices without notification? What a great way to propagate a virus!

Solution: sudo apt-get purge unattended-upgrades

I have had to roll my system back 3 times now. I am thinking it won’t be necessary tomorrow.

Thanks for all the above. I’ve got a working firefox back again.
Except now google drive is minus lots of options, and AFAIK unusable.
If I understand, now firefox is telling google drive (the online thing) that I’m on a mobile, so all the menus & options I had (image 1) are missing (image 2). I understand there’s an installable app for android that does all that, but not for RPi.
If I remember correctly, the old (or newer but faulty) firefox presented google drive OK.
It may well be more appropriate to start a new thread, but the problem is a spinoff from this one, so unless I’m advised otherwise…
Any ideas how to tell the google servers that the firefox is not on a mobile?
https://drive.google.com/open?id=0ByOoBxsh1lLPdXJ0WlU2ZEpvVFU
https://drive.google.com/open?id=0ByOoBxsh1lLPTkNjYmx1R09zNWM

It’s somewhat reassuring that others have these problems - I rolled back 2 installations which had the FF55 rubbish, and while using one of them it has frozen twice (cannot get anywhere either by monitor or SSH). I haven’t looked yet to see if it has now updated to FF55 - but fear it has.
I was finding the software and updates to be rather well concealed - it’s been a while since I needed to get at things, and memory is failing.
Derek

This’ll be a messy report, covers a lot.

I booted RPi Mate today and started ffubuntu0.12.04.1. It instantly crashed. I purged ffubuntu0.12.04.1. I reinstalled the official ffubuntu0.16.04.1, that crashed. I purged it, & reinstalled ffubuntu0.12.04.1 again, it works again. But FF still tells google servers that it’s a mobile.

Chromium instantly crashes, says ‘aw, snap’ for both internal & external pages. That seems to be a memory error, see


Tried midori, that shows google drive ok, but the right click activates midori menus, not google drive menus.

So, I’m on a quest for a browser that works on RPi Mate and uses google drive like a desktop.

Hmm…, hint: useragents

Well I’ve put a user agent switcher onto firefox, and firefox is telling google drive that it’s a desktop. So my page works properly.
https://addons.mozilla.org/en-US/firefox/addon/user-agent-switcher-firefox/
(there are a few, the one by “Linder” does work)
And I’ve re-booted and ff still works.

I had the same problem on Kubuntu 14.04 (Me and the other 4 Linux PCs in the office). I found the crash was caused by something in the profile (It worked with a new profile) but opted by downgrading to version 54, keep my profile and keep waiting for a fix from Mozilla.
But today I upgraded again to 55 in my PC, and after some testing I got it running with my profile just deleting cookies.sqlite database file:

[email protected]:~/.mozilla/firefox/kn5ilk3u.default$ rm cookies.sqlite*

I can’t guarantee it works for anybody, your mileage may vary.

I also tried to determine if I could avoid deleting the entire cookie repository by deleting certain cookies but I was unsuccessful. Anyway having to log again in certain site or something is a minor issue.

1 Like

Update to the tutorial.

While this issue still plagues us, we all still need to be able to
update our pi boxes for security patches and software updates.

There is a way to block firefox from being updated.

Run the following command: sudo apt-mark hold firefox or sudo aptitude hold firefox

This will block firefox from upgrades.

Note:
When a new working release becomes available you can unblock package updating with:
sudo apt-mark unhold firefox or sudo aptitude unhold firefox

Let’s hope a new working update becomes available soon.

1 Like

Someone reported the bug on launchpad:

https://bugs.launchpad.net/ubuntu-mate/+bug/1714616

Please mark yourselves as affected.

The true question is why in the hell are updates installed without prompting the user?

Feel free to complain about this by marking yourself as affected on the bug report I raised about this issue:

https://bugs.launchpad.net/ubuntu/+source/unattended-upgrades/+bug/1700930

Absolutely right! I read your bug description. It was clear and precise. Thank you. I am not familiar with that forum or its personalities.

I have 25 years as a network security consultant and my feeling was less technical and more angry. As you will see in my comment under yours. In my never humble opinion, our Ubuntu over lords have clearly made a policy decision to protect us from our selves. In doing so, they have violated our trust and introduced a vulnerability - though unintended.

Has anyone noticed in Software & Updates that “Security Updates” has been greyed out. They have disabled our ability to turn them off from this interface. On a windows system, when you turn off Automatic Updates - they are in fact, turned off.

I have experienced the same under many prior versions of FF. I think they have a memory leak which eventually will crash FF and often take the whole system down.

Thanks, this helped a bunch!

Perhaps this helps? I ran:

sudo apt-get install firefox=45.0.2+build1-0ubuntu1

this had ‘apt’ downgrade the firefox install – sadly to 45 which is just slightly past the dark ages…

It gets around any of the warning/incompatability messaging as it is actually in the armhf repo.

The error has been reported to Mozilla:

but it doesn’t sound like it will be fixed anytime soon. From the link above:

Wow! That is sad. And, Ubuntu is still pushing 55.0.2 on all updates to RPI users. Why don’t they just back it off until a fix arrives?

Thank you for your post, there’s an easier way to get this .deb file:

wget -c https://launchpadlibrarian.net/313439025/firefox_52.0.2+build1-0ubuntu0.16.04.1_armhf.deb

but I do like that clarity and honesty, don’t expect google to fix it, use the various workarounds