Firefox 66.0.3 disabled my Zotero extension - now using Brave browser instead

software

#1

Hello

This morning when I started my computer Firefox (Firefox version 66.0.3) had disabled the following privacy extensions:
(a) HTTPS Everywhere {EFF Technologists}, (b) Privacy Badger {EFF Technologists}, (c) uBlock Origin {Raymond Hill}.

and the following productivity extensions:
(i) Zotero Connector {www.zotero.org}, (ii) Unpaywall {Impactstory team} [used together with Zotero].

I am now using Brave (thanks to @Wimpy for making the discovery and installation so easy {it is in the Internet section of the Software Boutique}). :slightly_smiling_face:

I installed the Zotero Connector for Chrome and it seems to work. :slightly_smiling_face:


AdBlock on firefox
Mozilla Addons Problem discussion not found
#2

All of my extensions in Firefox are dead as of this morning. This includes:

Ad Block plus
Facebook Purity
Privacy Badger
Pushbullet
VideoDownloadHelper
Youtube Adblock

Just like that. Out of the blue. No warning.

Screw Firefox


#3

Looks like they have problems.


#4

Yeah I was waiting for that to hit since I got a heads up this morning.


#5

Since it's a certificate issue I hope they can fix that without having to roll out a new version of the browser.


#6

Too late. They have been limiting and disabling extensions for some time now on a more limited scale. This is just the final straw for me.


#7

Okay...

So, I downloaded Waterfox. I had no need to "install". I don't know if this is because I already had Firefox installed.

This is what I did:

  1. Downloaded and extracted Waterfox folder and placed in my home folder
  2. Double clicked the Waterfox executable file in the folder.
  3. Waterfox GUI opened and asked if I wanted to import settings from another browser. I chose Firefox to import from.
  4. Waterfox browser opened with all of my extensions that were previously disabled in Firefox, fully installed and enabled. Plus, they had also all remembered all of their individual settings.

That's me sorted.


#8

I have always been a little hesitant and confused about all the Firefox forks... are they safe security wise?

I mean almost all of them has security patches that lag behind the original Firefox don't they? :confused:


#9

As I wrote earlier - other possibility is to use Firefox ESR 52.9.0 - all my installed extensions are in place (even after reboot) including LEGACY ones. This Firefox version did not receive security updates, but works as I expect:

But I can't install any new extension from https://addons.mozilla.org .

To fix current version of Firefox you can use temporary solution from Fabby at AskUbuntu:

Oh, it's easy: just open a new tab and go to about:config and filter on signatures.required and double click both of them to turn them from true to false:

and the nasty red turns into a fine yellow:

Which allows me to move on (for the moment until a signed version of both addons is released)

Updates:

  1. just tested the above fix, it works with my Firefox ESR 52.9.0, I can install addons from addons.mozilla.org.
  2. Using Firefox ESR 52.9.0 is my personal preference, use it only if you need LEGACY addons and VLC plugin.

#10

I had no issue with Firefox 66.0.3 (64bit) and its extensions today:

  • convert2mp3.net
  • Cookie AutoDelete
  • Disconnect
  • EPUBReader
  • Firefox Lightbeam
  • Flagfox
  • KeePassXC-Browser
  • Open Tabs next to current
  • Privacy Badger
  • Startpage.com
  • Tab Deque
  • The Camelizer
  • uBlock Origin
  • Undo Close Tab Button

Running Ubuntu 18.04.2 LTS (need openJDK 8 and openJFX 8, therefor no update to 19.04):

  • wake up from hibernation at about 07:00 AM (GMT), all extensions were working
  • read the information here: https://bugzilla.mozilla.org/show_bug.cgi?id=1548973 after reading this thread
  • restarted due to new Linux Kernel 5.0.12 installation at about 12:00 PM (GMT), all extensions were working

Did I miss something? Not that I really miss the issues reported here :slight_smile:

Please do not understand me wrong: I'm sure there were a lot of users affected by the issue but presumably not all. Don't panic, the issue will be solved soon / is already solved. No need to switch browsers in a hassle :slight_smile:


#11

Looks like they rolled out a fix, uBlock Origin has just been reactivated on my browser.


#12

Hello

I re-installed the extensions by activating "Studies" as detailed in ouroumov's link.

The extensions seem to be working as expected. :slightly_smiling_face:

Many thanks to all involved in bringing us the information and the fix. :clap:


#13

The fix is coming. In the meantime, here's what I did...

The check and disabling seems to occur if Firefox is open. If you're lucky enough to not yet been disabled, copy ~/.mozilla and restore it to get extensions back for a while. It's like a snapshot before extensions were disabled. I get about 5 minutes.

EDIT: Yep, enabled Studies and just waited. It eventually fixes things.


#14

This fix works on Desktop. Anyone know how to fix on Android?


#15

The fix did not work for me, and on twitter they said that the fix is not working well for every one and they are still on it.

Anyway what I did and worked like a charm to find back ALL my extention and the theme
in about:config I set xpinstall.signatures.required to false then all addons were back and just re-enable my theme
Done
I will set back xpinstall.signatures.required to true when they will have the problem fully fixed which should be in 24h-2 days..

If you want to follow them on twitter and see the progression => https://twitter.com/mozamo


#16

the effect of the bug will disable your addons the 2019-05-04 before passing to 2019-05-05
:wink:


#17

They did not do it on purpose, And actually they are working hard to fix it.
Error is human :wink:


#18

OK, issue started on my PC :frowning:
Set xpinstall.signatures.required to false as a workaround.
Will set xpinstall.signatures.required to true once the issue is fixed.


#19

So new improvement and it worked for me:
Mozilla patches via the studies channel, so what I did now (to be able to set back xpinstall.signatures.required to true) I went in my Prefrences / Privacy & Security (or just copy this in the url = about:preferences#privacy ) and I checked the "Allow Firefox to send technical and interaction data to Mozilla"

Then I closed Firefox, wait 1 minute, open it again and wait that the "MATE Netspeed" (the applet which give you the internet upload and download speed) shows 0B/s in download (as when I re-open FF it automatically uploaded the fix via "studies")

Then I set back xpinstall.signatures.required to true and what a good surprise, everything stayed (all my addons and theme).
Personally, I have disabled the studies ("Allow Firefox to send technical and interaction data to Mozilla") after that, as I will get the final fix via the usual update's channel of FireFox


#20

OK they got their final fix https://twitter.com/mozamo/status/1125146829660786688 and a new version of FF is out (v 66.0.4) for both desktop and Android

If you have implemented some workaround as I did in the beginning ( for example xpinstall.signatures.required), don't forget to set them back to their default setting :wink: