Forum appears to not track most recent posts


feel free to move to a diff forum

when you click on your right hand image after logging in,
you get to see, I think the most recent responses to your replies?
I will call this my reply list

I have previously missed a reply in the past and not thought too much about it, but today I saw it re-appear so reporting it in case someone can work what is going wrong?

Not sure how to duplicate it to test it but
click on your replies and compare to most recent posts.

here is a screenshot no need to click it please but proof of what I am saying

Evidence follows
Using my reply list, today, it thinks my most recent reply is

which is one day ago

But using latest reply list gives me

OP replied 11 hours ago and does not appear in my reply list.

any clues?

1 Like

@aus9, I have same issue on other discourse page's too. I think the issue is just with how discourse handles notifications.

yeah well if that is a means I can not be lazy and just click me
instead I will have to click latest posts or unread posts
but me thinks I will stay with latest.

I can't mark it as solved as the issue appears to not be fixed.

Replies only show up as notifications if:

  • Somebody directly replied to you (as in, somebody used the "Reply" button next to your post, as opposed to the green topic "Reply")
  • Or, you're "watching" that topic.

It'll say at the bottom:

You will receive notifications because you are watching this category.

By default, Discourse will "track" a topic after 4 minutes of reading or if you reply - so it shows unread counters for that topic in topic lists.

You can change the behaviour in your User Preferences ā†’ Notifications:

When I post in a topic, set that topic to

option not found in settings

but option found in individual post. Maybe mods have diff settings?

so for me, one of my posts was showing as tracking
I click it and can change it to watching

Also I used the green button......most of the time.

I will try to pay more attention to see that its is showing Watching from now on

thanks for the heads up


post is solved

No problem. The preferences to change the default behaviour should be there:


you are right I was clicking in the wrong notifications section.