Fresh install UM 16.04 on laptop can't find available wi-fi networks

I just installed U-M 16.04 on my HP laptop (7 years old). I need to set up the wi-fi, but I can’t find the available networks. I removed Linux Mint18 to install U-M 16.04, and when I installed it,it was easy to find the available networks and get online.

I’m Stumped…It doesn’t take much…

Any help would be appreciated.


Please provide the output of the command:

inxi -N

xxxxxxxxxx-Compaq-Presario-CQ60-Notebook-PC:~$ inxi -N
Network: Card-1: NVIDIA MCP77 Ethernet driver: forcedeth
Card-2: Qualcomm Atheros AR242x / AR542x Wireless Network Adapter (PCI-Express)
driver: ath5k

Thank You

ive had the similar problem with my acer laptop before found out it was been blocked.

trying running this command to see if its report anything blocked.
sudo rfkill list all

Hi Cybermax

-Compaq-Presario-CQ60-Notebook-PC:~$ sudo rfkill list all
0: hp-wifi: Wireless LAN
Soft blocked: yes
Hard blocked: yes
1: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no


Just as an experiment … let’s try blacklisting hp_wmi and seeing if that makes a difference.

Open a terminal window

gksu pluma /etc/modprobe.d/blacklist.conf

and add a single NEW line at the bottom that reads:-

blacklist hp_wmi

SAVE the file


Open a terminal window

sudo rfkill list all

Hello What am I to do with the info you gave me. I’m new at this stuff, and I’m older… :fearful:

  1. Open a terminal window
  2. Enter gksu pluma /etc/modprobe.d/blacklist.conf
  3. An editor window willl open.
  4. Follow the further instructions provided by @CyberMaxpower
1 Like

OK, I may be able to help. @CyberMaxpower gave you instructions that will stop RFKill from turning off your wmi module; (Soft blocked: yes). Do that as @orschiro says and reboot. If it still doesn’t work, enter
sudo rfkill list all
again. If it still says Hard blocked: yes, that usually means that your laptop wifi switch is turned off. I don’t know which key it is on your particular model, but it should be F10, F11 or F12. It will probably have an orange light on it(meaning OFF). Press that once and the light should turn blue/white after a moment (meaning ON).

1 Like

Thanks orschiro, I did all that and the wifi icon appeared on the panel. I still can't see available connections. The blue light has always been on for the wifi. My wifes and my tablet, and TV work fine with the Wifi.

Sending photo of my situation now. I'm not sure who to or big_duck. I don't use forums much, which is real apparent.

It says that Wi-fi is disabled... etc.

Thanks for the help so far. You too big_duck

PS is SSID the network name or the key code?

Not up with this type of thing.

Apparently the wireless adapter is disabled by default at install. Read this, it should help you.

That did it!!! :grinning:

Thank you so much big_duck, and all the other folks that helped.


Thought it was solved :confounded: I can now see my network listed, but it will not connect.

I think I should be able to see all the networks around me like on my tablet, but my network is the only one available.

Help :sob:

OK, maybe try this:
Restart the network manager -
systemctl restart NetworkManager
Make sure wifi is not turned off again-
rfkill list all
Show interfaces -
ls /sys/class/net
Pick out the wireless adapter device name, probably something like wlo1.
Bring it down-
ip link set dev <devicename> down
Release the DHCP-
dhcclient -r
Then bring it back up-
ip link set dev <devicename> up
Scan for networks.
iwlist <devicename> scan
Pick out the network you want, we’ll need the ESSID, Frequency and Address.
iwconfig <devicename> ap <access point mac address>
iwconfig <devicename> essid <ESSID>
iwconfig <devicename> freq <frequency>
dhclient <devicename>
You should get an IP address from your access point and connect after that last command.

Hello big_duck…thanks for your time in this endeavor.

I apologize for being backward. I don’t know if I am to use the terminal or pluma or ? for the the above instructions. “bring it down-” means ?? “bring it up” means ?? I’m totally lost with your directions.

I’m not as geeky as I would like to be.

Thanks for being patient.



Sorry for the delay…My car just died yesterday…Please continue to help me


You would press ctrl+alt+t to open a terminal window.
Enter those commands one by one.
Add sudo before each command.

Bring it down and bring it up means turning the wireless adapter off and on with terminal commands.

OK big_duck…

Everything is working now. Thank You, and all that I tortured during this post.

Solved :grinning: