GPD Pocket 1 & 2: Ubuntu MATE 18.10

system

#1

I figure we’re going to be a small community here, so I’m not sure we’re worth a subform like the RasPi, but I wanted to get a thread started on issues we see with MATE on the GPD Pocket 1 or 2. I didn’t see anyone else posting about their device.

I seem to be able to install MATE with no issues, but booting seems to be hit-or-miss. On some boots I just get a black screen, pressing CTL+ALT+DEL quickly flashes the MATE logo. Other times, if I leave it long enough I’ll be dropped to the Built-In EFI Shell. I have tried using efibootmgr on a Live USB to edit the boot options, but no luck there. Also edited the options through the BIOS with the same results.

Anyone else with any issues or tips for running MATE on their Pocket 1 or 2?


#2

@Wimpy take a look and stay awhile.(needed to have 20 characters to tag you :)))) )


#3

I’m here with my Pocket 1. Though since I updated the BIOS last time around, it hangs on boot unless I can get into the menu to trigger some disable or another. (Not Ubuntu, but rather the BIOS itself hangs before it boots anything).

I’ll be listening eagerly to this thread for updates, and hopefully I can actually use my Pocket for something, someday. :grin:


#4

We may have a solution from the GPD Pocket subreddit:

I just found a solution. DO NOT install third-party drivers on setup. Seems kind of obvious in retrospect, those drivers will mess with the ones the Mate team included to solve Pocket quirks.

Makes perfect sense & I'll hopefully be able to test it out this morning. I wasn't intentionally installed third party drivers, just meant to install the non-free codecs. Nice that it sounds like a simple fix for us.

EDIT: Unfortunately this doesn't seemed to have fixed the problem for me. I did not install third-party software & additional media formats during setup, & I still get the black screen & pressing CTL+ALT+DEL briefly flashes the MATE logo & prompt for my disk encryption password.


#5

Hi,
I found a solution on reddit which has solved the problem for me.

  1. edit the file /etc/default/grub (try something like ‘sudo nano /etc/default/grub’ in a terminal)

  2. add the following lines to the file:
    GRUB_GFXMODE=1200x1920x32
    GRUB_GFXPAYLOAD_LINUX=keep
    GRUB_CMDLINE_LINUX=“acpi_osi=Linux”

  3. save the file, and return to the command prompt and run ‘sudo update-grub’

Worked for me, hope it helps someone.

BTW. I love the gpd pocket image! Thank you ubuntu mate team. This image runs better than windows 7 and solves the lackluster support of linux provided by GPD. THANK YOU!


#6

Thanks. I’ll give that a shot.

After making that change, have you tried running updates? I was starting to wonder if that could be causing out problem. Even though we don’t install 3rd part drivers, I’ve been wondering if they come down with updates.

EDIT: So it definitely seems to be related to one or more of the updates that come down either through apt-get or aptitude. After running updates, I stop being prompted for my disk encryption password & just get dropped back to the EFI Shell.


#7

Hi, I selected 3rd party packages during install, and have run updates. After the changes to the GRUB config file I have no problems. BTW, I’m running the original GPD pocket with the unlocked BIOS.


#8

Thanks. I thought I had the unlocked BIOS, but maybe I do not. Working on getting that running, then can give MATE another try,


#9

Hi!

I just tried this image using a GPD Win. It worked great the first few times, but after that it just boots into a black screen as described above. I was about to try the suggestion above, adding a few lines to grub, but since I can’t reach the system at all I can’t add them. Is there any way to add them directly in GRUB when booting?


#10

@mp035

Thanks for the info, on my Pocket 1 this fixed the boot issue.

FWIW before this fix it seemed the times it booted to black I could just type in my password and then the desktop would appear.


#11

Hi, I’m in a similar situation with a GPD Pocket 1. Can I ask what an Unlocked BIOS is, and whether I need it?
I’m getting the black screen after bootup and, as I’ve read here, I get a brief glimpse of the LUKS password prompt if I press ctrl+alt+delete. I haven’t found a way to actually log in yet, though.
I’d be grateful for any pointers.
Thank you.


#12

I’m seeing the same. First install on my GPD Pocket (1), using full disk encryption. First boot, the screen is black. ctrl-alt-del flashes the logo and encryption password prompt. When I type in my encryption password in the blind, nothing seems to happen. The screen stays black. ctrl-alt-del does nothing after that. On the power key, the red LED is slowly flashing (seems to never get fully charged) and the white LED is not lit.

@mp035’s grub changes made the screen visible again. (Had to boot into recovery in order to edit grub, working sideways).

Note that I see two kernels already listed in the grub menu, both with recovery options. The rev number difference is minor.

Installing the latest software updates now. (What is “linux-firmware” in the Updater list?) Screen is still working correctly. So, @mp035’s fix works before and after update. Super!


#13

I see that there’s a large misalignment between the cursor and my finger when I touch the screen. is it possible to calibrate this?


#14

Thanks for the feedback. I’ll see if I can give this a shot tonight.

If I can, I’ll let you know if I see the same thing with the misalignment.


#15

Thank you, @v3ritas. I wonder if the problem is that the digitizer coordinates are not rotated in alignment with the display, because the separation varies dramatically horizontally for different points on the screen. I know they are supposed to be aligned according to the announcement of the release.


#16

Got pulled into some works stuff so only reinstalling now.

Have you tried putting the screen orientation back to default (90 degrees counterclockwise?) just to see if the cursor & finger line up that way?


#17

Good idea. I tried that, putting the display back to normal rotation, and they are way misaligned. So, that was not a good guess on my part.


#18

i rebooted and he alignment good now. works through sleep/wake, too. Only change I’ve made is related to fixing it for sleep/wake, not the original problem. Those are in /etc/default/grub hanges described elsewhere in this community (I think).


#19

I’ll give that a shot tonight. I was able to finish a clean install last night, but just hangs at a black screen, no backlight. May have been battery related but can rules that out tonight.


#20

I think I’ve figured out what the alignment trouble is in my case: it goes out of alignment when I connect an external monitor to the HDMI port.

Edit: when I subsequently unplug the external monitor, the alignment does not return to the correct setting. But, when I log out and back it, the alignment is then correct.