Grub: Change the wait time to zero

Hello,

I’m having a problem with Grub do Ubuntu.
Ubuntu is in dual boot with Windows, and I would like to leave the standby time as 0 (zero), I already edited the Grub file I was able to change to 1 (one) second, but for 0 (zero) I still could not.
When I set 0 (zero) to restart the standby time is in 10 (ten) seconds.
I edit the file again and put 1 (one) again and this time is right.

The line I change is this:
GRUB_TIMEOUT=1

Maybe I need to change some line, but I do not know which one.

Note: whenever I make any changes use the command:
sudo update-grub

Thank You.

Hi @Lynx,

take a look here:

1 Like

Hi @wolfman,
Thank you for the link, I’ll check.

2 Likes

Hi Lynx

There you will find a good thread about grub2:

@wolfman: I don't know if this does answer the question, but I guess it could be helpful.

2 Likes

Hi @Atreju,

the link you show also has the link I posted above included in it (at the very bottom of the guide) but not to worry!. :smiley:

2 Likes

Hi @wolfman

I know, but in the community-thread I appreciate the details in the discussion. :slight_smile:

2 Likes

Here’s a really nice explanation of what you want:

https://ubuntuforums.org/showthread.php?t=2210008&p=12951149#post12951149

2 Likes

Hi,

You can set a shorter delay by using .01, or even .001, so quick you probably won’t notice GRUB options!

Reason 0 (zero) setting doesn’t hide GRUB options, 0 = ‘use default’, as you discovered, default is 10 seconds.

3 Likes

Many thanks everyone for the tips.

2 Likes

With the tip of @DaveB I was able to solve the problem.
I thank everyone.

1 Like