How to show grub menu in Ubuntu with only a single OS installed

system

#1

MAKE A BACKUP COPY OF THE GRUB FILE BEFORE YOU START, IF WHEN YOU RUN “SUDO UPDATE-GRUB” AFTER AND IT FAILS, REPLACE THE FILE YOU CHANGED WITH THE ORIGINAL COPY!.

WARNING, DO NOT TRY AND EDIT THE “GRUB” FILE USING LIBREOFFICE, ONLY USE THE DEFAULT TEXT EDITOR LIKE PLUMA!. ONLY CONTINUE IF YOU ARE CERTAIN EVERYTHING IS IN ORDER!.

Like the title says, if you only have Ubuntu (Mate) as a single OS on your PC/Laptop and you want to see the Grub menu all the time at boot time, follow the next few steps.

1: Open Caja (Nautilus or whatever folder manager you have with the following command, substitute caja for your folder manager):

Press Alt+ F2 and enter the following command:

gksudo caja

(For Ubutnu: gksudo nautilus) (for Kubuntu: kdesu dolphin or konqueror) (for Xubuntu: gksudo thunar) (for Lubuntu: gksu pcmanfm)

Enter your password when asked and your home folder will open as “root”:

Click on “File System > etc”:

default”:

grub”:

2: Now the grub file is open and you can edit it, you only need to edit 3 lines, it is that simple!. This is what your current file (with only a single OS installed) should look like when you first open the grub file:

Now add a hash sign (#) in front of the word GRUB on line 7 so it looks like this: #GRUB_HIDDEN_TIMEOUT=0 and change true to false on line 8 so it looks like this:
GRUB_HIDDEN_TIMEOUT_QUIET=false

Now go to line 31 and change “true” to “false” (type as written!) so it looks like this: #GRUB_DISABLE_RECOVERY="false"

Once done, click on “Save” and close all open windows. (DO NOT SAVE THIS FILE AS ANYTHING BUT A NORMAL TEXT FILE!. IF YOU GET ASKED TO SAVE AS AN ODT FILE, CANCEL THE SAVE AND CLOSE WITHOUT SAVING AND THEN RE-OPEN THE FILE USING PLUMA OR YOUR STANDARD TEXT EDITOR, IF YOU DO SAVE THE FILE AS AN ODT FILE, YOU WON’T BE ABLE TO UPDATE GRUB ANYMORE. YOU HAVE BEEN WARNED):

3: Now open a terminal (Ctrl + Alt + t) and enter the following command:

sudo update-grub

and close all windows and restart your PC, you may have to restart twice before the full menu shows without having to press the “Shift Key”!.

You should now see the the menu:

I hope it helps!. :smiley:

See also:


Recover the start logo
Grub: Change the wait time to zero
How do I get into the grub menu during startup
Startup error with xserver-xorg-core
Primary Mouse Click Disabled. Why
'Starting Caja' Loop
Ubuntu Mate Update Guide
Grub 2 misconfigured during initial UM 16 32bit install
Ubuntu Mate 16 Intro Load Fail Nvidia
Grey screen on startup?
GRUB terminal console mode error
Confused about grub updates!
16.04 failed to load Braiille support and kernel modules
#2

Hi wolfman, thank you for your instruction! I have the contrary case: that means, I’ve only one OS on my laptop, but grub is shown every boot. And I dont like this so much. The settings are allmost in every step of your guidance by default. The only difference is, the hash (#) symbol is staid at line 7. Should I remove the # to make unseen grub by booting?

Thanks


#3

Hi,

if you have a full Grub menu and you don’t want it, then I assume that by having no hash (#) sign in line 7 would do the trick!.

Make a copy of the file before you start editing in case things can wrong, you can replace the edited file with the original you save if things do go pear shaped!. :smiley:

Here is the original file at the start of part 2 of the guide and this is what you are aiming for!:

What version of Ubuntu Mate do you have?, I did the above on UM 15.04 Beta 2 on my laptop as the only OS!. :smiley:


#4

Thanks, my UM version is 14.4.2. For making copy of grub file, do I need root, or is this not necessery?


#5

Hi,

yes!; do it as root and simply save it in the main root folder, like I said, you never know!. :smiley:


#6

Thank you! I will try and give you a feedback than. :smiley:


#7

Hm…doesn’t work! I followed your instructions in all points (root, pluma and update and reboot twice) but grub is still showed by booting…


#8

Hi Atreju,

to have the standard (don’t show Grub at boot) that I had when I started without a Grub menu (Ubuntu Mate 15.04 Beta 2), you should have the following settings:

Line 7 should be = GRUB_HIDDEN_TIMEOUT=0

Line 8 should be = GRUB_HIDDEN_TIMEOUT_QUIET=true

Line 31 should be = #GRUB_DISABLE_LINUX_UUID=true

Please make a screenshot of your current setup if the above doesn’t work for you as they are the only setting changes I made!.

You should have the same as this which is what I started with before any changes:


#9

Hi wolfman,

It seems, it’s working now. I updated grub again and after a reboot, grub has gone.

Thank you much!


#10

No problem Atreju, I’m glad it worked out for you!. :smiley:


#11

thanks wolfman, it’s work. First time i use libreoffice to edit grub text, and then everything misbehave. After that i copying grub text from another ubuntu-mate laptop. edit it with pluma and it’s work. thank you very much :slightly_smiling: