HDMI audio not showing [21.10]

On Raspberry Pi 4, the HDMI audio is not showing as an option in sound settings. Normally it would show as "analog audio", but there's no option for that, only the 3.5mm jack. How can I get my HDMI audio back?
Screenshot at 2021-11-26 07-59-10
Edit: I did try uninstalling and reinstalling pulseaudio, and that didn't seem to fix anything.

Hallo ,
same here. First i install a normal ubuntu21.10 and Mate with apt. It works some weeks. After a reboot the hdmi sound output is not there. The Testscreen at boottime shows 1360x768 HDMI and when im booting a PiOS it worked.
I also tried a brand new ubuntu-mate21.10beta1, but no HDMI sound
Perhaps its a pulse thing because when i had this issue in the past i press the force_restart of Jack in Cadence, then all Audiodevices got resetted and then i was able 2 choose hdmi via pavucontrol/pulse. But this is not working anymore since the last upgradereboot.
Now i use Bluetooth Speakers beside the TV :frowning:
I know that there is 4 sure some hardwarebug because there are HDMI Sound Problems for a long time.
Now i try 2 figure out pipewire

Update: I just tried doing a complete reflash of the OS, and after updating and upgrading all my packages, I'm back to square one with the exact same issue.

My update: In the past there were problems with several Ubuntudistros. After big Problems with Ubuntu21.10 , where Freezes takes all of the joy 4 this wonderful OS i found the solution here: Ubuntu Budgie 21.10. There was a hint on the website that the config.txt has 2 be modified from kms to fkms and the everything was ok. So now i decided to check out budgie again. But the result was annoying anyway.
no sound. no digital hdmi output
But i was remembering that i had this issue since 20.10 and i thought about the hardware issue i mentioned in the first thread.
I connect a normal DVI screen to the other hdmi and tataaaaa: Sound works. But this time everytime when i turned of the hdmi TV, hdmi switch to the other screen. This was new issue in 21.10 but now i can handle it. I install ubuntu-mate via apt and now everthing is ok.
Before i tried the second DVI screen with the SD Card with fresh Mate21.10 from this website, but no sound.
Also, i m now fan of budgie because of the tweak-tool which i miss on the Mate.
I hope u can follow me.
Also i write the config.txt with the hdmi group 2 and mode 39 with the right solution for my TV.
Now i m very happy
On my second pi with 2gb i run the budgie with xfce because budgie takes much more ram.

Changing "dtoverlay=vc4-fkms-v3d" to "dtoverlay=vc4-kms-v3d" in /boot/firmware/config.txt worked for me. HDMI appears as IEC958:

That strangely doesn't work for me. It seems to make a difference, but not a good one. Upon changing the config.txt, the pi would just lock up every time when booting. Even disabling the overclock didn't fix it. I had to change it back to "dtoverlay=vc4-fkms-v3d" in order for it to boot again. So now I'm just back to square one. And I know there's no hardware issue because PiOS works with audio as well as MATE Focal. This issue seems to be isolated to Impish. And even impish itself seemed to work until I updated all the packages. I just want to find a want to fix Impish as I don't want to switch back to Focal for reasons.

I found it is to do with the kernel 5.13.0-1010-raspi and 5.13.0-1011-raspi.
if I reflash the kernel back to 5.13.0-1009-raspi, by
sudo flash-kernel --force 5.13.0-1009-raspi
the 'built-in audio stereo analog output'will comeback to live until a new update kernel replace it.


I actually had to download the image first using "sudo apt install linux-image-5.13.0-1009-raspi", but after that, running the command worked and fixed it. Thank you.


So there is some problem with kernel version 5.13.0-1011?
Since the drivers are usually stored on the kernel and when I ran inxi -MSA it didn't show any driver for HDMI audio.
I have had the same problem with 21.10 and I noted I had HDMI audio before doing a sudo apt full-upgrade and upgrading the kernel up to 1011.
Another problem I have had is when trying to compile from source code, the Raspberry freezes, I wonder if other people have this problem and if it's also related to the kernel version 5.13.0-1011
I wonder if it's possible to force the kernel version on a GUI program like Synaptic, to keep the system from upgrading to 1011, but keep updating other packages as usual?
Thanks for your help

Interesting. I have 5.13.0-1011 kernel installed and hdmi sound works without any issues. I only changed fkms to kms in config.txt.

on my pi 400, the audio randomly shut off, and in the settings it said everything was working normally. I used another device on my TV and it worked, so it wasn't my TV, I shut down and switched to the pi OS and it worked too, meaning it has something to do with the OS. btw im on 21.10

What kernel are you on? To check go to Menu --> System Tools --> MATE System Monitor --> System, and you should see something like this.

mine looks the same as yours besides the disk space (but disk space is probably different for everyone)

Gotcha, so kernel 5.13.0-1011 for some reason breaks hdmi audio on raspi, so what you're going to want to do is to flash 5.13.0-1009 instead. To do this, first run "sudo apt update", then "sudo apt install linux-image-5.13.0-1009-raspi". Then after it's done installing, run "sudo flash-kernel --force 5.13.0-1009-raspi". Then reboot. Hdmi audio should return. Alternatively, you could also connect bluetooth speakers if you wanted to as bluetooth works as well.

Edit: Some people also reported that changing "dtoverlay=vc4-fkms-v3d" to "dtoverlay=vc4-kms-v3d" in the config.txt worked for them, it personally just make my raspi not boot the OS and I had to change it back to "dtoverlay=vc4-fkms-v3d". Your mileage may vary though, that's just my experience.


it worked! thanks, ill note this for anyone else with the same problem.

I only had 1 audio device after fresh install. I tried the .cfg changes to get HDMI...no dice. I had been waiting to hook up the cheap amazon usb sound card, but when I did I have like 4 audio devices and I now can select one that sends audio over hdmi but is listed as spdif. So I can switch between the usb card and my tv as outputs :slight_smile:

1 Like

I was not able to find a bug report filed on this. I was able to get a hold of a Pi4 that I could test on for a short time and was able to confirm this.

I've filed a bug on this. Please click on "effects me" on the bug report and hopefully this can get some visibility.

1 Like

I got the new 5.13.0-1013 update installed and that didn't fix anything. Reverted back to 5.13.0-1009.

Note that nowadays kms is the preferred default, not fkms. For me HDMI audio with kms and 5.13.0-1013-raspi works just fine on MATE. But HDMI audio does disappear with fkms which I need to look into.

1 Like

Thanks for looking into this Juerg, it's much appreciated.

I can confirm that when switching to kms and using the -1013 kernel HDMI audio is available.
So fkms does seem to the culprit.