HELP - Help Debug/Fix Kernel Panic Error

Hey Ubuntu MATE forums! I wanna start by saying that I'm completely new to Linux in its entirety. I usually have no idea what some of these big words getting thrown around here actually mean, but I'm loving it so far - until recently that is.

I just experienced my first kernel panic. I'm horrified to be completely honest, and I while I've been told my data and customization should be okay, just the thought of losing the hard work I put into this damned thing AND all my data is making me feel sick to my stomach.

Let's cut to the chase.

-I have no idea how to debug these panic messages - they're all a jumble of text to me
-I have no clue what could have caused it or how to fix it (obviously)

Here's what I do know. I first felt something was off when I was trying to add a repository to install p7zip through the terminal. Things weren't as snappy as they usually are, and after adding the repository (assuming it was successful) I did the usual sudo apt-get update

Here's I got the first error. Then things on my desktop weren't responding, the terminal kept giving the same error (that I cannot recall) when I tried to do anything, then closed all together. I then tried to restart, which seemed to be normal. Then I saw this single line:

/dev/sbd5: clean, 399075/2960588 files, 15731001/118397169 blocks

-and nothing else. But the taunting blinking cursor. I assumed there was more so I walked away and got some snacks. When I returned I learned that nothing happened, so I casually restarted the machine. When it started, I was greeted with the familiar GRUB menu. Then I got a kernel panic when I tried to boot into MATE that looks like this:

If anyone can understand this blob of text and help me resolve the issue, that'd be great. Any and all help is appreciated.

Thank you.

try to boot with a different kernel.

reboot your pc then press esc or shift and select advance options.

Hey, thanks but I already tried with the other kernels I have listed here. Still get a kernel panic that seems to be similar - if not identical to the one i got before.

Hi @GameSpate,

try running “dpkg” per the update guide (network cable connection required):

Ubuntu Mate Update Guide :smiley:

This seems like it could work, but the catch is I can’t get into recovery mode. I get a kernel panic either way.

If you have a separate root and home partition, try the following: