Help with AMD drivers, ubuntu 18.04

Hi, first a disclaimer - I'm a total linux newbie, and not a HW person at all, so maybe some questions I ask might sound dumb, but please bear with me.
I'm trying to set up an old laptop for kids, one of the main goals being that they can play Minecraft together. We already have a Windows 10 laptop they use, and Bedrock edition of Minecraft there, so Java edition wasn't an option.
So far I managed to install Ubuntu Mate (which seems to work quite good), and I installed the launcher that I found here: After some initial problems, I got it working, but the game runs really slowly, and the troubleshooter in the game says it's due to software rendering.

The laptop is an HP 6560b with AMD Radeon HD 6470M.

The launcher wiki suggests this:

For integrated graphics and most AMD GPUs (and maybe Nvidia on nouveau) - sudo apt-get install libegl1-mesa:i386 libegl1-mesa-drivers:i386

Since half of the time i don't understand what I'm doing here, I just tried running what they said, but I got an error saying there's no such package.

After some more googling, I found these instructions on how to install AMD drivers:

I followed what it says there for open source drivers, except the part about editing xorg.conf end enableing DRI3, because I can't find xorg.conf in the directory /etc/X11/xorg.conf.

I have no idea if that would help, but so far the game is still really slow, and the troubleshooter still says the same thing (slow because of software rendering).

This is what I get in command prompt then running lspci: Advanced Micro Devices, Inc. [AMD/ATI] Seymour [Radeon HD 6400M/7400M Series] [1002:6760] (prog-if 00 [VGA controller])

What else I can try, any ideas?

You need to add i386 architecture support:

sudo dpkg --add-architecture i386 

Then do

sudo apt-get update

followed by

sudo apt-get install libegl1-mesa:i386 libegl1-mesa-drivers:i386


I've tried that, but when I run the last command, it says:

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package libegl1-mesa-drivers:i386

What am I missing?

the main problem is that your hardware is not 32 bit but 64 bit architecture.
Forget postfix :386 in package names.
Please find proper package names by invoking command:

apt search libegl1

It will give something like this:

libegl1/eoan,now 1.1.1-0ubuntu1 amd64 [telepítve, automatikus]
  Vendor neutral GL dispatch library -- EGL support

libegl1-mesa/eoan,now 19.2.1-1ubuntu1 amd64 [telepítve, automatikus]
  transitional dummy package

libegl1-mesa-dev/eoan 19.2.1-1ubuntu1 amd64
  free implementation of the EGL API -- development files

You won't need "dev" packages.
Your result should be different a bit, since I am on 19.10.

Still no luck.
I'm starting to wonder if this launcher was meant to work on my configuration at all :slightly_frowning_face:

So I've tried running:

apt search libegl1
Sorting... Done
Full Text Search... Done
libegl1/bionic-updates,now 1.0.0-2ubuntu2.3 amd64 [installed]
Vendor neutral GL dispatch library -- EGL support

libegl1-mesa/bionic-updates,now 19.2.1-1ubuntu1~18.04.1 amd64 [installed]
transitional dummy package

libegl1-mesa-dev/bionic-updates,now 19.2.1-1ubuntu1~18.04.1 amd64 [installed]
free implementation of the EGL API -- development files

Then I called the following (tried it both with and without postfix):

sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get install liebgl1 libegl1-mesa

Something did get installed, but the game still says that it's using software rendering. I tried restarting (where I get another issue, the computer doesn't boot properly every time, I get black screen and have to turn it off and on several times before getting to login, don't know if that's related), no change.

I tried purging oibaf drivers that I installed earlier, didn't help.

Should I install it all from scratch? Would that make a difference? Can I run some diagnostics to see what's wrong? Or some other app to see if it's the launcher maybe that has the issue?

Minecraft uses 32 bit libs. Minecraft says to try -

sudo apt install libegl1-mesa-dev:i386

The line with "drivers" was for Ubuntu 16.04.

You shouldn't need the "dev" libs but you can try them if Minecraft is still using software rendering.

sudo apt install libegl1-mesa-dev:i386

Another Minecraft user says they used

sudo apt-get install libegl1:i386

for Ubuntu 18.10



I've tried different things, nothing helped.

However, I did run some diagnostics mentioned here:

Among other things there's a line saying:

[ 2.363541] [drm:r600_dma_ring_test [radeon]] ERROR radeon: ring 3 test failed (0xCAFEDEAD)
[ 2.363545] radeon 0000:01:00.0: disabling GPU acceleration

It is the same error I get when booting the system and it goes to black screen. I found a similar issue described here:

So, I would like to try changing grub settings, but can't enter recovery mode. When during startup I choose the option with "recovery mode" in the name, the computer goes to a screen with some artifacts and stops booting:

Any ideas how to get past that?