Hibernation broken in kernel 4.13.0-25

Acer Aspire X3-710
Ubuntu MATE 17.10 (fresh installed a few days after release)

After updating to latest kernel, the system won’t wake up from Hibernate. Advanced boot options shows that it decompresses the files on the swap partition and afterwards the keyboard / mouse are deactivated and the monitor goes into power saving mode.

When booting with kernel 4.13.0-21-generic hibernate and wake up from hibernate works fine, as it did over the last 14 months running Ubuntu MATE 16.10, 17.04 and 17.10 until now.

I’ve also done an Intel microcode update (using the intel-microcode_3.20180108.1_amd64.deb file from http://ftp.us.debian.org/debian/pool/non-free/i/intel-microcode/):
dmesg | grep microcode states microcode updated early to revision 0xc2, date = 2017-11-16 (don’t know why the difference in dates).

Log file viewer does not show anything in the “boot.log” and power management logs are not listed at all in the left-side navigator.

I’ve searched for possible solutions or at least any information stating that this may be a regression or that it will not work at all, but cannot find anything.

I’m sooo sad… hibernate is one of the features I use since WinXP and I really cannot imagine living without it :slight_smile:

Any hint or information are welcomed

OK, Hibernate (respectively wakeup from Hibernate) is completely broken with Linux Kernel
I’ve tested:

  • fresh Ubuntu MATE 17.10.1 installation on separate PC
  • Linux Mint 18.2 on separate PC
  • Linux Mint 18.3 on separate PC

Looks like Hibernate worked flawlessly up Linux Kernel (or 4.13.0.x older) for all PCs.

Good news (is it ?) - Suspend works - but this is not an option for a Desktop-PC that is down for over 12 hours a day.

New kernel received via Software Update => Hibernate, respectively Wake Up from Hibernation is still broken.

What I’ve done:

  • installed ukuu
  • installed kernel version 4.14.15
  • tested hibernate and wake up from hibernation => hibernate works as expected

The only reason for returning to kernel was Oracle Virtualbox 5.1.x and 5.2.x that did not run using kernel version 4.14.15. Everything else worked as expected.

Looks like I have to wait for Ubuntu MATE 18.04 (3 months or so - looking forward for the new version :slight_smile: )…

  • moved on to kernel 4.14.15.
  • installed Virtualbox 5.2.6 including the Extension Pack
  • sudo apt-get install libelf-dev
  • sudo /sbin/vboxconfig

Tadaaaa, Virtualbox is running as expected.
Due to kernel 4.14.15 hibernate respectively wake up from hibernation is working as expected.
My issue is solved.

Suppose Ubuntu (MATE) 18.04 will use kernel 4.15 (or 4.14). Therefor will mark this issue as solved (even if the initial issue - hibernation and wakeup from hibernation using kernel 4.13.0.x with x >= 25 - is still open.

I have the exact same issue running mint 18.3 natively where my system did not boot after hibernation. This report here helped me out. Thanks for that. Booted into grub and tested hibernation with all installed kernel versions on my system.
All kernel versions where hibernation did not work: