How To Activate Ubuntu Login Sound

system

#21

There does need to be a space after the paplay command and the path to the ogg file. That might cause problems for some. :slight_smile:


#22

Hi, @ieh, like this?

paplay/usr/share/sounds/ubuntu/stereo/desktop -login.ogg

(with a space between desktop and -login)?

Thanks! :sweat_smile:


#23

Actually, the command should be as follows:

paplay /usr/share/sounds/ubuntu/stereo/desktop-login.ogg

The command is paplay, and the single parameter is the sound file including the path. :smile:

(It’s correct in the original image, but the text was wrong)


#24

@ieh BINGO! :joy:

Utter magic for a newbie; thanks, friend!


#25

@wolfman: Well, my trusted confidant, I am getting the login sound now - WOW - :yum: - and without boosting my Alert volume. Yep, it’s still stuck on reverting to zero on each close; but so far, that has proven irrelevant. For instance, all of my event sounds seem to play, as they should, via the main auxiliary speakers. Perhaps, there is an override/setting forcing the Alert volume all the way down to zero; due to the way the speakers are set up… just a newbie supposition, of course :blush:.

Thanks for the community effort on this - very cool when it unfolds as such, no doubt. :smile:

Also, wolfman, just so you can keep track of everything, pertinent, I was able to try this above tip, at issue, prior to installing your sound-tool-terminal-command:

sudo apt-get install libsox-fmt-all sox paman

Do you think I may still need it for other uses? :dizzy_face:

Thanks, as always!


#26

Thanks @ieh,

I have edited the command to reflect the real command, I don’t know how I did that as mine works fine but like you said, does have a space in it!. :smiley:


#27

Hi @mated ,

it won’t hurt any if you have installed the packages, they might prove useful for something else!. :smiley:


#28

@wolfman: Whoops, I just edited in some more info…:scream: up above…

“For instance, all of my event sounds seem to play, as they should, via the main auxiliary speakers. Perhaps, there is an override/setting forcing the Alert volume all the way down to zero; due to the way the speakers are set up… just a newbie supposition, of course :blush:.”


#29

@mated,

I think that that is just one of the “broken things” in Ubuntu, I don’t have an answer for you sorry!. :frowning:


#30

This missing space was probably unavoidable, @wolfman, without knowing at least. When I copied & pasted ieh’s command directly into the Startup Apps menu it took the space out. For reference, I copied & pasted into Pluma and it kept the space. I’m thinking that it auto corrects, maybe, on the Startup Apps menue; but that the text editor keeps it true… just another newbie supposition, of course :blush:."


#31

I don’t know how the space got taken out?, you may be right about auto correction as I was sure I pasted the correct command the first time around because it worked for me!. :smiley:

Thanks to @ieh, I corrected the command so there shouldn’t be any problems in the future! (said he hopefully!). :smiley:

Here is the original command copied from my backup docs of interesting Linux things and as you can see, there is a space after the first part of the command!:


#32

At least in the Ubuntu 14.04 32bit installation that I have,

/usr/bin/canberra-gtk-play --id=“desktop-login” --description=“GNOME-Login”

works as shell commend but not as a startup application item setting.

I used the following in the setting and it worked:

/usr/bin/canberra-gtk-play -f /usr/share/sounds/ubuntu/stereo/desktop-login.ogg


#33

Hi and thanks, I have included your command in the above thread starter!. :smiley:

I noticed there was a couple of extra empty spaces in the command at the beginning and have edited it so hopefully both commands will work now!. :smiley:


#34

Hi wolfman,

I am wholly used to my login sound now, and would no longer feel my OS was complete without it :yum:; thanks!

My month with Xfce was tough - due to the fact that those guys feel that silence is golden (they seem to enjoy bugs more than we do, here, too :smiling_imp:).

By chance, is there a way to get a logout sound, in our mix, as well?


#35

Hi mated,

just use the same method as described above!. :smiley:


#36

Right after my reply to you (this string about logout sounds), I put this one together (below). I logged out/in and only the login sound activated; but I have yet to reboot. Fingers crossed then, if the below command is what you advise, @wolfman! :sweat:

[ paplay /usr/share/sounds/ubuntu/stereo/desktop-logout.ogg ]

Thanks! :smile:


#37

Hi @wolfman,

I still want a logout sound but, unfortunately, [ paplay /usr/share/sounds/ubuntu/stereo/desktop-logout.ogg ] is not getting it done - like it does with the [ -login.ogg ] command for login :cry:.

Am I doing it wrong, by chance? :sweat_smile:

Thanks!


#38

Hi @mated,

I really must learn to read peoples threads correctly!. :confused:

All I can find for “Logout Sound” is this:

and:

http://forumubuntusoftware.info/viewtopic.php?f=7&t=9182

I have never bothered so I don’t know if it works?. :smiley:


#39

Thank you for finding these! I’ll give um a whirl; thank you @wolfman:laughing:


#40

Late to the party, but tried the Mate 14.04 version in my Ubuntu-MATE 15.10 and it works fine, so haven’t felt the need to use this line:

sudo apt-get install libsox-fmt-all sox paman.

Thanks for the info. Now where did I put my Windows 7 startup music? :wink: