How to install the PulseAudio equalizer which works

:closed_book: I am retiring this thread, and I highly encourage someone to package this software for use in Ubuntu. As I am finished with this thread, also finished should be this software, and I hope in the coming weeks there will be a package for 3.0.2 in the case people prefer this software Debianized.

:ubuntu_mate: In later versions of Ubuntu, apt functions in place of apt-get where applicable.

:ubuntu_mate: Introduction

The version of PulseAudio EQ which Ubuntu has by default sucks. I mean, it sucks, good and proper. There are several disadvantages I've found with it compared to the older EQ users had been installing via PPA before the "Official" PA EQ came into the fold;

  • It does not work immediately after installation
  • To prevent from needing to invoke modules manually, needs to be modified
  • When removed after making it become invoked automatically, it breaks PA until previous changes are reverted
  • When functional, it cannot cope with multiple audio sources (at least for me)
  • qpaeq does not come with presets (why the hell not?!)
  • The end-user needs to select it after invocation every. Single. Time.

That's some pretty strong bat crap going on there, and makes using Ubuntu more of a pain than it has to be. So let's get the one which works instead.

:grey_question: Why even get it?

An equalizer is intended to make your aural experience better by providing more options for listening environments, device, genre or general sound curve preferences. A lot of users coming from Windows might be familiar with an equalizer in VLC Media Player or WinAmp, which is where a lot of the presets bundled with the older PA EQ are inspired from. Using a software EQ means you trade off the use of a hardware EQ for CPU cycles, but since most people who use Windows are already familiar with some form of software audio enhancement, that shouldn't be such a big deal except for users of the most anemic of CPUs.

:install: How to install

:arrow_down: Getting it

At present, users of Bionic and less, up to Xenial can follow these directions without additional steps to follow. If you're on Xenial, then the webupd8 PPA provided below will just work and you won't need to specify version. Past Xenial, version is required. If using anything later you will need to follow some additional steps. Regardless, the below will work for everyone.

If you're using an older version of Ubuntu, that's fine; this PPA supports down to Precise, and the package exists for Ubuntu versions down to Trusty (technically Oneiric but who uses that anymore?)

:warning: Special information for Groovy Gorilla

:fast_forward: Instead of reading the below and downloading everything, I've compiled all of the dependencies this software relies upon. You can download that archive from here. Once obtained, extract to a separate directory and perform the following after cd'ing to it.

:heavy_dollar_sign: In x-terminal-emulator:

sudo apt install ./*.deb

This is everything you need, so you can skip directly to Adding the repository and getting that out of the way. Until someone bulds the later versions of this, it's all you've got.

Somebody please put this software out of its misery!
Even more packages, this time five of them. Later on I'll modify my care package to include the seven you need for this to work, but it's just getting more and more broken with every passing Ubuntu release. Nonetheless, since there is no Debian package for the later release available from the Arch User Repository in Arch Linux land Ubuntu users must settle for more of this. Hooray.

Download those five, plus the two below, and the collation of packages for Eoan. Once all of that mess is installed — twenty-five in all — the equalizer will install correctly.

At this time, webupd8's repository for Focal Fossa can be used for equalizer source. The content below the boxes and boxes of hotfixes for older Ubuntu builds is updated to reflect this.

:warning: Special information for Focal Fossa onward

More layers of dependency
20.04 LTS requires the installation of two more packages before installing the rest of the stuff for Eoan. From the Ubuntu Package Archive:

:arrow_left: Why packages for Xenial? Canonical decided to drop package support for Eoan. Due to this, an alternative had to be sought, and these exist in the Ubuntu Package Archive.

Once those are installed, the rest of the installation should go smoothly. Else, you can extract the Eoan care package provided below first, then put these two packages in along with it and follow instructions provided for Eoan to install them all at once — apt will figure out the rest.

:warning: Special information for Eoan Ermine onward

:hammer: Canonical decided to break everything, so instead of telling you lot to edit URLs or fixing up this box with URLs which work, just grab the care package linked above and use that.

Welcome to dependency hell; enjoy your stay!
All aboard the pain train! Anyone starting with a fresh copy of 19.10 have to install a ton of packages as dependencies for python-gnome2 and python-pyorbit. Before installing them, you have to install these:

Get all of that, and install it. Start with pre-depend multiarch-support, then do all of the common depends, then do all of the depends. Afterward, you can follow the advice provided below this box, which will let you install the final dependencies legacy PA EQ needs.

:warning: Special information for Disco Dingo onward

Dependency installation
You will need to download the following packages as these might had been removed during the upgrade process to Disco Dingo or are simply non-existent on your fresh installation:

Download the version compliant for your system architecture and from your preferred source, and use gdebi-gtk to install. You can also use dpkg or apt-get in command line, just cd to the path where you saved them, then you'll need to execute the following:

:heavy_dollar_sign: In x-terminal-emulator:

sudo apt-get install python-pyorbit_2.24.0-7.2_*.deb
sudo apt-get install python-gconf_2.28.1+dfsg-1.2_*.deb
sudo apt-get install python-gnome2_2.28.1+dfsg-1.2_*.deb

:information_source: For dpkg, it would be dpkg -i instead of apt-get install.

:asterisk: To do the apt-get command for installing them all at once with regex magic:

:heavy_dollar_sign: In x-terminal-emulator:

sudo apt-get install python-*_*.deb

If you used dpkg, The instance of apt-get is necessary to complete installation as using dpkg will produce errors which apt-get can resolve. As follows:

:heavy_dollar_sign: In x-terminal-emulator:

sudo apt-get install -f

When finished, you can carry on.

:heavy_plus_sign: Adding the repository

Perform the following;

:heavy_dollar_sign: In x-terminal-emulator:

sudo add-apt-repository -n ppa:nilarimogard/webupd8

:ubuntu_mate: In later versions of Ubuntu, -n is required to not update automatically.

:information_source: Software availability

Currently this software from the webupd8 repository is available for Focal Fossa. If reading this in the future, you may have to edit the repository list to include software for Focal Fossa. To do so:

sudo nano /etc/apt/sources.list.d/nilarimogard-ubuntu-webupd8-eoan.list

Then replace every instance of whatever $LSB_RELEASE is with focal and save pressing O while holding Ctrl. Afterward, you can update repository information as described below.

To install the equalizer, after following the above instructions, perform the following:

:heavy_dollar_sign: In x-terminal-emulator:

sudo apt update
sudo apt-get install pulseaudio-equalizer=

:bangbang: Installation issues on Xenial

If the above fails and you're not up to Xenial (why wouldn't you be?), try using the package name shown without version specified:

:heavy_dollar_sign: In x-terminal-emulator:

sudo apt-get install pulseaudio-equalizer

Keeping it working

Since a "later version" using FFT exists, apt-get will want to stand firmly in your way about keeping it. There is only one command you need to perform for fixing this. (If I am wrong, I will later append onto this with new information):

:heavy_dollar_sign: In x-terminal-emulator:

sudo apt-mark hold pulseaudio-equalizer

With that done, you can move onto configuring and purposing it.

Using it

Open pulseaudio-equalizer-gtk and choose to enable the equalizer, pick a preset, then choose to keep and apply changes.


Problems at boot

In some scenarios, Pulseaudio might not work at all with this enabled. While there isn't a fix I can figure, a workaround would be to append this into your autostart, or if you don't reboot often to perform manually:

:heavy_dollar_sign: In x-terminal-emulator:

# Remove ANY instance of PulseAudio configuration files
rm -rf ~/*pulse* ~/.config/*pulse*
# Kill and reload PA
pulseaudio -q
pulseaudio &
# ! You may not have to, but if you Hold [Ctrl] and press C to break operation
#   it should restore access to terminal, should you be locked out after invocation.

When finished, open pulseaudio-equalizer-gtk and re-apply specified changes, and reconfigure your audio devices to previous specifications.


If you find after many hours of tweaking the above isn't worth it, removal is pretty easy;

:heavy_dollar_sign: In x-terminal-emulator:

sudo apt-mark unhold pulseaudio-equalizer
sudo apt-get remove --purge pulseaudio-equalizer

And to be done with the webupd8 PPA altogether if you have no other use for it and had not upgraded any packages using it;

:heavy_dollar_sign: In x-terminal-emulator:

sudo rm -rf /etc/apt/sources.list.d/nilarimogard*
sudo apt-get update


  • As always, holding back updates and locking down packages can lead to security risks and the distinct possibility of dependency hell.
  • As mentioned previously this will use some of your processor so if your CPU is weaksauce you may want to caution using enhancements like this.
  • You are using this information as-is without express warranty. If you goof and gaffe, it isn't my fault (stupid).

Information sources


THANKs A LOT @tiox.
:joy: & :relieved:
I am months behind her but REALY appreciate you contacting me.

which version of ubuntu are you using ?
i tried with 17.10 without success :frowning:

The latest webupd8 repo should still have the Xenial version of PAEQ, since it’s working on my end. Mind producing some output so I can determine where you went wrong?

Alternatively, if it’s because the package for Xenial doesn’t exist in the Arttful repo, open the .list file for webupd8 in pluma and copy the active line there to paste in a new line to also pull packages for Zesty.

I've also been swapping between 'qpaeq' and the LADSPA based 'PulseAudio Equalizer' for years now and I quite agree that 'qpaeq' is completely inferior for all the reasons you've given.

It seems the LADSPA version has new maintainers over at...

I managed to package it but only afterwards realised that Ubuntu 18.04 only has python-gi version 3.26 and 3.30 at minimum is needed for the Gtk.Template bits to work.

So I thought I'd make the old one work without any crazy package holding. In short the reason for package holding above is because the package 'pulseaudio-equalizer' is now in the main Ubuntu repositories - but that is the 'qpaeq' version!

This script takes the webupd8 package and renames it (both in terms of package name and directory structure) to 'pulseaudio-equalizer-ladspa' (which is incidentally what the Arch guys are calling it...

Then it installs just fine and won't even conflict with 'qpaeq' if you want that too...

sudo dpkg-deb -R pulseaudio-equalizer_*_all.deb src
sudo sed -i '0,/\(pulseaudio-equalizer\)/s//\1-ladspa/' src/DEBIAN/control src/usr/share/menu/* src/usr/share/lintian/overrides/*
sudo sed -i 's/\(pulseaudio-equalizer\)\//\1-ladspa\//' src/usr/bin/* src/usr/share/menu/* src/usr/share/pulseaudio-equalizer/*.py
zcat src/usr/share/doc/pulseaudio-equalizer/changelog.Debian|sed 's/^\(pulseaudio-equalizer\)/\1-ladspa/'|gzip -c|sudo dd of=src/usr/share/doc/pulseaudio-equalizer/changelog.Debian.gz    
sudo find src/usr/share -name pulseaudio-equalizer -exec mv {} {}-ladspa \; 2>/dev/null
(cd src && find usr -type f -exec md5sum '{}' \;|sudo dd of=DEBIAN/md5sums)
dpkg-deb -b src pulseaudio-equalizer-ladspa_2.7.0.2-5~webupd8~xenial0_all.deb
sudo rm -Rf src

Works great :slight_smile:

Good on you man. Pleasant to see a great mind thinking alike, but tackling the issue differently.

However I will say this much; Until the FFT EQ gets better and becomes more user friendly, I wouldn’t even bother. What would be really nice is if you forked webupd8’s project into its own PPA using that script to “Build” the renamed equalizer. You can then publish it as a joint effort between you and the maintainers who created it, and make it installable for Bionic and Cosmic.

About that… yes, that is exactly the reason. Figured I would confirm your suspension. The EQ gets replaced immediately upon next update which is why the package holding has to be done if not using your solution. The bother I have with it presently is it’s not user-friendly, but at the same time I post less user-friendly things myself so I can’t knock you for trying. :wink:

One more thing; I should attempt to see if I still need to hold those QT packages or if it was me rushing and panicked. You shouldn’t need to hold anything except pulseaudio-equalizer, so I am going to take a look at that and see what’s up there.

1 Like

Appending further onto the script which was presented earlier, I managed to install the package he built and acquire the deps for it rather easily. If you would rather the above without adding the webupd8 PPA:

# Fetch and rename
sudo dpkg-deb -R pulseaudio-equalizer_*_all.deb src
sudo sed -i '0,/\(pulseaudio-equalizer\)/s//\1-ladspa/' src/DEBIAN/control src/usr/share/menu/* src/usr/share/lintian/overrides/*
sudo sed -i 's/\(pulseaudio-equalizer\)\//\1-ladspa\//' src/usr/bin/* src/usr/share/menu/* src/usr/share/pulseaudio-equalizer/*.py
zcat src/usr/share/doc/pulseaudio-equalizer/changelog.Debian|sed 's/^\(pulseaudio-equalizer\)/\1-ladspa/'|gzip -c|sudo dd of=src/usr/share/doc/pulseaudio-equalizer/changelog.Debian.gz    
sudo find src/usr/share -name pulseaudio-equalizer -exec mv {} {}-ladspa \; 2>/dev/null
(cd src && find usr -type f -exec md5sum '{}' \;|sudo dd of=DEBIAN/md5sums)
dpkg-deb -b src pulseaudio-equalizer-ladspa_2.7.0.2-5~webupd8~xenial0_all.deb
sudo rm -Rf src
# Install
sudo dpkg -i ./pulseaudio-equalizer-ladspa_2.7.0.2-5~webupd8~xenial0_all.deb
sudo apt install -f -y

(Hindsight is 20/20. This might not be the best way to install but it worked for me.)

1 Like

Yeah I left off the bit for installing the package as there are lots of different ways to do that. Most would likely just double click the package and keep it around in case they need it in future. I just use…
sudo gdebi -n pulseaudio-equalizer-ladspa_2.7.0.2-5~webupd8~xenial0_all.deb
Which both installs it and also takes care of dependencies in one hit.

I think there is some sort of bug with this software however, haven’t quite nailed it down yet.

But on one of my systems… when I reboot I find the MATE panel / main menu / marco / basically anything Gtk2/3 that makes new windows (or menus) - does so at an alarmingly slow rate. When I go in to sound preferences my audio devices also don’t look right.

The moment I go into this equaliser and undo ‘Keep Settings’ - and boom, it’s all good again. Took me a long while to find this (as I couldn’t find any debug) and a reinstall to work it out.

So in case anyone else has similar issues (this is on Ubuntu MATE 18.04) let me know.

Hey guys! Long time no see, I know, but figured I would update this guide for Disco! Sucks you need to download some extra packages but hey, them's the breaks.

Made the guide more efficient by considering order of operations and having the information which matters most for Disco Dingo users first.

When I first ran bionic on my pc,
I found a quite manual way of installing it:

In xenial I reinstalled the equalizer and quickly grabbed everything that was downloaded from


before the installation finished and automatically erased all downloaded packages.
So that was a rough backup, but I got everything needed.

Back to bionic I installed one by one, in the following order:


And BAM! PulseAudioEQ was fully operational on my system, and I was happy than ever. HAHAha
Only to find this guidance a few hours later..

This EQ was first created on November 1st, 2009 by an Irish guy

but I sware that when I find an Ubuntu that won't be able to load it, I'll have to remain with the older version. JUST because of this equalizer.
You are the only few users who understand how mighty it is.

So please, let's try to maintain it whenever possible without modifying, forever.

You guys are awesome, it's the best support of all Ubuntu flavors and distros.

Why don't we contact the nilarimogard/webupd8 ppa and ask them to release an installation for bionic? I'm sure it's just a matter of editing simple lines, and inform about the apt-mark hold approach to not interfere with the system package.
Why not even disco, they just need the right guidance found here. :wink:

Glad you found the guide useful, even if it is in hindsight. If nothing else, I'll keep the package on hand for my own use and upload it if I ever encounter the issue of this software no longer existing in any capacity.

There is an alternative I want to try out on this system called PulseEffects which has way more sound control options, but for best compatibility I would need to add either the PE PPA or Pop!_OS' PPA for it, and see if the community presets for it sound better than what's baked into my preferred EQ. I remember during my time on Pop!_OS the PulseEffects EQ was prone to crashing and giving me no audio due to it.

I super-goofed and swapped install commands for LADSPA PAEQ. My bad! In newer versions of Ubuntu, if you only did sudo apt install pulseaudio-equalizer it will install the FFT version, which is the one that is so bothersome to even attempt using!

I'm aware of PulseEffects and I remember it didn't work out-of-the-box, just after setting it to the right direction. I examined every option of it and concluded it was a copy and paste of what we find in the Realtek High Definition Audio drivers for Windows.

If your hear it closely, this equalizer adds a bad 'static' to the sound acoustic, distorting the original audio. It does not provide a quality overall output, it is very poor.
It's useful if you wanna play around with the ambient effects, but it's the same as using a cheap set of speakers.

Now, the LADSPA EQ has a tremendous quality.

It doubles the power of your speakers! Has a perfect distribution of channels, every detail and nuance of the audio has definition, clarity and potency without any artificial layer.
I gotta say, undoubtedly, that only through this piece of software, you'll have a better audio than several so called audiophile and expensive speakers.
It's the cornerstone of my HTPC.

It must never die. :monitor:

1 Like

So tiox, are you a fan of Bach? :laughing:


You seem like a notorious and assiduous contributor to this community, inherited from the composer.

1 Like

Guys, I'm so sorry. I don't have time to research right now. I managed to successfully install old PAEQ after much issues with missing legacy GTK2 libraries which were not in Eoan's repos.

In the next day or two, I'll have the good stuff for y'all. But it's going to be a lot to fetch.

Fifteen packages.

Fifteen packages?!

Fifteen packages!

Holy O'Connell is that a whole lot of packages! But I figured it out, yet again for the benefit of the three people here who give a damn.

If you encounter the 500 server error issue because you're hammering the Ubuntu Packages website a little too much with requests, use Google; begin a search with site: and the URL you want to access, you'll bypass the 500 for a few minutes, anyway and be able to download all of the packages you need. But that's ridiculous. This is getting out of hand.

Can someone more experienced than I rebase and recompile this for GTK3?

Added archive with all Eoan deps to keep Rhonda from fielding multiple 500 issues for Ubuntu Packages;

PulseEffects made it to the debian main repo.
It can be installed with sudo apt install -y pulseeffects.
However, in order for the EQ to work, you have to install lsp-plugins as well (sudo apt install -y lsp-plugins).