How to turn Ubuntu Mate into Ubuntu Mate Studio

I like Ubuntu Studio. I don’t like the XFCE desktop that comes with it. I do like Ubuntu Mate. So, I figured out how to install all of the relevant meta packages from Ubuntu Studio, including the low latency kernel (many of the Ubuntu Studio apps wont work without it).

Simply copy and paste the command below, in its entirety, into a terminal and press the “enter” key on your keyboard. Then follow and carry out any instructions given:

sudo apt-get update && sudo apt-get upgrade && sudo apt-get install linux-lowlatency && sudo apt-get update && sudo apt-get upgrade && sudo apt-get install ubuntustudio-audio ubuntustudio-audio-plugins ubuntustudio-graphics ubuntustudio-video

About half way through the installation, you will be asked if you want to “enable real time process priority”. Make sure you answer “yes” to this question. Please note, that you can alternate between “yes” and no" in the terminal by using the “Tab” key on your keyboard.

When you are done, reboot and everything should be working fine.

The only issue you will have is an aesthetic one. That is to say, the sound & video menu will be ludicrously long, given all the audio apps that will have been installed. Thus, you might be advised to edit your applications menu and put some futher sub-folders into the sound and video sub-menu and then move your various sound apps into the respective sub-folders.

If it helps, the sub-folders (including where I placed all my sound apps) I have added to the sound and video menu are:

(also, please ignore if there are any apps I have included in the following list that are not actually in your sound and video menu. These will be apps I have personally installed after installing the ubuntu studio meta packege. i just can’t remember precisely which ones they are!)

Sound and Video
        Audio processors
            Calf Plugin
            HDA JackRestask
            Jack Rack
            Ladi control Centre
            Ladi Log File
            Ladi Player
        Midi Utilities
            Jack Keyboard
            Virtual Midi Keybaord
        Mixers and Card Control
            audio mixer
            echo mixer
            ffado mixer
            pulse audio volume control
        Sound Generators
        put all of your video production apps here
    Media Playback
        put all of your sound and video playback apps here
    Miscellaneous Sound and Video Apps
        What's left, if anything, goes here

I’m going to give this a try tomorrow since I cant find my damn usb stick still!

1 Like


I should let folks know here, that UB has been kind enough to test out an Ubuntu Mate rebuild iso I had made to turn it into Ubuntu Mate Studio. But, then, I realized how to just do it after the fact of Ubuntu Mate installation, as described here.

Which is just as well given the USB situation!.. :grinning:

1 Like

You might want to check if there are any tweaks in /etc/security/limits.conf for performance under Ubuntu Studio. I made a tweak for rtprio on my Debian install which seemed to help lower latency a little when I was using it.

Cheers Rob, I know it needs the low latency kernel installing. But, I have included that in the command. I have tested it all in a VM and it seems to be working fine, albeit sluggishly (due to it being a VM). As for the limits.conf, I have no idea. If you have any suggestions/tips, I’d be grateful

Yeah, I saw you included the lowlatency kernel. I don’t recall if there was anything specific in the limits.conf for Ubuntu Studio, but I use at least “@audio - rtprio 99” for an install I want to do lowlatency audio work with. There may be some other stuff that could be tweaked but that’s all I’ve ever really used.

1 Like

I should also say, I recommend installing rosegarden midi editor and vmpk virtual keyboard as well. Rosegarden cos I think it is a powerful program once you get past the initial learning curve and VMPK cos it tends to behave itself better with things like QjackCTL

Rob, the machine I am on now is an Ubuntu Studio install (with UM over the top). The contents of the limits.conf file are below, if there is anything that stands out that you think I should note:

(though, I should say, it all seems to be commented out, and so inactive)

# /etc/security/limits.conf
#Each line describes a limit for a user in the form:
#<domain>        <type>  <item>  <value>
#<domain> can be:
#        - a user name
#        - a group name, with @group syntax
#        - the wildcard *, for default entry
#        - the wildcard %, can be also used with %group syntax,
#                 for maxlogin limit
#        - NOTE: group and wildcard limits are not applied to root.
#          To apply a limit to the root user, <domain> must be
#          the literal username root.
#<type> can have the two values:
#        - "soft" for enforcing the soft limits
#        - "hard" for enforcing hard limits
#<item> can be one of the following:
#        - core - limits the core file size (KB)
#        - data - max data size (KB)
#        - fsize - maximum filesize (KB)
#        - memlock - max locked-in-memory address space (KB)
#        - nofile - max number of open files
#        - rss - max resident set size (KB)
#        - stack - max stack size (KB)
#        - cpu - max CPU time (MIN)
#        - nproc - max number of processes
#        - as - address space limit (KB)
#        - maxlogins - max number of logins for this user
#        - maxsyslogins - max number of logins on the system
#        - priority - the priority to run user process with
#        - locks - max number of file locks the user can hold
#        - sigpending - max number of pending signals
#        - msgqueue - max memory used by POSIX message queues (bytes)
#        - nice - max nice priority allowed to raise to values: [-20, 19]
#        - rtprio - max realtime priority
#        - chroot - change root to directory (Debian-specific)
#<domain>      <type>  <item>         <value>

#*               soft    core            0
#root            hard    core            100000
#*               hard    rss             10000
#@student        hard    nproc           20
#@faculty        soft    nproc           20
#@faculty        hard    nproc           50
#ftp             hard    nproc           0
#ftp             -       chroot          /ftp
#@student        -       maxlogins       4

# End of file

Ah, yeah they’re using the standard Ubuntu limits.conf. If anything I’d suggest just adding the rtprio line. I was reading a Debian mailing list thread a while ago and they concluded that not much else really makes much of a difference in latency performance.

@stevecook172001 I shouldve mentioned this when we were talking on Skype but check this out.

I do these on every ubuntu install. I’m not sure if they are alreay done or relevant to ubuntu studio

That site is awesome and I know nobody that can write and tell tutorials better than him. I even co-hosted a podcast with him on there for awhile. I think they are still available for download if you want to listen to them. There is one where I was playing my guitar live through Rackarak. :grinning: I miss doing that show.

Damn I just tried to download it and got no file. No podcast available.

I’ve rewritten my main rig with this set-up now. Please see below for a quick video of how the menu looks once it’s been tidied up

interesting - i may have to dig out my old usb midi keyboard and have a play…


I have now tested this out on both ubuntu mate 14.04 32 bit lts and ubuntu mate 15.04 32 bit lts.

In both, everything installs fine and everything i have tried to run seems fine.

Apart from one program: Rosegarden. It does not want to work at all in Ubuntu Mate 15.04. Though, it works perfectly in Ubuntu Mate 14.04.

For me, this is a big thing since I use Rosegarden all the time. So, as far as I can tell everything that I have tried, apart from Rosegarden, works equally well in UM14 and UM15. but, my guess is that other things may rear their ugly heads with regards to UM15, though that is a guess. So, while you may decide that you are never going to use Rosegarden and so it is okay to use the Studio meta packages with UM 15, given the issue with rosegarden and given my guess that there may be other apps that could have a problem, I recommend doing this with UM14.04, since I can guarantee that version works with all of the Ubuntu Studio apps

1 Like


panic over, I think, for Rosegarden vis a vis UM15.04

I have written a simple bash script that you need to launch Rosegarden with special settings in UM15.04. If you do that it works okay…

…I think

I am going to push it a bit to make sure it remains stable. If it does, I will write up instructions for doing it here shortly.

1 Like

Okay, to get this working nicely in 15.04, I recommend doing the following:

Add two extra lines to the "limits.conf" file

  1. paste the following into a terminal:

sudo pluma /etc/security/limits.conf

  1. navigate to the bottom of the file and paste the following two lines into it:

@audio - rtprio 90
@audio - memlock unlimited

  1. save and close the file.

Make a bash script to load Rosegarden in the correct way

  1. Firstly, you need to knock up a little bash scrip to start rosegarden in a particular way.

a) open a blank pluma file

b) paste the following text into it:


c) save the file as

  1. use caja to navigate to your newly created file. it should be in your home folder.

  2. right click the file and choose "properties"

Make sure you select the "allow executing the file as program" check-box, in the "permissions" tab

Then close the properties dialogue box.

  1. You can, from now on, if you wish, simply start Rosegarden by double clicking this file. However, if you like things all nice and neat, like me, then follow the instructions, below, to make it so you can run this bash script from your Rosegarden entry in your main menu.

a) go to your main menu and right click and choose "edit menus"

b) navigate in, the menu editor, to where your Rosegarden launcher is. Then, double click it.

c) press the "browse" button and navigate to where your bash script is located and then select it. The path to the script will now appear in the command field. You can now close the launcher and close the menu editor.

From now on, whenever you select Rosegarden form the menu, it will actually be running this script to load it, in which case it will work properly

Edit to add:

Of course, the Rosegarden instructions only apply if you actually choose to install Rosegarden!

However, that said, and irrespective of whether you install Rosegarden, I would still strongly recommend you implement the instructions on adding the extra lines to your "limits.conf" file.

1 Like

In conclusion and on balance, I would recommend installing the Studio meta-package in Ubuntu Mate 14.04 LTS over Ubuntu Mate 15.04 due to issues with QT packages. That is not to say they cannot be made to work in 15.04, as exemplified by the fixes I have mentioned. But, I cannot say this in total confidence. I can say it about UM 14.04. I have pushed many of the packages hard in it and everything has run perfectly.

Additionally, I have another, indirect, issue with running the Studio meta-package in 15.04 that is pertinent to only me. But, I thought I should share it with you in case it may be of value to you:

I run PNP LTSP on my Linux system. But, this version of LTSP is also not running in UM 15.04 due to to some kind of problem with the PNP LTSP ppa. Again, this problem does not occur ion 14.04.

Hi, just stepped by and had some testing with Studio too.
Is your command line still working with 16.04 LTS?

Yep, I just tested it in a VM and everything seems to be working okay. Also, Rosegarden now seems to be working unproblematically in 16.04 as well. So, all good, so far as I can see. Still working on trying to get LTSP operational in 16.04 though!. But, that’s another story…

1 Like

Actually installed with your post and all worked well. Thx a lot :grin:

Only ToDo now is sorting things out… :stuck_out_tongue_winking_eye:

1 Like