HP X2 10-p005na mini laptop Touchpad & Touch screen problem

I bought this mini convertible laptop, full specs here http://cc.cnetcontent.com/vcs/hp/inline-content/KV/2/5/0/B/B/250BB499F2638D8EF4957605AAC863FD4F253C57_source.PDF
As yet I am only trying it as a live session, 16.04LTS. I am a little hesitant about installing as I can't remove the hard drive, on previous installs I have cloned the hard drive so if a really mess things up & can replace the drive and it will be back to factory settings.

I knew about the sound & battery indicator issues

I am hoping they get fixed soon.
I have a problem with the clickpad and touch screen. They both work but only basic functions.
For the clickpad I would like to enable either 2 finger scrolling or edge scrolling. The strange thing is I can't find the settings. On other PC's I go to the control panel and there is a mouse & touchpad settings. This one only has mouse settings. Is there a way to get the touchpad settings?
For the touch screen, there is no right click, zooming etc, again I can't find any settings.

Any help would be greatly appreciated.

What is the output of the following two commands?

$ synclient VertEdgeScroll=1
$ synclient VertTwoFingerScroll=1

Hi orschiro,
Both command give
Couldn’t find synaptics properties. No synaptics driver loaded?


And $ dpkg -l | grep synaptics?

Does it tell you that synaptics is actually installed?

For me it says:

ii  xserver-xorg-input-synaptics                    1.9.0-1ubuntu1                                              amd64        Synaptics TouchPad driver for X.Org server

Hi orschiro
I get
ii xserver-xorg-input-synaptics 1.9.0-1ubuntu1 amd64 Synaptics TouchPad driver for X.Org server

(Actually trying 17.04 today but the same result)

Also tried installing Touchpad-Indicator but it crashes.


Well, then I am a bit clueless.

This article might help you:


Thanks for your help.
I looked at the link but it’s all a bit beyond me.
Getting nowhere with the clickpad scroll which is disappointing as it difficult to use without it.

I am getting somewhere with the touchscreen.
Mate 16.04 - No right click, no scroll, no zoom
Mate 17.04 - No right click, no zoom but scroll works
Ubuntu 16.04 - scroll & zoom work,
after command (on Ubuntu 16.04)
gsettings set org.gnome.desktop.a11y.mouse secondary-click-enabled “true”
right click works but is very temperamental, only works about 1 in 4 tries, I think this is down to it detecting tiny movements when holding for 3 seconds. Doesn’t work at all on either Mate 16.04 or 17.04.
Just need to get it to work on Mate 16.04


So, if it does work on Ubuntu Unity, then I suggest you file a bug against Ubuntu MATE as it seems to be something that is just not yet supported:

Thanks, I have filed a bug report for the touchscreen.

I am still not getting anywhere with the clickpad. I don’t understand why I don’t have touchpad settings in the control centre, only mouse. I thought there would be a simple fix for this.


So, you are saying you are missing this entire tab?

That’s right, I only have the mouse tab.

I have also tried Ubuntu 16.04 and that also only has the mouse tab. I then installed tweak which had touchpad settings showing two-finger scrolling selected. From what I understand this disables edge scrolling. I unchecked this but it made no difference. (in windows it works as two finger scrolling).
I am thinking that it might be using a driver to normal, else why does synclient VertEdgeScroll=1 give the error Couldn’t find synaptics properties. No synaptics driver loaded and the tweak settings not working?


Hmm, very strange.

I just checked this page and even on Debian the touchpad seems to working out of the box: https://wiki.debian.org/InstallingDebianOn/HP/Pavilion%20x2%2010%20(2015%20model)/Jessie

Have you tried a live image of 17.04 already?

Hi have tried Ubuntu Mate 16.04LTS & 17.04 and also Ubuntu 16.04LTS & 17.04.

Both Ubuntu Mates show this

Both Ubuntu

That link is very interesting. It looks like they have at least got the battery indicator working, hopefully that will come through to Ubuntu soon. As for the clickpad it just says working, doesn't mention the scroll so maybe they are only looking at the basic function. One more annoying thing about the clickpad I have just noticed is that it isn't disabled when typing and it is very sensitive so as I type it keeps moving the cursor to the pointer.

It's as if it detects the clickpad as a mouse? Is it possible to force it to detect it as a touchpad?

Thanks again for your help