Battery indicator not working HP X2 210

Hi @wolfmann,

I’m back to my little troublemaker (the HP X2 201 G2). Just found out, that the battery isn’t recognized either. Still working on both issues. @wolfman: is there an elegant way to link this thread to another headline (battery problem with this device) so, that users, searching for the battery issue find it, too? Or is it better to open up another thread to distinguish both more easily?

Concerning the battery problem: The battery itself is working, but ubuntu doesn’t recognizes it, thus, the icon isn’t not shown in the upper right. I already checked the system preferences (System > Preferences > Hardware > Power Management) and set it to ‘always display an icon’, which shows an red X where the battery status is expected.

That’s it for now, I’ll report back on any news :slight_smile:

For the record: I’ve already read and tried the suggestions from these forum threads:
HP Split 13x2 (Laptop) and Ubuntu Mate
Battery not recognized on Lenovo Flex
Pi-Top Battery Display

From Ask Ubuntu - No Battery Status Icon I tried:
apt-get install indicator-power
Also, from the same thread, I check wheather this setting is true, however it was already:
gsettings get org.gnome.settings-daemon.plugins.power active (result: true)

Hi @fabos,

I don’t have an answer for you myself, maybe one of the others has a solution for you?. :smiley:

IS the battery showing as working in Windows too?. :smiley:

Hi @wolfan - battery is very much working on Windows. Only not appearing in Ubuntu. Maybe, not recognised.

I’m interested in knowing if Linux “sees” the battery at all. Command line work, once again. What does command upower -e show? Example listing from my Nokia Booklet 3G netbook below:


Does the listing show battery? If yes, you can dig deeper. This gives full info of the battery:

$ upower -i $(upower -e | grep 'BAT')

1 Like

@samuvuo - Below is the output for upower -e


It does not show battery. Plus, it will be greatly appreciated if you could kindly help out in getting the sound worked for this laptop for any linux distro.

I did a bit of googling (or should I say “ducking”, because I use DuckDuckGo) and found out that while people have managed to get Linux distros installed on this machine, there is no support for the battery or sound currently in the kernel. Also, HP doesn’t support Linux (here’s one HP help forum post on the topic).

So the only thing you can do is wait and hope the hardware in question will get support in the future.

Is that the same machine as described here?

I was just looking at one of those yesterday as a potential replacement for my iPad :disappointed:

@crankpuss - Yup, its the same one. You can still go ahead and buy the same as its pre-loaded with Windows 10. Good HW, nice touch and overall, total value for money deal here. Sadly, updates for Win 10 eats up entire disk space. Also, you can go ahead and install any linux distro of your choice, but sound works on bluetooth speaker/headphone and there is no indicator for battery on Linux. But battery life is pretty decent. Rest is ok.

Have you tried mate-power-statistics? It might be a clue. I’m thinking 32G is plenty of space for Ubuntu-MATE and all my data, though working with no battery indication at all seems… more difficult than necessary.

MATE Power Manager (the package that provides mate-power-statistics) operates as a policy agent on top of Upower. If Upower cannot see the battery (as you can see from output of upower -e, posted earlier in this thread) there’s really nothing mate-power-statistics can tell us.

I don’t have time to learn upower and write a driver or something, the learning-curve is always about 10x the actual work of writing the code. If Windows can show it, that means Microsoft has the required info, if HP won’t divulge that sounds kinda monopolistic, so likely the info could be squeezed out of them somehow without going to court. The thing’s awful cute, playing with it would be a great excuse not to write the code i should be writing, and i am one lazy guy. Last year i took a shot at getting linux running on an ASUS T100 but it wasn’t to be at that time with the distro that i tried… but then last year i needed to get PHP running and i’m just about not to care about that anymore except for backups. I do recall somewhere seeing a table of device identifiers used to load the right .ko but have to force myself not to get all hooked into it right now. Anyway i hope someone will get a battery monitor working, and my wallet hopes they won’t. :slight_smile:

I hear ya! That machine looks sure looks sweet! :smile:

If anyone learns more about making everything work, please remember to post about it here… i’m feeling a potentially irresistable urge to buy one of these things. :astonished:

Hi, I’m looking for a solution to show the battery status. I don’t found any way to do it
But if your already have no sound on your PC I can explain you how to do.
Let me know

Hi Rem_Nuts,
Please explain how to make the sound work.

Hi men, sure,

First you can see your audio card by running “inxi -F”, if installed.
For my soundcard (bytcr-5640).

I follow the instruction at this link :

so :

You need UCM files from

follow instructions there (notice the bytcr-rt5640 folder - that is what you need)

also hdmi might be messing with pulseaudio, so blacklist it (but it might not :stuck_out_tongue: - please test it for your device)

echo ‘blacklist snd_hdmi_lpe_audio’ >> /etc/modprobe.d/50-block-hdmi-audio.conf

As you can see the link is for “bytcr-5640”, but other files are available here : https: // (remove the space in the url, because of anti-spam protection, I guess).

But for the fix works on all of my system, I had to modify the 50-block-hdmi-audio.conf as say above. Before this, the sound only work on login screen.

Hope this will help you.
Let me know if it work for you.

I’m having this issue as well and I can’t solve it.

I thought I would post an update
Ubuntu Mate 20.04 now has sound and touchpad scroll (2 finger) on the HP X2, the only thing missing now is the battery indicator. Has anyone been able to make ubuntu display the battery level?
The command sudo lshw gives
product: SW02032XL
vendor: 333-42-1E
physical id: 1
slot: Primary
capacity: 32570mWh
configuration: voltage=7.7V
So it can find the battery so why not the charge status?
Anybody have any ideas?