I can't see the option to Update to 20.04 from 19.04

I successfully upgraded from 18.04 to 19.04, but now when I run "update-manager c" I don't see the option to upgrade to 20.04. The release notes do not mention any other significant step so, am I missing something?


same thing here, started to wonder if it was released at all... But it seems so from this:

tried this but seems to fail:

~$ /usr/lib/ubuntu-release-upgrader/check-new-release-gtk
/usr/lib/ubuntu-release-upgrader/check-new-release-gtk:30: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk
WARNING:root:timeout reached, exiting

@Khan, you wrote that you tried "update-manager c"
perhaps a typo in your post, but else try run
update-manager -c

with the leading - in -c

i ended up using do-release-upgrade as mentioned on the link below and it looks like it works :slight_smile:

1 Like

Hello, I used the instructions in the release notes and it worked nicely:

To upgrade on a desktop system:
  • Open the "Software & Updates" Setting in System Settings.
  • Select the 3rd Tab called "Updates".
  • Set the "Notify me of a new Ubuntu version" drop down menu to "For long-term support versions" if you are using 18.04 LTS; set it to "For any new version" if you are using 19.10.
  • Press Alt+F2 and type update-manager -c -d into the command box.
  • Update Manager should open up and tell you that Ubuntu 20.04 LTS is now available.
  • If not you can run /usr/lib/ubuntu-release-upgrader/check-new-release-gtk
  • Click Upgrade and follow the on-screen instructions.



Yes, I followed the advice here as well.

Opened a terminal (CTRL + ALT + T) -
sudo do-release-upgrade -c -d

When terminal confirmed the new upgrade available -
sudo do-release-upgrade -d

welcome to the forum @yaargh! Interesting, the release notes on the ubuntu-mate.org blog do not include the -d flag in the update-manger command.. Too late to try now, do-release-upgrade worked well for me... :slight_smile:

Now i just need to figure out how to make my ruby gems work without sudo again, but that's for another topic :slight_smile:

Thank you everyone. I managed to update, running update-manager -c -d seems to have worked somehow. Now to enjoy and try the new release :smiley:

1 Like

Yeah, I'm not sure why you would need -d for update-manager or for do-release-upgrade to upgrade to a released version but maybe it is related to the lag between the release of the iso and the updater automatically recognizing it?

I was upgrading from 19.10 and I too needed to use the -d for update-manager, and do-release-upgrade did not find anything released. I also tried the instructions in the release notes that @yaargh quoted, but that did not work either. This is yesterday and the day before on 3 different laptop computers. Made me think it wasn't released yet, so I hope it is.

Now I'm feeling shy about upgrading from 18.04 on my main desktop, my real computer, and I'm now hesitant to update my wife's real computer that's running 19.10.

The whole -d parameter thing has confused me too, but it turns out it is necessary to update to the LTS from 18.04 and 19.10 before Canonical enables the prompts in :update: Software Updater.

Looks like that command in the release notes should in fact include -d, at least for now.

       -d, --devel-release
              If  using  the latest supported release, upgrade to the develop‐
              ment release

See also:

It didn't work with both -c and -d ?

It did work with the -cd but from what many of us have read we didn't think it needed the -d if it was released.

I have been recently prompted to upgrade from 19.10 to 20.04 by Software Manager automatic notifier - and what I was offered is, indeed, development release (with all the warnings and disclaimers carefully presented to me). I'll take my time for now and wait for stable (first point) release.