I need help with nvidia driver

Hello everyone!
I am having problems with the nvidia driver in Ubuntu mate 19.04
I have NVIDIA GTX 1060 (on a MSI notebook). I installed the nvidia drivers but I when I try to open NVIDIA X server setting it opens but there is nothing in the box as I only get a white box as you can see here:

Also, I cannot modify the brightness of my screen. I have noticed that the brightness applet tells me that I am in the lowest brightness and the icon unusual as it is with a forbidden symbol.

I have also try to install the latest nvidia driver (430) from this PPA: ppa:graphics-drivers/ppa, but I get the same errors.

Could anyone help me?


Have you tried a theme with dark letters? could be white on white which would result in what you see.

I have just tried it but it didn't work. It seems that there is a misconfiguration in the driver but I don't know how to fix this.


do a search on the site for nvidia, there are several solutions that can help you. without system specs it may be hard to know exactly what's going on. You can post the results from inxi -Fxz and it should give us a place to start.

This might help

Sure. I apologize I didn't do it. I am really new on this stuff :slight_smile:
This is what the command showed me:

  Host: Florin-MSI Kernel: 5.0.0-23-generic x86_64 bits: 64 compiler: gcc 
  v: 8.3.0 Desktop: MATE 1.20.4 Distro: Ubuntu 19.04 (Disco Dingo) 
  Type: Laptop System: Micro-Star product: GE73VR 7RE v: REV:1.0 
  serial: <filter> 
  Mobo: Micro-Star model: MS-17C1 v: REV:1.0 serial: <filter> 
  UEFI: American Megatrends v: E17C1IMS.10A date: 03/13/2018 
  ID-1: BAT1 charge: 40.6 Wh condition: 44.1/53.4 Wh (83%) model: MSI BIF0_9 
  status: Unknown 
  Topology: Quad Core model: Intel Core i7-7700HQ bits: 64 type: MT MCP 
  arch: Kaby Lake rev: 9 L2 cache: 6144 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 44928 
  Speed: 800 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 801 4: 800 5: 800 6: 800 7: 800 8: 801 
  Device-1: Intel HD Graphics 630 vendor: Micro-Star MSI driver: N/A 
  bus ID: 00:02.0 
  Device-2: NVIDIA GP106M [GeForce GTX 1060 Mobile] vendor: Micro-Star MSI 
  driver: nvidia v: 430.40 bus ID: 01:00.0 
  Display: x11 server: X.Org 1.20.4 driver: fbdev,nouveau,nvidia 
  unloaded: modesetting,vesa resolution: 1920x1080~77Hz 
  OpenGL: renderer: llvmpipe (LLVM 8.0 256 bits) v: 3.3 Mesa 19.0.2 
  direct render: Yes 
  Device-1: Intel CM238 HD Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
  Sound Server: ALSA v: k5.0.0-23-generic 
  Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter 
  vendor: Bigfoot Networks driver: ath10k_pci v: kernel port: e000 
  bus ID: 02:00.0 
  IF: wlp2s0 state: down mac: <filter> 
  Device-2: Qualcomm Atheros Killer E2500 Gigabit Ethernet 
  vendor: Micro-Star MSI driver: alx v: kernel port: d000 bus ID: 05:00.0 
  IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Device-3: Qualcomm Atheros type: USB driver: btusb bus ID: 1-10:4 
  Local Storage: total: 1.14 TiB used: 7.19 GiB (0.6%) 
  ID-1: /dev/sda vendor: Toshiba model: THNSNJ256G8NY size: 238.47 GiB 
  ID-2: /dev/sdb vendor: HGST (Hitachi) model: HTS721010A9E630 
  size: 931.51 GiB 
  ID-1: / size: 97.13 GiB used: 7.04 GiB (7.3%) fs: ext4 dev: /dev/sda5 
  ID-2: /home size: 452.76 GiB used: 121.8 MiB (0.0%) fs: ext4 
  dev: /dev/sdb2 
  ID-3: swap-1 size: 3.82 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda6 
  System Temperatures: cpu: 59.0 C mobo: 27.8 C 
  Fan Speeds (RPM): N/A 
  Processes: 237 Uptime: 2m Memory: 15.55 GiB used: 946.5 MiB (5.9%) 
  Init: systemd runlevel: 5 Compilers: gcc: 8.3.0 Shell: bash v: 5.0.3 
  inxi: 3.0.33

I looked at the other post you linked me but I think this is a bit different because he couldn't run the driver, but theoretically I am running it.

I don't know how you installed originally your NVIDIA driver (before the one you installed from ppa:graphics-drivers/ppa), but what I did (also on UM 19.04) was to open Software and Updates and, in the tab Additional Drivers, selected the recommended NVIDIA driver (by default, Nouveau was selected):


You have to wait a few seconds for the options to appear in this tab, while it searches for the drivers. Once selected and clicking Apply Changes, you'll have to wait for it to download the files needed. Then I guess you'll have to restart (I don't remember if it's a restart or logout).

Then you can open the NVIDIA Settings (either from the applet in your panel or from the Control Center):


As you can see, it's version 418.56.

Now --- you say “theoretically I am running it”, but I don't think so: compare my inxi output under Graphics:

Device-1: Intel UHD Graphics 620 vendor: Hewlett-Packard driver: i915 v: kernel bus ID: 00:02.0
Device-2: NVIDIA GM108M [GeForce MX110] vendor: Hewlett-Packard driver: nvidia v: 418.56 bus ID: 01:00.0
Display: x11 server: X.Org 1.20.4 driver: modesetting,nvidia unloaded: fbdev,nouveau,vesa resolution: 1920x1080~60Hz
OpenGL: renderer: GeForce MX110/PCIe/SSE2 v: 4.6.0 NVIDIA 418.56 direct render: Yes

  1. I don't know why for Intel Graphics you have “driver: N/A”, while I have “driver: i915” ---as far as I know, i915 comes by default in Ubuntu installation.

  2. See that you have “Display: x11 server: X.Org 1.20.4 driver: fbdev,nouveau,nvidia
    unloaded: modesetting,vesa”, while mine is

“Display: x11 server: X.Org 1.20.4 driver: modesetting,nvidia unloaded: fbdev,nouveau,vesa”

That is, you have a mixture of drivers (fbdev,nouveau,nvidia); I just have nvidia.

3)Therefore, I don't think you're using NVIDIA, and your inxi output reads

“OpenGL: renderer: llvmpipe (LLVM 8.0 256 bits)”

while mine states

“OpenGL: renderer: GeForce MX110/PCIe/SSE2 v: 4.6.0 NVIDIA 418.56”.

Best regards,


The first time I installed ubuntu mate 19, I tried to install the NVIDIA drivers from "Software and Updates" but I had the same problems I mentioned. That is the reason why I tried the ppa drivers.

Fortunately, I solved all the problems by installing Ubuntu mate 18.04.3 LTS and NVIDIA drivers from the ppa.
I simply cannot understand why NVIDIA drivers worked on the LTS version and it didn't in the 19.04 version.

Thank you guys for helping me :slight_smile:

Congratulations! And thank you for letting us know how you solved it. Maybe when 19.04 reaches its end of support, I will revert to 18.04.x, instead of going for 19.10...

Best regards,