"Indicator Applet Complete has quit unexpectedly"

I upgraded to 19.10 yet I am still getting "Indicator Applet Complete has quit unexpectedly"
with every boot up.

Is that gonna be fixed in 20.04?

Since there has been no response, should I take that that the problem will not be fixed?

The error message you've described is very generic. In order to fix your specific issue, it needs to be submitted as a bug report with steps to reproduce and ideally a "stack trace" of the crash so it can be looked into.

However, it sounds more like one of your applications is auto starting and crashing the indicator at login. We can use this topic to troubleshoot. Maybe try disabling all your start-up apps and see if it continues to crash?

If it's a system you don't mind using for experimenting, you can try upgrading to 20.04 Beta?


How do I do a stack trace?

Normally Apport would show a "send error report" prompt if it left a dump in /var/crash/, these can be attached to the bug report.

This applet is a little tricky due to the moving parts. :gear: You could try:

apport-bug /usr/lib/mate-indicator-applet/mate-indicator-applet-complete

Another thought I had is resetting the panel using MATE Tweak if you don't mind losing customisations. This might clean up any foul configuration.

I sent the bug report.

Do you mean delete my panel layout in Mate Tweak?

Changing the layout in MATE Tweak resets the panels to a fresh configuration, so if you have a custom one saved, see if the error persists with another fresh layout.

I reset the panel, but no change.

I also tried several times installing the 20.04 Beta, but it got to a point where it was in an endless loop. The Shasum was ok. ?

These are all my startup applications.

Which ones are absolutely needed?

When I know that, I can selectively disable the others one by one to see if any are causing the error.

AT-SPI D-Bus Bus

Blueman Applet

Certificate and Key Storage

Indicator Application

Indicator Messages

Indicator Power

Indicator Session

Indicator Sound

Mate Settings Daemon

Maximus Window Management


PolicyKit Authentication Agent

Power Manager

Print Queue Applet

PulseAudio Sound System


Secret Storage Service

Settings Overlay

Snap User Application Autostart Helper

Spice vdagent

SSH Key Agent

Update Notifier

User folders update

Definitely keep these checked:

  • AT-SPI D-Bus Bus
  • Certificate and Key Storage
  • Mate Settings Daemon
  • PolicyKit Authentication Agent
  • Secret Storage Service
  • Settings Overlay

I would probably focus on unchecking the Indicators first as the other start-up items seem unlikely to be crashing the "Applet Complete".

On another note, 20.04 LTS has just been released, you may want to backup your files and try upgrading again soon. Or, if you have the time, I'd recommend a clean install of 20.04 - a fresh installation sounds like it would resolve this "quit unexpectedly" problem.

1 Like

This is a work around that solved the problem.
It needs to be put in Startup Programs.


sleep 5
xte 'key Return'

1 Like