Instalación de antena Wifi USB


Quisiera que me ayudaran con un problema que tengo: no puedo instalar los drivers para que Ubuntu Mate reconozca la antena USB y pueda tener Internet en mi PC.

La antena es "EDUP: Wireless Networking" y su modelo "EP-DB1607".

La antena trae un CD con sus respectivos drivers y un manual de instalación. Sin embargo, en dicho manual no está la instalación de Linux, sino que está dentro de la carpeta donde se encuentran los drivers para Linux y está en inglés.

Traduje el documento y dice que hay 2 maneras para la instalación: 1) instalación automática ejecutando el archivo y 2) paso a paso.

Hice la primera, pero cuando ejecuto el me pide mi contraseña y dice error. Cuando vuelvo a colocarla, se cierra el Terminal solo. Así como aparece en esta imagen:

Ahora bien, con la segunda manera del manual, leí pero no entiendo muy bien cómo debería hacerlo, debido a que no soy un experimentado en Linux.

Por cierto, no instale los drivers originales del CD sino descargué directamente desde la página del fabricante uno más actualizado y correspondiente al modelo de mi antena. Y, por otro lado, puse en la terminal "lsusb" para ver si reconocía la antena y sí la reconoce.

Espero que me puedan ayudar. Se los agradecería un montón.

Hi my friend !
I'm not talking Spanish but i understood your issue with google translate.
I would advise you to get here :
From the menu, search "additional drivers"

This can help installing some extra drivers.

Let's start with that !

Also i found this link that looks solved the issue :

Thank you very much for your answer.

I can't test your solutions since I don't have wired Internet in my Linux distribution, so I want to install the antenna.

I don't know if you know of any solution that doesn't require an Internet connection, for example, doing the installation of the drivers step by step or any other way in which you can help me with my problem.

Can you use your phone as USB modem ?
I'm afraid you will need internet to figure out a solution.

Luckily I can use my phone. I'll try the solutions you told me about and I'll tell you.

Well, I've tried both the ways you mentioned, but neither way has given me the Internet with the antenna.

I'm telling you:

With the first "additional drivers"
It was marked "No usar dispositivo" and not the one on top. I selected it and gave it "aplicar cambios", loaded a bar for a while and it stayed like that:

I suppose that means that now you are using the antenna drivers, but I don't know if I have to activate it now in any way to make it work. I checked the network connections part and nothing new came up.

Hi :slight_smile:
Did you rebooted ?

Can you share the output of lspci with the usb dongle and the same without ?

What about the other sollution ? Guys there look happy with the problem solved :

sudo apt install git dkms build-essential
git clone
sudo dkms add ./rtl8812au
sudo dkms install 8812au/4.2.2

I did reboot, but it stayed the same.

The other solution:

Image summary:
It says "build-essential" is already in its most recent version and "dkms" too.
After the package "libllvm7" was installed automatically and is no longer needed, I suggest to remove it with "sudo apt autoremove".
It suggests several packages and new ones will be installed, none of which were found by "404 Not Found".
And, at the end, that I should try "apt-get update".

The forum won't let me put 2 images, so I'll put the lspci ports in another comment.

Here's the information on lspci

Disconnecting the antenna gives me the same results as that image.

Probably you broke some packages with the installation of your driver before we started.

Try this (it will fix software that has missing software, it will try) :

sudo apt-get update --fix-missing

and next (it will try to force install missing packages)

sudo apt-get install -f

Next try again :

sudo apt install git dkms build-essential
git clone
sudo dkms add ./rtl8812au
sudo dkms install 8812au/4.2.2

sudo apt install git dkms build-essential will install git to clone the git repo, and build tools you will need to compile your driver

git clone will clone the repo to your computer

This will proceed your driver installation :
sudo dkms add ./rtl8812au
sudo dkms install 8812au/4.2.2

I still believe it will work :slight_smile:

I'll tell you how it went.

Everything was going well until I got to this point:

I skip an error because I put 8812au/4.2.2 when you gave me 8812au/4.2.3 before; I don't understand why. To avoid leaving it there, I put the 8812au/4.2.3 and I don't know if I am wrong. At the end of the installation I restarted, but no positive results.

Now, you tell me what I can do next.

By the way, thanks for your help.

Let's try to modprobe it :

sudo insmod <path to the driver>

it should be somewhere here :

let us know :slight_smile:

I tried the first command and it gave me this result:


bash: syntax error near the unexpected element 'newline'

Try this :
sudo insmod 8812au.ko



What can I do now?

Do you think it can work or not? I'm giving up XD.

Hahha :slight_smile: lets keep believing :slight_smile:

I dont know where the driver got installed. Can you run a :

sudo find / -name 8812au.ko 2>/dev/null
(it will search for the file we have built before so take some time)
Once you have found it somewhere try again our command but with full path (you found)

sudo insmod
and add the path the find command will output

This was the result I had, but I think I did something wrong:

I don't know if I did the process the way I should have.

Looks better and better :slight_smile:

try :

sudo rmmod 8812au

Show us the output, next try to insert this one :

I had to do the process twice, since when I first placed the command sudo rmmod 8812au nothing appeared; although I did place the one you marked in red.

When I tried everything again for the second time I got the results of the image above.

The funny thing is that the first time he didn't tell me "permiso denegado (permission denied)" when I put the mark in red.