Installing 20.04 is a nightmare! Please assist?

I've installed 8 times now, and most times, I got it to start and see the desktop.

On Shutdown, I get fails to unload /cdrom, and failed to unload isodevice and hangs there.
Powering off, and rebooting again, I get the login screen (first time that happened), and after logging in, I see a light-grey screen with a small darker border and after 11 seconds, the green logo, then after 48 seconds (timed it) I get a black screen sometimes with a cursor, sometimes not. The only thing that works, is the fan the black screen, and the mouse - sometimes the mouse.

How I installed:

  1. I downloaded the cdrom/ link to get "ubuntu-mate-20.04-desktop-amd64.iso"

  2. This was burned to a 8 Gig USB Drive using Balena-Etcher (because the first suggested Universal-USB-Installer refused to format the USB Memory Stick).

  3. The USB Thumb Drive was inserted into the ltop and booted. That opened Pandora's Box.

  4. Too many install fails so I re-burned the USB stick

  5. Re-installed - again- and made it to the desktop.

  6. There was no request to set up user, or password or to remove the USB Flash Drive.

I noted that there was a Install Ubuntu-Mate icon. I thought that was what I just installed so many times but what the h , I clicked it, and eventually, asked to set up a user name and password. That done, I did a restart and was again greeted with "Failed to unmount /cdrom and /isodevice.

Now, when I boot, I get a most private system, it's a black screen with no input from mouse, touch pad, or keyboard. No amount of old or newly invented cussing helped any.

What else have I done:
I bought a new USB dongle, re-downloaded "ubuntu-mate-20.04-desktop-amd64.iso", re-imaged to USB Pen Drive, and re-installed again.

As it turns out, there is was no opportunity to reformat, wipe, or partition the HHD, anf the Installer saw Ubu was installed, checked the files (./casper/filesystems.quashfs )), started Ubu again, with logo in centre screenand the 5 whites dots below it stay white and that is the end of that install. It hange there.

= two bricked USB (whatevers), one bricked laptop and 15 new curses to added.

What kind of laptop should I buy to make Ubuntu 20.04 install?

~s~ I'm feeling very :biohazard: right now >:(

16 hours in two days I've put into this and only got as far as forced to use Windows to ask how to make Ububtu install.

Let's get some facts ...
are you trying to install UM (ubuntu-mate) on a laptop that has Ubuntu already installed?
do you want a dual boot system or completely wipe the disk (sda) and install UM?
do you have the specs of the laptop (model, disk, ram, graphics card)?

When you boot from the usb stick, it offers 1. Try Ubuntu or 2. Install Ubuntu. Try will let you test that UM loads and works well (graphics, wifi, etc.). Then, you can click on Install UM which will start the Installer. This is where you decide to wipe your disk and install UM or install alongside another OS.
Let us know, there are guides in this forum for installation.

3 posts were split to a new topic: Grub fatal failure Lenovo S205

See also:


It had UM 16. Then Prisim PureOS was installed using delete partition and install.

Wipe and then nothing but UM; no SSD, "sda" (Seventh-day Adventist huh - ?) UM goes on the HDD, no where else with anything else.

Yes, I said it meets all the requirements:

Not the version I got from here, that was /ectched/burned/uncompressed to the USB )(whatever). I followed the link from the front end to downloads and clicked "download" that took me to a page where I picked the one that says "64-bit PCs/Macs" and then the next pages, chose "20.04 LTS Focal Fossa"

I would have chosen WIPE. I know it means the same thing it did 1983.

Maybe that's the problem - I followed the guide :slight_smile: and not one shoe fits all so I searched before posting here.

NOTE: When I was able to get to the desktop, there was mention that I was Live access of some sort.
Thanks @ pavlos_kairis


You want one OS, one disk (btw, sda comes from the sd driver, way back sd was a SCSI driver and a, b, ... are the disks, so the first disk is sda, the second sdb, etc.

You d/l a good, verified UM 20.04 iso, you burned it on a usb stick, start the laptop to boot from the stick. Booting starts, at some point you should get the familiar green desktop with a panel and an icon on the screen, Install Ubuntu Mate 20.04 LTS.

You click on that and it begins asking questions about keyboard, country, user, and wipe out everything and install mate. It should go through all this, installing packages, removing packages at the end -- and then asks you to reboot, remove the usb stick, and it should boot into UM 20.04 It should pop the welcome window which helps you for initial configuration.

I found this video, a month old, if that helps ...

1 Like

Yes please.

I followed the link from the front end to downloads and clicked "download" that took me to a page where I picked the one that says "64-bit PCs/Macs" and then the next pages, chose "20.04 LTS Focal Fossa"

Yes - that is I what have done about 14 times now.

No, first it's a black screen with a small icon that resembles a keyboard and equal sign and small stickman. Pressing SPACE, a screen loads with Help, Language, Keymap, Modes, Accessibility, and Other Options (using F# keys) as the bottom menu and above that menu, it gives me options:

Try Ubuntu MATE without installing.
Try Ubuntu MATE without installing (safe graphics)
Install Ubuntu MATE
Install Ubuntu MATE (safe graphics)
Test Memory
Boot from first hard disk

and I highlight Install Ubuntu MATE which provides a line beneath that says:
Boot Options: 'ubuntu-mate.seed only_ubiquity initrd=/casper/initrd quiet spalsh ---|

I hit ENTER on highlighted * Install Ubuntu MATE

No, now there is a "install (as superuser) "Welcome"" screen.

Chose English
Chose Keyboard (US)
Chose I don't want to connect to a wi-fi network right now
Chose Normal Installation
Chose Erase disk and install Ubuntu MATE
Chose None selected (Did NOT choose Advanced features).
Did NOT use "Something else"

Clicked "Install Now" and next screen said: (not that they can talk)

The partition tables of the following devices are changed:
partition #1 of SCSI2 (0,0,0) (sda) as
partition #5 of SCSI2 (0,0,0) (sda) as ext4

Clicked continue...
Clicked defaults of:
Where are you? New York
Asked for and entered data for Name, comp name, user name, pword etcetera and Chose Require my password to log in

Welcome to Ubuntu MATE
copying files

then later...

Installation Complete (as superuser)

There is no mention of removing anything.. So I leave it in this time and click "Restart Now"

After Restart, I get the remove installation device. Removed USB and clicked "Continue..."

It reboots to a black screen, HDD spins wildly for a while, then it stops, and fan and screen are only things working again.

So then I tried another thing:

Do a hard Shutdown (hold power button down) because no help from UM to 'Restart'.
Insert that ^%$# USB thing.
Reboot and let it boot from HDD.
Get Dark-grey screen with darker border. Wait for it:
Border disappears and desktop shows up with Login.
I enter password, press Enter

and the screen goes totally dark grey, menu vanishes, mouse/cursor freezes, keypad light goes out and the HDD action stops, and the Ltop is a paperweight.

CONCLUSION: It's gone from OK so long as it's not sleeping, hibernating, or Shutdown to Freddy Kruger installed himself.

I will try again, this time I'll try it again by connecting to the network before install so it dloads the patches and fixes BEFORE it's done installing - maybe this time it will work. But I've tried it this way a couple of times before.

Please ♫
When it first installed and dtop and all worked, before the shutdown bug, I set the screen to solid color of Dark Grey. After shutting down for the night, and restarting, is when the bug begins and after re-install goes to a dark grey screen. Even after busting out partitions, and re-partitioning.

Know where I can get a large bottle of Pzozac? :woozy_face:


I think the issue is with the display driver ...
can you boot again and edit the boot line (press 'e') and add nomodeset after the quiet splash
(in effect, tell the system to boot via a generic graphics driver)

see this link for images

Have I asked the model of this laptop (dell, toshiba, asus, acer, ...) ?
you may need to pass other parms in the boot line to get the laptop to start properly.

I disagree with it being the display on this Toshiba Sat a660 because it worked fine the first time UM was finished installing and rebooted and all was very nice. I installed and tried TOR without any glitches. When headed to bed, I "Shutdown" the ltop. The next day, reboot to a black screen nightmare began.

Some 20 now re-installs, the last re-install I did as you suggested with the "nomodeset" edit it and there being no "Save changes" button, I pressed F10 and hoped it would Save before it re-booted. Now itboots to what reminds me of my old Atari 130XE screen. But screen is there. Then a screen said done installing updates, or words to that affect, and I restarted, and voila! Back to the ^%$%#@ black screen again. No mouse, no keyboard and only only one cursor - ME!

So, again, I reboot, break into the Grub editor, edit again and re-add nomodeset again, and pressed F10 again (I assume it saves the changes) and I am met with the black screen. So again, I reboot, and break into Grub, and edit the line again adding nomodeset again. This tells me Grub doesn't save the changes... only processes the edited version, then reverts to it's old Kruger self. I wish there was a way to add a bat file to do that edit each time at boot, then I'd have time to get breakfast.

This is not good. It is a device that meets the requirements as published. I can read and follow instructions, and research when the instructions or parts are for level 10 geeksters, then press the right keys. It installed fine - please keep that in mind, but every time it's when I restart the ltop that it reverts back to booting to a black screen. Even now with crippled visuals, I have to edit that same file just to get cheap graphics.

If the nomodeset option works, you can make it permanent by sudo vi /etc/default/grub or some other editor you know, find quiet splash, add nomodeset, save, exit, then sudo update-grub

it would look like GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

I cannot explain why install worked the first time but any subsequent install fails with black screen.

Hi Internaut,

it may also be down to hard drive failure?, how old is the drive and what type is it?. Maybe investing in a new SSD might solve all your problems?. Or, if you have another drive lying around that you could swap out, try that!.

1 Like

Hi Internaut, I am amazed that you spent so much time trying to install and troubleshoot a distro that obviously has serious problems and was rushed to production. Personally I could not install it on my Lenovo T420 laptop. Dedoimedo only gave UM 20.04 a 6.5 out of 10 rating in his recent review. Why waste any more time with this distro? Linux Mint MATE offers a MUCH better experience!

Now, I have to agree. I even bought a new HDD, and even UBMate has the same issues - I get a nice kiddie-kewl black screen with a grey margin around it. Maybe I have to color it in? :slight_smile: Odd though, it had UBMate 16.x() on it and that installed fine when it was done. Whatever, I need to go back to my life and move on.

Wasted so many hours, days and frustration learning what a UEFI is, and all the other gobbledygook. I got fed up and put Windows Spy10 on it. DONE! No need to tweak anything, no need to learn any new programming language, no more pulling hair and inventing mnew curses about camel fleas and what they can do to 20.

BUT, I have another laptop with Ubuntu MATE 18.(whatever ver) and will continue to use that too.

I will look into Linux Mint MATE - and many thanks for the tip.

Off to fine Linux Mint MATE

Do ridiculous comments fall on deaf ears?

1 Like

No, people are free to their opinions.

To especially, @pavlos_kairis , @wolfman, @rbeltz48 and @colinux.

I re-read my OP and then realized that thew title may seem to point to UM as being the culprit, and it is not. I'm sure it slips on as easily as putting on our socks - - - for most people.

As the saying goes, 'we create our own nightmares' .

In short, I too believe it must be the video driver. Why it worked with UM 16 and not 20 is for the techies and such to ponder.

The tech stuff:
At one point during install, I was asked if I wanted the genic, or 3rd party drivers. I chose 3rd, as it was "recommended" at install. This installed the nVidia driver, and that, is where I think it went south.

This time around, I said no and accepted the generic driver. So far, all is good, and it can come out of sleep, or screen saver to login instead of a black screen.

I must confess, that I did install, without any issues, Linux Mint Mate. And there too, I took the generic graphics driver over nVidia's. I had also install a new HDD and tried UM, again through the new drive and accepted the UM nVidia driver, and again without and the same thing happened... black screen.

Someone asked what kind of ltop is is. It's a Toshiba, and I think I had mentioned it somewhere. I know every ltop can have a mean streak in it when it comes to installing anything. But my aim is to try UM 20.04 out and if it is in good working order, then buy a brand new ltop and put it on that, with no Windows at all. If all is successful, I intend to switch everything over to Linux and leave Microsoft in the dust. I have been promoting it to my family and friends and hope they will join me and use the better O/S.

If I could edit the Title of this post, It would read the same, but add "for this noob".

Everyone has been very helpful, and even if the answer didn't work, I learn a lot from it all. Many thanks to everyone that responded. Whether you realize it or not, your participation is greatly appreciated.