Installing Recommended Mesa driver problem

Downloaded from here:

Extracted tar to downloads.

then open terminal on the folder location and did:

./configure (works)
make (doesn't detect the make file)
sudo make install (also not working)

I checked the folder and there is a and another

Can anyone help me install it properly?

Hi @Pablo_Perez_Gutierre,

I haven’t tried/used it but you can take a look here:

Are you sure ./configure actually worked?

Here’s a preview of what I had to do in order to get configure to run to the end with no errors on 16.04:

 1973  wget -c
 1974  tar xvf mesa_12.0.3.orig.tar.gz 
 1975  cd mesa-12.0.3/
 1976  ls
 1977  ./
 1978  sudo apt install autoconf
 1979  ./ 
 1980  ls
 1981  make
 1982  ./configure 
 1983  ls
 1984  sudo apt install pthread-stubs
 1985  apt-cache search pthread
 1986  sudo apt install libpthread-stubs0-dev
 1987  ./configure 
 1988  apt-cache search glproto
 1989  sudo apt install x11proto-gl-dev
 1990  ./configure 
 1991  apt-cache search libdrm
 1992  sudo apt install libdrm-dev
 1993  ./configure 
 1994  apt-cache search dri2proto
 1995  sudo apt install x11proto-dri2-dev
 1996  ./configure 
 1997  apt-cache search dri3proto
 1998  sudo apt install x11proto-dri3-dev
 1999  ./configure 
 2000  apt-cache search presentproto
 2001  sudo apt install x11proto-present-dev
 2002  ./configure 
 2003  apt-cache search xcb
 2004  apt-cache search xcb | grep dev
 2005  sudo apt install libxcb1-dev
 2006  ./configure 
 2007  apt-cache search xcb-dri3
 2008  sudo apt install libxcb-dri3-dev
 2009  ./configure 
 2010  apt-cache search xcb-present
 2011  sudo apt install libxcb-present-dev
 2012  ./configure 
 2013  apt-cache search xshmfence
 2014  sudo apt install libxshmfence-dev
 2015  ./configure 
 2016  apt-cache search x11-xcb
 2017  sudo apt install libx11-xcb-dev
 2018  ./configure 
 2019  apt-cache search xext
 2020  sudo apt install libxext-dev
 2021  ./configure 
 2022  apt-cache search xdamage
 2023  sudo apt install libxdamage-dev
 2024  ./configure 
 2025  apt-cache search xcb-glx
 2026  sudo apt install libxcb-glx0-dev
 2027  ./configure 
 2028  apt-cache search xcb-dri2
 2029  sudo apt install libxcb-dri2-0-dev
 2030  ./configure 
 2031  apt-cache search libudev-dev
 2032  sudo apt install libudev-dev
 2033  ./configure 
 2034  apt-cache search libomxil-bellagio
 2035  sudo apt install libomxil-bellagio-dev
 2036  ./configure 
 2037  apt-cache search llvm
 2038  sudo apt install llvm-3.7-dev
 2039  ./configure 
 2040  sudo apt install llvm-3.7
 2041  apt-cache search llvm
 2042  sudo apt install llvm-3.8-runtime
 2043  ./configure 
 2044  apt-cache search llvm
 2045  sudo apt install libc++-dev
 2046  ./configure 
 2047  apt-cache search llvm
 2048  sudo apt install llvm-runtime
 2049  ./configure 
 2050  sudo apt install llvm-config
 2051  apt-cache search llvm-config
 2052  apt-cache search llvm
 2053  ./ --with-gallium-drivers=r600,swrast

By command 2053 I was pulling my hair out. This was the last one I felt like trying.

@ouroumov @wolfman

Not working, Here is the error I get when doing ./configure on mesa 12.0.3

configure: error: in `/home/pablo/Descargas/mesa-12.0.3':
configure: error: The pkg-config script could not be found or is too old. Make sure it
is in your PATH or set the PKG_CONFIG environment variable to the full
path to pkg-config.

Alternatively, you may set the environment variables PTHREADSTUBS_CFLAGS
and PTHREADSTUBS_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

To get pkg-config, see
See `config.log' for more details

So I went to pkg-config page, downloaded latests pkg-config, ran ./configure and got:

configure: creating ./config.status
config.status: creating glib.spec
config.status: creating Makefile
config.status: creating glib-config
config.status: creating gmodule/gmoduleconf.h
config.status: creating gmodule/Makefile
config.status: creating gthread/Makefile
config.status: creating docs/Makefile
config.status: creating docs/glib-config.1
config.status: creating tests/Makefile
config.status: creating config.h
config.status: config.h is unchanged
config.status: executing depfiles commands
config.status: executing default-1 commands
creating glibconfig.h
glibconfig.h is unchanged
config.status: executing default commands

so I ran make and got another error:

collect2: error: ld returned 1 exit status
Makefile:388: fallo en las instrucciones para el objetivo 'testglib'
make[4]: *** [testglib] Error 1
make[4]: se sale del directorio '/home/pablo/Descargas/pkg-config-0.18.1/glib-1.2.8'
Makefile:476: fallo en las instrucciones para el objetivo 'all-recursive'
make[3]: *** [all-recursive] Error 1
make[3]: se sale del directorio '/home/pablo/Descargas/pkg-config-0.18.1/glib-1.2.8'
Makefile:322: fallo en las instrucciones para el objetivo 'all'
make[2]: *** [all] Error 2
make[2]: se sale del directorio '/home/pablo/Descargas/pkg-config-0.18.1/glib-1.2.8'
Makefile:428: fallo en las instrucciones para el objetivo 'all-recursive'
make[1]: *** [all-recursive] Error 1
make[1]: se sale del directorio '/home/pablo/Descargas/pkg-config-0.18.1'
Makefile:227: fallo en las instrucciones para el objetivo 'all'
make: *** [all] Error 2

Thanks for trying to help, I think configure doesn't detect and makefile or in case of mesa doesn't even create it.

Hi @Pablo_Perez_Gutierre,

did you try using the following terminal commands (Ctrl + Alt + t) from the link I posted?:

sudo add-apt-repository ppa:paulo-miguel-dias/pkppa

sudo apt-get update && sudo apt-get dist-upgrade


Are you sure it’s a good idea to try to build and install Mesa from source if you’re stuck at the compilation process? If you really want to, you can check the GOL wiki that has a guide. Warning: it’s for Debian, it might have to be adapted for Ubuntu on some points.

If you’d prefer an easier way to install a newer version, you have these possibilities:

  • Padoka’s Mesa Stable: currently at version 13.0.3 (latest one is 13.0.4). Please note that there is a bug in the LLVM version he provides that displays icons in Gtk2 apps with a pink tint.
  • Padoka’s Mesa Devel: devel version from GIT. Available for Xenial and Yakkety
  • Oibaf’s Mesa Devel: devel version from GIT. Available for Xenial, Yakkety and Zesty.
  • Xorg-edgers: devel version from GIT. Available for Trusty, Xenial, Yakkety and Zesty. The version for Trusty is way older. The PPA also includes newer devel versions of X.

Using the devel version will bring you the most up-to-date version of Mesa but be aware that: 1) you’ll get very frequent updates (sometimes several on the same day), requiring you to restart your PC every time; 2) the devel version can (and will) have occasional bugs, which range from small graphical glitches to crashes or even complete breakage of the X server, so it’s important that you’re able to fix your system if that happens (i.e. be able to log in on a TTY to purge the PPA to get back to the repos version) −it’s especially true for the Xorg-edgers PPA, which provides updates for the X server, which adds to the chances that you’ll break your system with a random update at some point.

Of course, never ever try to use several of these PPAs at the same time, choose one. Now, if you want to use Mesa devel and hesitate between Padoka and Oibaf, they’re slightly different on the packages they provide, though the main Mesa version should be about the same. Check the packages list and versions on each PPA page.


Thanks a lot really helped, went with padoka stable you said in your first post. Used @wolfman commands, so far so good.

if not I’ll try your other options, again thanks a lot

1 Like

Mesa 13.0.4 is not in a PPA (Padoka’s stable one has 13.0.3), you’d have to build it yourself. But apart from that, it’s a stable release, so no specific problems AFAIK.

Now, if you’re talking about problems like the pink tint on some icons, the issue with Padoka’s PPA is not with Mesa but LLVM. If Padoka updates his PPA to 13.0.4, it’s likely that the LLVM package stays the same and thus the issue too.

Mesa 17.0 stable (which is in fact Mesa 13.1 but the devs decided to change the version format) is supposed to be released later this month, so I guess Padoka will package it, probably with LLVM 4 that fixes the bug.


PSA: Padoka just upgraded his stable PPA to Mesa 17.0 RC2. I can confirm that it fixes the problem with icons. It’s a RC but I guess there are no serious issues.

1 Like

There’s another PPA I completely forgot about: Ubuntu X team, the stable version of xorg-edgers. According to an article on OMGUbuntu, it just added the current version 13.0.4 of Mesa stable. I haven’t checked if the LLVM version it provides (3.9.1) has the icons color issues.

So, to sum up the current options:

  • Padoka stable: currently has Mesa 17.0 RC2 (stable)
  • Padoka devel: Mesa GIT
  • Oibaf: Mesa GIT
  • Ubuntu X team: Mesa 13.0.4 (stable) + (stable)
  • Xorg-edgers: Mesa GIT + GIT

@terzag thanks if not going to try your other options