Internet connection not working 17.04

I have a 2008 iMac running Ubuntu MATE 17.04, and none of my internet connections are working. I tried wi-fi and mobile broadband, none worked. It says i’m connected, but i can’t connect to any websites.

1 Like

To be clear: did you try lan?

1 Like

I don’t have LAN at my house. I tried Wi-fi from my phone and my USB mobile broadband

I’m guessing you need firmware. You might be able to install them from the install medium. Or you can use a generic wifi adadapter and see if that works.
(sorry if i’m not really helpfull atm. I’m cooking :slight_smile: )


no problem, thanks for the help!

[quote=“Chopto, post:1, topic:13567”]but i can’t connect to any websites.[/quote]Just to confirm something…

open a terminal and execute the following:

ping is one of OpenDNS’s DNS servers, a server of which I know it will respond to a ping. This is just to confirm or deny the actual connection. You see, you might have a connection without being able to open a website. In that case, it’d be a DNS configuration issue.

Just post the result of the ping.

A successful one would look something like this:

PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=58 time=9.48 ms
64 bytes from icmp_seq=2 ttl=58 time=8.85 ms
64 bytes from icmp_seq=3 ttl=58 time=9.02 ms
1 Like

Ubuntu MATE 17.04 has DNS issues on some systems. This is why you can connect, but not go to any websites. Please read the following post for a solution.


That works just fine

[quote=“Chopto, post:8, topic:13567, full:true”]That works just fine[/quote]See steven’s post then:

Did that, still doesn’t appear to be working.

Tried that, still no luck. Ubuntu 14.04 also didn’t work, i suspect this has something to do with it being a Mac? When I (for example) google something, it just says “Server not found”. I haven’t found anyone who has run to the same issue while installing any version of Ubuntu on to a Mac. Maybe I’ll just install Mac OS on this one and sell it, buying a better Linux PC with the money?

I have 17.04 installed on a late 2008 MacBook and everything is working. However the MacBooks WiFi card quit several years ago and I’m using a USB WiFi adapter I had laying around. So unable to test that for you.

I have to say what you have described still sounds like a DNS problem to me.

Please test one more thing before giving up.

I’m going to have you ping google two different ways.

First in a terminal run the following command


you should get a result something like

PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=47 time=32.9 ms
64 bytes from icmp_seq=2 ttl=47 time=34.2 ms
64 bytes from icmp_seq=3 ttl=47 time=33.8 ms

Next run the following command in a terminal


you should get a result something like

PING ( 56(84) bytes of data.
64 bytes from ( icmp_seq=1 ttl=52 time=58.2 ms
64 bytes from ( icmp_seq=2 ttl=52 time=58.0 ms
64 bytes from ( icmp_seq=3 ttl=52 time=59.3 ms

So here where the rubber meets the road. If you can successfully ping but you can not successfully ping then you most definitely have a DNS problem that needs to be resolved.


Domain Name Servers (DNS) are the Internet’s equivalent of a phone book. They maintain a directory of domain names and translate them to Internet Protocol (IP) addresses.

Basically when you enter into your web browser, DNS tells your web browser to go to They are one in the same, but with out DNS your web browser can not find it’s way there.

See more here

Please report back your results.

Edit: If you have enabled a Firewall, disable it while you are conducting the ping test.

1 Like

Okay I can’t quite explain what i actually did (because i don’t know) , but everything works now. Thanks!

Excellent, please mark your post as solved to help other find a solution in the future.

1 Like

Hello there
I have an Acer laptop running Mate 16.04 & am having the same issue. I have followed the instructions all the way down to pinging the Google address, & it can't do that.
'unknown host'
I understand that means it's a DNS issue, but don't have a clue what to search for, to resolve the DNS issue. I'd be so grateful if you could give me a pointer. I'm a total novice!
Thank you so much!
P.S. every now and then, I get a connection.
I have tried different connections, not just wifi. All the same. Different browsers, too.

I have just followed the link above, & now it's fixed!
Can any one tell me what changing the ipv4 setting to 'Automatic (DHCP) addresses only' & the DNS servers to actually did, & is this something I'll need to do again, please, when I boot up, next?
What was the actual problem.

Sorry if Im neing thick, but the other info in the post seems to refer to a Mac.

Thank you so much!