Issue shutting down 16.04: at-spi-registryd.desktop

Hi everyone,

I’m new to Ubuntu MATE (I installed the 64 bits 16.04 version), and I’m having a problem when shutting down both my laptop and my desktop PC. After customizing the appearance a little bit, I keep getting a message when I try to shut down both my computers.

The message says that this program (at-spi-registryd.desktop) is still running. It doesn’t stop running and when I force the computer to shut down, it takes ages to do it.

Does anybody have an idea why this is happening?

I appreciate your help.

1 Like

I have also seen this problem, but only in a virtual machine. Its Assistive Technology, are you using it?

If not, just disable it in your startup menu.

I already tried that and it didn’t work. I saw it in some Ubuntu threads from 2009 and 2014. I disabled all the assistive technologies in the startup menu but it kept happening. I even removed them all, but after removing Assistive Technologies, the Change background menu just stopped working. And I’m not using a VM.

Instead disable the executable


and leave it installed.


I disabled that executable in my laptop and it worked. Thanks for your help, v3xx. :thumbsup:

The at-spi2-core folder doesn’t exist in my desktop PC. I uninstalled Orca and Onboard and left Assistive Technologies installed. I disabled all assistive technologies in the startup menu, and I also switched from Cupertino to Redmond in Tweak. The message just disappeared when shutting my desktop PC down.

Thanks for your help, again. I really appreciate it.

How do you disable the executable?


1 Like

I tried this solution in post #18 and worked for me


First, sorry that I didn’t make it back in time to answer, but you got it :slight_smile:

I think its just necessary to rename at-spi2-registryd but I’m getting picky :slight_smile:

Do you by chance have Nemo File Manager installed. I am wondering if it could be the problem.

My file manager is CAJA 1.12.7

Hi Alex,

I don’t know if this might help you, but I think you can run sudo caja in the terminal and then go to

as v3xx said. As running sudo caja opens the file manager as superuser, you can then rename the at-spi-registryd file to disable it. Actually, I just changed the permissions so that it wouldn’t be executed as a program, but I think the other solution might work as well.

I hope this helps.


Yes, just uncheck the box that allows it to be executable. Also gksudo should be used with caja or with any gui app you wish to run with sudo privileges. Run in terminal.

man gksudo


I run many LTSP clients with 64-bit Ubuntu MATE 16.04.6 LTS with all installed upgrades. No PPAs are added to the system.
It became very annoying to see this message on shutdown or reboot:

A program is still running:

Not responding

Waiting for the program to finish. Interrupting the program may cause you to lose work.
[Lock Screen] [Cancel] [Reboot Anyway]

And what is interesting, I have never seen this error on 32-bits of Ubuntu MATE 16.04 LTS. This problem seems to exist only for 64-bit OS.

What is a current state of this problem? Does it related to bug 1605224?

The message stopped to occur after manual remove of executable bit with

sudo chmod a-x /usr/lib/at-spi2-core/at-spi2-registryd

and reboot (or rebuild LTSP image in LTSP case).

This problem is also present in Linux Mint 20, some 11 years after first being reported in Ubuntu. The file is in a different location, so I fixed it by renaming it thus:
sudo mv /usr/libexec/at-spi2-registryd /usr/libexec/at-spi2-registryd.disabled

Thanks for all the prior replies, which pointed me in the right direction.