Issues with Libreoffice Calc

G’day all, just updated my mate installation (16.05 LTS 4.5.0-040500-generic) and I have a contents overwriting problem in Libreoffice Calc. (yes updated that too to version Version: Build ID: 1:5.1.4-0ubuntu1).

If this is not a place for this application then please direct me to the right place, I’m guessing there is a libreoffice forum somewhere, but to be honest this is a trusted group :smile:

In essence if you enter into a cell then try to delete or overwrite the contents, both old and new are superimposed together during the overwriting (rather than the expected behaviour of showing the new entry) until you TAB or ENTER to different cells. When I’m making entries, particularly for finance sheets.

Has anyone seen this before or know possible solutions, or even what information I would need to gather?

I posted at pic at in where the uppermost cell in column C I have deleted the text in the cell (see cell contents bar) but still see the old contents in the cell.



Have you tried reinstalling it? You can do this using the Software Boutique.

Hi yes I could re-install, I have not at this point as I would of hoped this would be something not requiring a full re-install. The software has always been more robust that that

Hi Andy,

have you run a full system update?:

Evening WM, yes fully updated and no de[dependency issues that I can find. I always do the updates through the command line as it is.

If this has not been seen before a removal and reinstall of LibreOffice may be the only thing, I was hoping it wouldn’t come to that.

Interestingly there is no uninstall option in Boutique for Libreoffice. Bug?

Also uninstalling via synaptic has some interesting side effects in that removing the libreoffice-core package also removes the other packages. At this point after a reboot, Boutique does not recognise that LO is not present. Installing via synaptic meant going through the packages one by one and marking for installation as the -core only installed the core not the applications… another bug?

To note, doing a “reinstall” through synaptic had no change on the symptom.

Post install again the problem has gone away BUT all the style and visuals are screwed up…sigh. helptext here I come.

Hi Andy,

if you want to remove and re-install LO, the easy way is a single command instead of picking out individual packages is with the following terminal command (Ctrl + Alt + t):

sudo apt-get update && sudo apt-get remove libreoffice && sudo apt-get install libreoffice

Hi WM, interestingly that was the first command I tried before posting, as it didn’t solve the problem, but to be correct I executed them individually instead of inline.

The issue originally reported seems now to be solved but LO now seems not to be pulling through the window configuration settings, see the links below, the toolbar text is not pulling through the system theme/style and the menu the same. Very strange, there must be a setting or selection somewhere. I’m thinking this is probably one for the LO forums but any thoughts?

For some reason the links are not showing up, just blocks for pictures, but they work.


I think that you can only do something if you have active fields?, try typing something in a box and then see what happens?.

Have you also tried a different desktop theme?. :smiley:

Hi WM, yes the original problem was from entering in active fields, that seems solved. Now its a theme/style issue. I don’t actually want to change my whole desktop theme and shouldn’t have to because of one rogue app. Libre office seems to be the only app that has a grey menu bar with grey text regardless of theme, and the menu style is not the system style as it is supposed to be. minor but an incredible annoyance

So perhaps a full remove and reinstall is needed, would a --purge in apt-get be useful and clear out my .local and .cache settings you think?

Hi Andy,

I honestly don't know but mine seems to be fine without anything in the fields so I think it is indeed theme related!:

I dont understand what you mean, what I’m describing is that LO will not pull through the system theme post reinstall, it seems to be defaulting to grey/grey menu bar and menu styles that are not consistent with the rest of the system. odd. I have looked through as many settings as i can find.

Thoughts on the --purge? This should get rid of the config too which may be the issue?

Thanks for the help so far

1 Like

Okay, firstly, did you follow this advice when you first created your bootable media which might be the cause of your sorrows?:

Secondly, did you do a full system update and run any fix commands?:

The terminal commands (Ctrl + Alt + t) in question are the following:

sudo apt-get --fix-missing install

The above command downloads and installs any missing packages on your system.

sudo apt-get --fix-broken install

The above command downloads and installs any broken dependencies on your system.

For a fresh install and keeping your data intact which should overwrite any .config files:

Purge will not remove the .config file in your home directory. Perhaps rename that file (keep for backup) and see if it will rebuild.

So I managed to solve the issues by doing what I didnt really want to do, a full uninstall through synaptic, getting rid of the .config directory, full purge, autoremove, clean, upgrade, fic-broken etc and reboot a couple of times. Manually went through my ~ and deleted references to libreoffice, reboot and reinstall in the usual (simple) way (sudo apt-get install libreoffice) - boom! All good, both issues resolved. Interestingly sudo apt-get remove libreoffice didn’t actually remove anything and I had to use synaptic, but anyway sorted. Thanks to you all.

1 Like