Latest LIBC on Ubuntu MATE 18.04.6 LTS

Hi. I am using Ubuntu MATE 18.04.6 LTS with regularly installed latest updates for the OS, firmware, libraries, software etc. I did not want to upgrade to later version of the OS, because I have very old hardware.

Recently I've tried to install some newer software, but I could not run it because it required installation of the latest version of LIBC. When I tried to start one of these software I've got this error:
" > /lib/x86_64-linux-gnu/ version `GLIBC_2.32' not found

*** /lib/x86_64-linux-gnu/ version ` GLIBC_2.34' not found*** "

And what could be the easiest solution for this? How can I install the latest version of LIBC on Ubuntu MATE 18.04.6 LTS? Currently I have installed version 2.27-3ubuntu1.6.

1 Like

I'm sure you can install 22.04 in your old hardware (desktop/laptop). You can even test by trying a live iso which will not affect your existing env. Newer software uses newer libraries.


Welcome @griffin to the community!

You can force the install, but don't it will break your system an put you in dependency hell. I was there once and never again. Take Pavlos suggestion and install the newest edition or LTS edition of Ubuntu Mate, it will run just fine.

Linux gives you a lot of power and control over your OS, but the power to destroy it if you don't know what you are doing.


I wanted to install Ubuntu MATE 20 LTS, but it simply could not boot. The screen was black with blinking dash. I do not know whether the problem is with my motherboard BIOS, or maybe with the Geforce 9400 GT card.

People need more info to help you. Where did you download Ubuntu Mate? Did you check the hash? What did you use to extract and burn it to your USB drive? Can you run the live USB but not install? Sounds more like a corrupt USB drive than a computer problem.

That is not recommended because 20.04 LTS is already end-of-life and therefore out of support. It might be better to install 22.04 LTS

That is a well known nVidia problem which also crops up on 18.04 and 20.04 and is nVidia driver related. See this:

Have you tried NOT using the closed source proprietary nVidia drivers and use the open source free Nouveau drivers instead ? They are probably a much better fit for a 9400GT

(b.t.w. Open source drivers are almost always qualitatively better than their proprietary counterparts).


I have downloaded from the official Ubuntu MATE website for several times and I've tried with several USB drives, and every time the result was the same.

I did not have any problem with MATE 18 version, but with newer versions. The problem was with booting from USB device.

I have encountered this problem on only one of my (old) laptops.

Luckily there are several ways to write an ISO:

  1. directly writing the iso "as is" using "disks" or "dd". This uses the bootloader build into the ISO
  2. using something like unetbootin or ventoy which have their own bootloader build in.

Method 1 failed on that specific laptop, method 2 worked.


Oh before I forget. I remember a thing that @guiverc told me:


I guess we are missing some details ...

all we know there is a motherboard and a GT 9400 (I assume Desktop).
Do you use an SSD or a spin disk? basic specs? cpu, ram.

I build um22.04 daily on various equipment with different gpu's, do not have an issue.


How can I disable Nvidia drivers when booting from Ubuntu MATE 20.04 or 22.04 LTS DVD disk?

Is your CPU a 32 bit processor? I ask because the GT 9400 came out in 2008. That's about the time PC's crossed over from 32 bit to 64 bit.

1 Like

No. It is 64 bits, and I am using 64 AMD Ubuntu.

  1. When the bootmenu of the USB thumbdrive shows, you can choose for safe graphics mode. But try first without it.
  2. If the bootmenu of the USB thumbdrive does not show, you probably need another method to write the ISO to USB thumbdrive because it didn't boot anyway.