Lock Screen not working

Lock Screen is not working (in Impish), either from ctl-alt-L or from the item in the System menu.

Anyone else experiencing this?

1 Like

Not so far, from me.

But while Beta / Gamma testing :slight_smile: Impish a month or so ago, I tried pressing Ctrl-Alt-L to lock the screen about a minute after booting up, and the first time I tried that, I didn't see the screen lock. A few minutes later, a message popped up that said "Ubuntu has encountered an error" and lo and behold, the crash was caused by mate-screensaver. I didn't report it since I couldn't subsequently reproduce the bug; all the times I pressed Ctrl-Alt-L after that, the screen locked normally.

I sort of doubt a connection between my experience and yours, since you imply that pressing Ctrl-Alt-L multiple times or hitting the "Lock Screen" menu item several times still doesn't lock the screen.

Still, see if you get anything from either of these two commands:

dmesg | grep -i screensaver
grep -i screensaver ~/.xsession-errors

The former might print a message or several about a "segfault" caused by mate-screensaver; the latter might print something along the lines of:

** (mate-screensaver:431): GObject-CRITICAL **: 13:31:07.321: Assertion `something != NULL' failed

Either message would be useful for me to see, if the messages are indeed present. Please run these commands right after attempting to lock the screen; do not run them after a clean reboot and before you try to lock the screen again.

I hope these commands turn up some results. :crossed_fingers:

1 Like

Thanks for your input, gordon. It seems now that my issue is, in fact, intermittent.

I figured I'd attempt a screen lock and then run the commands you gave, and the attempt was a success! And, unsurprisingly, the commands gave no output.

I'll have to do some more troubleshooting to see if I can discern a pattern to when it works and doesn't work...

1 Like

I just made a fresh install of 21.10, have th esame problem. Clicking the gears top right and choosing lock screen I get no reaction.

grep -i screensaver ~/.xsession-errors
```[email protected]$ ~$ grep -i screensaver ~/.xsession-errors
mate-session[2484]: WARNING: Detected that screensaver has left the bus
** Message: 16:56:24.806: Screensaver is not running!
** Message: 16:56:37.635: Screensaver is not running!
** Message: 16:58:00.773: Screensaver is not running!
** Message: 16:59:28.374: Screensaver is not running!
** Message: 17:04:47.682: Screensaver is not running!
[email protected]:~$ 

I get one of these lines for each time I try.

I just started having this issue intermittently in 22.04. Sure enough, sometimes mate-screensaver wasn't loading, though it was set up properly in autostarts. I tried launching it manually from the commandline, and it said it wasn't installed. I went to install it, and apt said it was already installed! I tried launching it again, and it worked.
Not sure what's going on, but I'm sure it will be sorted out by April...