Macbookpro 10,1 not working with nvidia card

video

#1

I have a macbookpro 10,1 with a GeForce GT 650M Mac Edition
Running ubuntu-mate 16.10
currently using the Nouveau Drivers

Whenever I install the nvidia driver (both from additional drivers and from the updated ppa)the computer just boots to a black screen. I do get the mate loading screen, 5 dots, then black.

I did have 16.04 earlier in the year and I would get the display 1 out of 4 times (nvidia splash after the 5 dots)but after 16.10 and new nvidia drivers I can not boot to the login screen even after 8+ tries.

I have tried the bumblebee package but that requires an OS reinstall
nvidia-prime comes with the drivers but I do not see the option before I reboot

Any additional ideas to try getting it to work?


#2

You should first determine if that black screen means the computer froze I think.
When you get to the black screen hit CTRL+ALT+F1, if the computer is not frozen you should get access to a terminal login screen.


#3

Thanks for the reply. I have tried that in the past at the black screen with no luck. I’ve had to do a hard power kill and boot to recovery to remove the nvidia driver to get it back working


#4

I just tried doing a live install of 16.10 UM and I was getting a blank screen while It was loading, I could hear the boot up sound but still blank screen. After doing some research I found that adding nomodeset to grub fixed the blank screen and was able to do the install.


#5

I did use that originally to fix my system but with nomodeset I believe that it drop down to the intel integrated chip. This allowed me to get in to remove the nvidia drivers not to actually use it.


#6

Hi @rasb23,

try dropping your Nvidia drivers to version 304, I have had problems with my Nvidia card too and prefer to use that one!.

See also:


#7

Just tried it and it freezes at the 4 nvidia loading dots. These show up after the Mate loading splash and before the nvidia splash before the login.

driver version - 304.132

lspci:
01:00.0 VGA compatible controller: NVIDIA Corporation GK107M [GeForce GT 650M Mac Edition] (rev a1)

found this in syslog
Dec 13 10:54:57 matepro kernel: [ 10.828256] nvidia: Unknown symbol mtrr_del (err 0)
Dec 13 10:54:57 matepro kernel: [ 10.828398] nvidia: Unknown symbol mtrr_add (err 0)

which lead me here:
https://ubuntuforums.org/showthread.php?t=2306441

there was no real fix beside it now works. I don’t really want to downgrade to 14.04 to test this


#8

Hi @rasb23,

take a look at the Additional Drivers Tool and see if it offers you a higher Nvidia driver version!. :smiley:


#9

I’ve made some major breakthrough.

I found a guide for dual booting - which I thought I was going to end up doing - (seems to be down at the moment):

Two key changes:

  1. remove quiet splash from grub line:
    GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash”
  2. run nvidia-xconfig

Now I believe this fix is more about option 2.

Now I booted up with 367.57 and logged in with mate-optimus-applet crash (duplicate of 1599311)

But it seems to be mostly working. Going to see if Diablo 3 now works :wink:


#10

This thread is two years old, but I am actually facing the exact same issue and have been unsuccessful so far. That is, I have a 10,1 MBP retina that I tried to get any nvidia drive to work on but all that I get is the same black screen or the 4-dots freeze reported above. I tried various solutions and always had to revert back to the nouveau drive. In a few attempts I even had to reinstall since the “fix” actually messed with more things it should.
My question: is it really possible at all? You mentioned a “major breakthrough” but I tried to run nvidia-xconfig in some of those attempts and got nothing more than the black screen. Are you still managing to have a stable configuration with an nvidia drive on a MBP 10,1?
Is Diablo 3 still firing up? :slight_smile: