Make sound volume go over 100%


#1

Many times, while I am watching a video, I have to set the volume over 100%, especially when I’m not right in front of my laptop. To do so, I click the sound indicator on the system tray and then I click Sound Settings. From there I can use the slider to have the output volume over 100%, to my desirable volume.

It would be really convenient, though, if I could adjust the volume to be over 100% just using the indicator slider, without having to open the Sound Settings window.

What I am suggesting is that pressing the keyboard keys or using the mouse wheel on the sound indicator allows for the output volume to have a maximum value of 100%, while clicking on the sound indicator allows for the output volume to be over 100%.


#2

You can try adjusting both the normal and amplified volume setting in dconf editor>com>canonical>indicator>sound. I'm not on a laptop, I cannot test this.


#3

In the end, there are potentially four ways to adjust volume There is the primary software setting:

Then there is the secondary software setting:

Then there is the application-specific volume setting.

Then there is the physical volume control on your speakers.

Typically, if I have this problem, after making sure my primary and secondary software volume settings are set to 100%, I adjust my physical speaker volume until it is as loud as would ever want it to be. Then, following that, if ever I want to adjust the volume down, I use the secondary software volume setting or the application specific volume setting.

If all else fails, then I will set the primary software volume up until it reaches the point where it is as high as I would ever want it to be.

Do I take it you have explored all of these options and it still is a problem?

Sometimes, I hear, after setting the primary software volume to higher than 100%, it reverts back to 100% on the next login. If this is happening to you, I have a fix.

You would need to insert the following command into a new startup application entry:

pactl set-sink-volume 0 150% # max

Obviously 150% is VERY loud, so you might want to adjust that down a bit.

The way to set a new startup application, in case you don't know, is the following:

  1. go to System/Preferences/Personal/Startup Applications and click on the Add Button

  1. Put what you want in the "name" and "comment" fields. For the "command" field, paste the command, I mentioned above, into it (making sure to adjust the actual percentage to your own preference).

  2. Click "add" and then close the startup application dialog box.

That's it. From now on, when you log in, your underlying primary software volume setting will be whatever percentage you put in that command.


#4

I realized just now that I accidentally put this topic in the wrong category! :scream:
It was meant for “Thoughts & Feedback”. I’m changing that immediately!

Btw, these are great suggestions! :grinning: I have already tried some of them, but I’m not completely satisfied. I will try the rest of them and see.


#5

I have also found the settings for increasing the volume … still doesn’t seem to put out enough sound compared to running the same machine on Windows 10. Just saying. Bob


#6

The panel control applications for audio are limited to a few adjustments in Pulseaudio

pavucontrol is the main Pulseaudio mixer, with more control of Pulseaudio levels
There is option to have volume higher than 100%, but is very likely to sound distorted

If sound levels are still too low and level settings in Pulseaudio are ok, it is likely that audio level settings in ALSA need to be increased. This needs to be checked in alsamixer (or similar mixer with access to ALSA)

Sound levels are no problem on any of my Linux installations, including UM. This has more relevance than claim of better performance on non-Linux OS, but still completely useless for helping OP solve his audio problem


#7

Assuming you already have pulseaudio-utils installed:

The following command will shift the default underlying volume to whatever you want it to be:

pactl set-sink-volume @[email protected] 150%

You can see, above, I have set it to 150%. But, you could put any percentage in there.

Using the above method, you could have five such launchers sat side by side in a row with a volume setting of 100%, 110%, 120%, 130%, 140% and 150% respectively.


#8

@stevecook172001 He could try this script :slight_smile:


#9

That’s impressive Misko…:slight_smile: