Marco window manager crashes after reboot

Ubuntu 16.04.1 LTS
Mate 1.14.1 (also happened with 1.12)

After every reboot my Macro window manager fails. The min/max/close buttons do not respond, I can not move windows, etc. I order to fix this problem I need to go to System-> Preferences-> Look and Feel-> MATE Tweak, select the Windows icon, switch from Marco (No Compositor) to Marco (Software Compositor) and back to Marco (No Compositor) .
After this everything works.

How can I fix this problem? It happens with every reboot since the first install of Ubuntu Mate. Is this a Mate issue or another issue?

This is issue with mate-tweak .
Do this :

gsettings set org.mate.session.required-components windowmanager "marco" 

And you should be fine with restart ! To test this just logout and backin.

1 Like

No, this did not work, same thing as before. I wanted to attach a screen shot of the error but I don’t see the option to attach a picture.

The error under the Window manager of Mate Tweak is “You are currently using an unknown and unsupported window manager. Those we cannot guarantee that changes made here will be effective.”

Is Marco not the default window manager? There are three variants of Marco, the forth choice is Compiz. I have tried all four with the same problem.

I tried this as well and it did not work.

Replace mate window manager with openbox

Can you do " marco --replace " in terminal and give me the output ?

Thank you. After using the "macro --replace" I checked mate-tweak, the window manager section was blank. I reboot and the problem returned.

(I found the option to upload a graphic)

I looked at my ".xsession-errors":

openConnection: connect: No such file or directory
cannot connect to brltty at :0
mate-session[1544]: WARNING: Unable to find provider 'marco --replace' of required component 'windowmanager'
mate-session[1544]: WARNING: Unable to find provider '' of required component 'dock'
grep: /home/xxxx/.xinputrc: No such file or directory

** (process:1858): WARNING **: Warning: show_on_monitor_number is no longer a valid config option for the current version of Tilda.

** (process:1858): WARNING **: Warning: scroll_background is no longer a valid config option for the current version of Tilda.

** (process:1858): WARNING **: Warning: use_image is no longer a valid config option for the current version of Tilda.

(nm-applet:1843): Gdk-CRITICAL **: gdk_window_thaw_toplevel_updates: assertion 'window->update_and_descendants_freeze_count > 0' failed

(nm-applet:1843): GLib-CRITICAL **: g_hash_table_remove_all: assertion 'hash_table != NULL' failed

(nm-applet:1843): nm-applet-CRITICAL **: nma_icons_free: assertion 'NM_IS_APPLET (applet)' failed

(blueman-applet:1856): Gdk-CRITICAL **: gdk_window_thaw_toplevel_updates: assertion 'window->update_and_descendants_freeze_count > 0' failed
/usr/lib/python2.7/dist-packages/gi/overrides/Gtk.py:50: RuntimeWarning: You have imported the Gtk 2.0 module. Because Gtk 2.0 was not designed for use with introspection some of the interfaces and API will fail. As such this is not supported by the pygobject development team and we encourage you to port your app to Gtk 3 or greater. PyGTK is the recomended python module to use with Gtk 2.0
warnings.warn(warn_msg, RuntimeWarning)
sys:1: PyGIWarning: Caja was imported without specifying a version first. Use gi.require_version('Caja', '2.0') before import to ensure that the right version gets loaded.
** Message: Initializing gksu extension...

** (caja:1807): WARNING **: Can not calculate _NET_NUMBER_OF_DESKTOPS

** (caja:1807): WARNING **: Can not calculate _NET_NUMBER_OF_DESKTOPS

** (caja:1807): WARNING **: Can not get _NET_WORKAREA

** (caja:1807): WARNING **: Can not determine workarea, guessing at layout
Duplicate property or field node
Duplicate property or field node

I did not ask you to change the gsettings schema to “marco --replace” . Becouse of setting the schema as you did you get error :
mate-session[1544]: WARNING: Unable to find provider ‘marco --replace’ of required component ‘windowmanager’ .

So now do this to get things back to normal :

gsettings set org.mate.session.required-components windowmanager "marco"

Then run in terminal “marco” or “marco --replace” and paste me the output of the command.

I am sorry, I misunderstood. Thank you for your help.

$: marco
Window manager warning: Screen 0 on display “:0” already has a window manager; try using the --replace option to replace the current window manager.

$:marco --replace

(The entire screen rapidly flashes several times and then appears to hang. It does not display any text or errors. It does not return to prompt.
If I type Ctrl-C, it returns to the prompt but the original problem has returned.

Please install neofetch and post the results here:

sudo apt install neofetch
neofetch

This should result in something like:

The line with WM: Metacity (marco) is if interest here :slight_smile: But please post the complete info

And yes: this is actually one of my test computers at work :wink:

I had to add the repository, but I have used neofetch before on my laptop.

Yes, the computer is a few years old, but it works. I tried switching the theme and the problem remained.

I never asumed you didn’t use neofetch before I just like to be thorough :wink:

And now I am confused, the windowmanager is actually set to Marco… well… guess I am stumped.

Thank you for your help. I was commenting that I had used it before, I had forgotten about it. That comment wasn’t directed at you, that was a comment saying, “Oh wow, I forgot about that but I used it before.”

I am going to reboot and use neofetch. The error happens after a reboot…

After rebooting, I can not accesss the Applications/Place/System menu as the terminal’s "File/edit/view/search/… menus have replaced the top panel. I copied and pasted the text instead of using a screen shot. There is no window manager listed. I am guessing isn’t saving the WM config. When it reboots it doesn’t think there is a WM. Could it be a permission problem?

Model: Precision WorkStation T3400
OS: Ubuntu 16.04.1 LTS x86_64
Kernel: 4.4.0-42-generic
Uptime: up 1 minute
Packages: 2081
Shell: /bin/bash
Resolution: 1280x1024
DE: MATE
Theme: TraditionalOk [GTK2/3]
Icons: Mate [GTK2/3]
Terminal: mate-terminal
CPU: Intel Core2 Duo E6850 (2) @ 3.0GHz
GPU: NVIDIA G86 Quadro NVS 290
Memory: 557MB / 3885MB

So is this not a Mate problem? Does anyone have any ideas?

I have the same problem after upgrading to Ubuntu 16.04 (from 14.04) a couple of months before. This is the most informative source I could find then - so I am hoping to revive this as it has been silent now for months.

For me, too, a fairly old, 32bit machine is affected:
uname -a
Linux fliewatuet 4.4.0-51-generic #72-Ubuntu SMP Thu Nov 24 18:29:17 UTC 2016 i686 i686 i686 GNU/Linux

I am sure there are no (more) file permission problems (left) in the home directory (checked with find . ! -writable -a ! -path “/.git/” …). After reboot, with the problem (making sure the setting itself persists across boots):
gsettings get org.mate.session.required-components windowmanager
‘marco’

To be more exact: the problem does not occur on startup, but when logging in with mate. Some tests:

  1. Log in as affected user, do not fix window manager problem, log out, log in as not affected user, log out, log in as affected user: problem persists
  2. As above, but with fixing the window manager during first login: problem reappears.

So at least for me, this is a problem during initialization after login. These are my non-default settings for org.mate.marco.general:
reduced-resources true
side-by-side-tiling false
theme TraditionalOk

… resetting these does not change anything though.

I know a simple reproduction now, but I am still lost on how to analyze this further: Where would I look for logs for this? syslog and Xorg seem clean. Help!

I’ve been looking over the various solutions suggested here in trying to figure out what my problem is. I’m running Ubuntu Mate 16.04, a fresh install, on a dual new xeon system. I had a heck of a time getting the GeForce 1050 ti card to work, and mostly navigated through all of the roadblox (owing to this GPU not being supported by older versions of nividia-current in the repositories). But the final problem was that the window manager was not being loaded properly, and is not fixed by dconf settings. Symptoms were only one desktop and no control buttons, plus the menu items in each window didn’t work. Also mate-tweak window manager dialog showed “you are currently using an unknown and unsupported window manager”. Really annoying. I could of course open mate-tweak each time to reestablish the window manger but this is a pain (and I’m somewhat OCD). I also had similar problems with my fresh install of 14.04 but I don’t remember how I resolved that. I think they just went away after an update.

I’ve got a kludy fix that works. I figured out from the dconf site was to add a command to the startup applications (system.preferences.personal.startup-applications - click ADD):
marco-compton --replace
this could be also
marco --replace
or
compiz --replace
(I think - haven’t tried them).

The underlying problem(s) will hopefully be fixed in future updates.

Thanks for the reply - the suggested workaround is simpler than the initially mentioned workaround (and I have something similar, but less automatic in place, just a launcher of a script containing marco --replace &).

But what bothers me most is that I cannot find the cause of this with the OS of my choice.

I opened a support request for marco, https://github.com/mate-desktop/marco/issues/304 - hoping they can share some insight.

Happy New Year.

I was beginning to think I was the only one having this problem and I gave up. Thank you axm for opening a request.

I have noticed that my window manager is now blank. Everything "works", before it didn't, however there is no window manager listed.

Thank you for your answers .

my problem is very similar: on every login Marco is not running (probably it crash after login), so every windows miss the decorations.
I created a shortcut in the System Tool menu to manually start it, then everything work.

MATE Tweak report:
Windows manager: Marco (compositor GPU Compton)

Ubuntu 16.04, GPU nVidia G102M

very annoying, any suggestions?

I think I found a solution:

In the directory /home/USERNAME/.local/share/applications

Rename (or delete) the following files
metacity-no-composite.desktop.desktop
marco-no-composite.desktop.desktop
marco.desktop.desktop

and reboot. Those files are causing the problems.