MATE 15.10 cannot boot "...after message ignoring BGRT - [SOLVED]

Hello eveyone,

Yesterday, I was trying to fix a problematic flash of mine on my windows os, but in the process of doing so via disk management I mistakenly deleted the linux swap partition. When I rebooted my system to select Mate 15.10 I got this message:

0.0032442 ignoring BGRT: invalid status 0 (expected 1)

I restored the deleted linux swap using GParted and reinstalled/updated GRUB, but I still get the error message of which the system cannot proceed from there. I can wait for eternity and nothing will happen.

I don’t mind reinstalling OS, but I have my entire Moodle site it.

Can any one can help this?

Thank you.


you can try using "Boot Repair":

Or you can do a re-install and keep your data intact by using the "Something else method":

The file /etc/fstab contains the partitions that your system will mount at startup. When you create a new swap partition, it will have been assigned a new UUID.

You can quickly start a live session (via CD or USB) and locate this file on your installation (not to confuse with the live session's version!)

First, open GParted to find out the new UUID. It's under System → Administration and is available during live session by default.

Right click the swap partition and go to properties and keep a note of the UUID.

Next, mount the partition where Ubuntu MATE is installed. Clicking on the partition in the file manager will do.

Let's suppose your drive is mounted at /media/ubuntu-mate/mydisk/, open a terminal (CTRL+ALT+T) and type the following:

sudo nano /media/ubuntu-mate/mydisk/etc/fstab

Locate the line under where it reads:

# swap was mounted at /dev/xxxxx during installation

Delete the old UUID and paste in the new one (CTRL+SHIFT+V), be sure to keep the rest of the line intact.

Save your changes, and restart. The system should now correctly mount the 'new' swap partition.

Thank you! The article helped me solve the problem.

I highly appreciate your help. I went offline for a long time and was struggling with the problem not the installation, but with migrating the whole moodle site. I had been reading countless of articles, but I needed a more simple solution. I finally had install MATE as a clone of my previous broken MATE and then manipulate the moodle files to get it working without installing and going through all the lengthy processes.

Anyways, since I have fixed the site and its up and running perfectly; however, I will still mess up with the system exactly the same way and try out your solution; and that is after I have backed up the entire site and moved it to another PC; and will let you know if your solution worked for me.

Gracias, Iah7

HI, which did you use?; "Boot Repair" or the "Something else method"?. :smiley:

Please mark as so it helps others!. :smiley:

Something else method!

1 Like