MATE panel and Plank

I am using Plank. I’ve deleted the bottom default MATE panel. My Plank is configured transparent, bottom, auto hide, fill. This morning I found this entry in my Dell laptop syslog …
org.mate.panel.applet.MultiLoadAppletFactory[4783]: ** (mate-multiload-applet:4955): WARNING **: Failed to get pixmap 16779554,613,0
Dell laptop has UM 16.04.1 installed with MATE 1.14. I checked a default UM install in Virtual Box and did NOT find a similar message.

On my HP desktop UM 16.04.1 MATE 1.12 : I’ve deleted the bottom default MATE panel. My Plank is configured transparent, bottom, auto hide, fill. I found a similar message in syslog
Jul 26 14:54:46 HP-T org.mate.panel.applet.MateWeatherAppletFactory[3923]: ** (mateweather-applet:4190): WARNING **: Failed to get pixmap 16777498,1007,0

I haven’t noticed any visible symptoms on either system. I was investigating a request from @BenjaminNYC. My suspicion is this is somehow related to deleting the bottom MATE panel.

Hi @pfeiffep,

have you try restoring the bottom panel and restarting then deleting it again?. :smiley:

No I haven’t tried that. I’ll set up my instance in Virtual Box and give this a go!

This occurs during boot only … I’ve move Plank to the right side and added a panel to the install on my HP desktop.

And does that work for you?. :smiley:

No there's been no improvement. Since there are no visible symptoms I'll dive a little deeper.

Do you think this entry in fstab might be problematic?

Move /tmp to RAM

tmpfs /tmp tmpfs defaults,noexec,nosuid 0 0

Hi Peter,

I honestly don’t know?, did you write the script yourself and have you been playing around with “fstab”?. :confused:

I have eliminated the entry as being the cause since I don't have the same entry in my other machine.

I did add those 2 lines to my fstab. I added all lines after #Hide Windows ....here's my entire /etc/fstab

pfeiffep@pfeiffep-Studio-1749:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
#
# / was on /dev/sda5 during installation
UUID=f738d292-b96a-4157-a901-252a8fa2c404 / ext4 errors=remount-ro 0 1
# swap was on /dev/sda7 during installation
UUID=aae188ec-6170-434e-80ec-fb0b020827c6 none swap sw 0 0
# Hide Windows
UUID=D8143D2D143D104C /mnt/WinOS ntfs noauto 0 0
# Move /tmp to RAM
tmpfs /tmp tmpfs defaults,noexec,nosuid 0 0
# Add storage
UUID=031abbc5-60dc-4f45-9806-ee32774145b2 /ISO ext4 errors=remount-ro 0 1

Hi Peter,

here is mine and there is obviously a slight difference because you added your own bits & pieces:

wolfman@fred2:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda6 during installation
UUID=203e649c-a089-4616-88ab-ee70a1476566 /               ext4    errors=remount-ro 0       1
# /home was on /dev/sda7 during installation
UUID=c81df271-fc20-4d62-853a-93b7462ae7f6 /home           ext4    defaults        0       2
# swap was on /dev/sda5 during installation
UUID=33738544-3f99-4720-8ca4-0df28835f649 none            swap    sw              0       0
wolfman@fred2:~$
1 Like

I’ve noticed that failed to get pixmap errors are a result of making panels transparent. I haven’t been able to narrow this further.

Hi Peter,

have you tried using different themes at all?. :slight_smile:

I wasn't certain how this would help me narrow down the cause, but I decided to try a different theme in a virtual environment.

Confirmed that the problem existed in the VM
Changed theme 2 times
Rebooted VM on each change
The problem existed after each reboot

Possibly I'll set up the vm with none of my personal changes then add a change at a time.

###Nothing to do with Plank
This failed to get pixmap errors symptom doesn't seem to affect anything I can discern using my computer. It certainly is caused by setting top panel to 100% transparent background color

Here are the steps taken I used to prove this to myself.

reset VM instance to default desktop environment
restarted vm instance - no failed to get pixmap errors
added logout, weather, system monitor, & shutdown to top panel
restarted vm instance - no failed to get pixmap errors
to startup added HP, removed blueman
restarted vm instance - no failed to get pixmap errors
changed top panel to transparent background color - failed to get pixmap errors
changed top panel back to system default and restarted vm - no failed to get pixmap errors
deleted bottom panel, added Plank to startup and restarted vm - no failed to get pixmap errors
changed top panel to 100% opaque background color - no failed to get pixmap errors
changed top panel to ~50% opaque background color - failed to get pixmap errors
changed top panel to 100% transparent background color - failed to get pixmap errors
changed top panel to 100% opaque background color - no failed to get pixmap errors

This certainly is only a very minor problem, maybe @Wimpy might be interested.