Microphone toggle on thinkpad edge e540

I am using ubuntu mate 16.04 on a lenovo thinkpad edge e540. I’ve noticed that the microphone toggle key XF85AudioMicMute (same key as F4) is not working. I did not have this issue when using vanilla ubuntu where this key works out of the box. This seems a known problem, but despite several possible solutions found I have not yet discovered how to actually get the key working as a toggle. This is a recurrent problem as I have also experienced it when using other official ubuntu flavors. Everything else works fine nonetheless.
Does anyone know how to fix it? Thanks in advance.

Hi @fkuhn,

have you done a full system update as that may solve the problem for you with the introduction of new kernels?:

Hi wolfman,
thanks for your quick reply. I have done an update according to the welcome guide but it did not solve my problem. Note that in vanilla in ubuntu 16.04 which I had installed some hours before trying ubuntu mate, the problem was not apparent and the toggle key worked. AFAIK both are using the same kernel 4.4.0-21-generic, right?
I know directly mute the mic via the sound settings. Oddly, the small indicator led on the key is turned on to indicate the mic is muted.

I do not own one, but had a look around. This is dated, but parts may still apply.

Would a work-a-round be possible?

1 Like

Hi v3xx,
thanks for the reply. I have tried these guides but it still does not work. This is strange since it works in vanilla ubuntu but does not apply for any of the official flavours. I am not experienced in working with the audio servers but will still try to get it working when I have the time.


Dear @fkuhn,

I just found your topic and believe to be affected a similar problem [1].

Meanwhile, have you found a solution?

[1] How can I make my mute microphone button work?