Mouse Pointer Misbehaving after update

My mouse pointer started misbehaving after a big update, which followed the newest regular kernel update, a few days back - nothing buggy happened after the new kernel; but only after the subsequent update.

After a fresh boot, now the pointer is either invisible (but still able to fully operate, otherwise), or it is just a big X. However, as soon as I open an app, it will activate the pointer - and the rest of the session is normal.

I have done the easy stuff: tweaked Compiz, Appearances, and reset my default pointer in the system files, but no help; everything else is perfect, though but this single annoyance.

I was hoping someone knew of a fix; thanks!:relaxed:

Hi, again; this appears to be a fairly persistent issue in the Ubuntu world :neutral_face: so I was still trying to hold out for someone who could shed some light on the little update bug - and hopefully offer a workaround/fix

I tried the: gsettings set org.gnome.settings-daemon.plugins.cursor active false fix, listed in the the first (below) link, with no success; but I wanted to wait before I tried to engage the potential solutions/headaches in the 2nd link.

I am leaning towards just reinstalling, especially if this query stays inactive for much Ionger; it, conceivably, could be quicker and less of a hassle then venturing into the abyss of more exploratory OS torture :wink:.

The invisible cursor / big black X cursor sounds like a problem with Xorg, the display server.

Sadly, while I do not know of a fix or reason why a kernel update would break the cursor, there are a few things you could try to pinpoint if it's a system-wide or user profile issue.

  • Does it happen with Marco window manager?
  • Does it happen on the login screen or guest session?
  • Does switching to a console (CTRL+ALT+F1) then back to X (CTRL+ALT+F7) show anything different?
  • Do you have any proprietary drivers installed? I am presuming it's an Intel, in which case their display drivers are already part of the kernel.

The temporary workaround is to boot the older, working kernel by holding SHIFT at start-up, then choosing "Advanced options for Ubuntu", followed by the kernel before 4.2.0-27. If that solves it, then it's definitely a regression introduced in the new kernel, and you can save this as a permanent boot option for now if desired.

Might be overkill, if you know which update caused it, you can temporarily revert back to the older version of the affected package. There are a few ways to look up which updates you had installed.

Ok, @lah7, it is total fixed by changing over to Marko :joy: thanks :sweat_smile: ; but I so need Compiz :worried:.

I never really thought it was the kernel, but, instead, the subsequent (a few hours later), update - which, by the way, was mostly a Compiz update. This tells me to start with Compiz, obviously. I reinstalled it but that did not help; should I have, likewise, deleted some configuration files for Compiz, as well?

Or, should I go and try the update help which I have checked out via your link (I was not sure if my Synaptic reinstall changed the game somehow…

Thanks! :wink:

So, compiz is the culprit, no surprise there. I was thinking this is a problem deeper in the system, but thankfully, that's not the case. :slight_smile:

Resetting Compiz to the default settings may help. You can do this by clicking Reset Compiz in MATE Tweak (providing Compiz is actively running) - this will erase any customizations if you made any.


If that doesn't work, you can downgrade the package via Synaptic, like so:

Compiz highlighted → Package → Force Version...

Choose the older version, if available.

After locking the version, you may need to re-install what will now be the older version.


Coincidentally, compiz is upgradable for me via Synaptic, but I will wait until it appears in the Software Updater - in case it breaks my system too!

Okay, thanks; here I go… I’ll report back! :relaxed:

Well, I tried just about everything, and then I reinstalled the OS…

Can you believe it? - The exact same problem - after the final (compiz) auto-update. :scream:

I will try installing the community respin: UUMATE :dizzy_face:

I have UUMATE, this morning the update showed up on the Software Updater and I have the same issue. The X is somewhat useful in regards to accidentally closing pages and documents, but rather annoying on the desktop. Does anyone know if this will be corrected anytime soon?

Well, I wanted to help the project with this issue, in any manner which I could; :kissing_heart: so I went on and did the update on all of our family computers - and with the two different versions of 15.10 (UMATE & UUMATE) scattered between them. Verdict: this is a universal bug… at least over here, anyway. :neutral_face:

A workaround to this problem has, indeed, been found! :grin:

Make sure that you lock the previous version of Compiz before updating: or, if it is already too late… see @lah7’s above reply/images.

The version he shows corresponds with the versions at issue: the bad version of Compiz ends in 02; whereas the good one (old version) ends in 15.

@lah7, I had a bit of a debacle after resetting Compiz in MATE Tweak; and then I was prompted by Synaptic to check some other boxes, when doing the lock/rollback.

It took out a bunch more than it added - and when it was done, things were not right; so I started the quest.

All is perfect, now, as I locked the old version right after reinstalling UMATE15.10; but, crucially, until the lock was executed, I furthermore did not do that big hunk of 'new-install ’ updates (the ones right after the OS install - and that was where the Compiz bug, indeed, was). :wink:

Glad to hear it’s working again. One way to help prevent the issue happening again is to file a big report against compiz. The changelog might help identify some possible culrpits.

From what I can see, you’ve been updating via Syanptic, which may hold back some packages before they appear in the Software Updater. From what I recall, “early updates” may be available in Syanptic.

Believe, or not, these updates came out of the Software Updater; I have to wonder, though, why it is not happening to more folks - just a handful.

Well, I am, at least glad it is not annoying millions. That version of Compiz is the same one being put out by both Synaptic and the trusty updater… so, just in case, be particularly careful.

I would really like to know when it will be safe to upgrade Compiz, as well.

Thanks for hanging tight with me on this issue @lah7! :smile:

i have the same issue. Big X as my mouse pointer. Gonna try above mention methods for fix. I don’t wanna reinstall the OS. Let’s see what happen.

For reference, the change log only shows one change:

compiz (1:0.9.12.2+15.10.20151202-0ubuntu1) wily; urgency=medium

  • Screen: monitor root RESOURCE_MANAGER and update cursors when Size
    or Theme changes (LP: #1359211)

I just upgraded the packages and it hasn't affected me - but note I am using an NVIDIA card (GTX 960) with proprietary drivers.

i am using the NVIDIA card with proprietary drivers too. Mine is GT640 (nvidia driver 352.63)

@Buddhika_Jayasingha, if you do find that a reinstall is better than the big X :neutral_face:, or even worse: in those instances where the cursor is, instead, invisible - and you, then, realize that something should be addressed; than all will be well - so long as you lock the old version before doing any post (OS) install updates - ANY :cold_sweat: .

The lock must be executed to keep the group of packages which end in 15 - and not 02 :scream:!

I am on my second day of blissful mouse cursor behavior; plus, as an unrelated bonus: my boot time and memory usage has improved enough make it worth it :yum:.

I had mixed luck with the rollback: too many quirks afterward; so an OS reinstall had to do it. I am on my 5th month with UMATE, and this is the first, apparent, update bug; so I am okay with it - it is just my way of “testing” and learning fixes & workarounds :wink:.

Noted, @lah7, thanks!:smiley:

I guess you saw that the little pest has starting making its rounds; we have another X-er on the thread now - @Buddhika_Jayasingha - you can see if I lead him astray, at all :scream:.

It is very cool that you pinpointed the issue: Please follow this bug, if you would, and let us know when it is safe to upgrade :innocent:!

Here is the scoop, then:

http://www.ubuntuupdates.org/package/core/wily/main/updates/libdecoration0-dev

@lah7, being that this is the only package, with the only issue - and furthermore the only change in the aggregate of this update: then is this the only one which needs to be locked/rolledback to the earlier version? :smiley:

You raise a good point. It would be a good idea to lock versions for other compiz related packages, since having a mismatch of libraries will only lead to problems.