MPV Not working?

I can’t seem to play any videos, all it gives me is:

$ mpv --hwdec=rpi Desktop/...mkv
Playing: Desktop/....mkv
 (+) Video --vid=1 (*) (h264)
 (+) Audio --aid=1 --alang=jpn (*) (ac3)
 (+) Subs  --sid=1 (*) (ass)
mmal: mmal_vc_port_enable: failed to enable port
mmal: mmal_port_enable: failed to enable port (ENOMEM)
mmal: mmal_port_disable: port is not enabled
mmal: mmal_port_disable: port is not enabled
Could not open codec.
AO: [pulse] 48000Hz stereo 2ch float
Using software decoding.
Using conversion filter.
VO: [rpi] 1920x1080 yuv420p
mmal: mmal_vc_port_enable: failed to enable port
mmal: mmal_port_enable: failed to enable port (ENOMEM)
Could not initialize video chain.
mmal: mmal_port_disable: port is not enabled
Video: no video
A: 00:00:04 / 00:01:30 (4%)

Any idea?


did you install the Ubuntu codecs pack?, what I’m reading from your printout is it is codec related, have you also tried using a different player?.

sudo apt-get install ubuntu-restricted-extras

I think it's OpenGL related actually, 'cuz Kodi doesn't start either, telling me errors about libEGL.

What version of Ubuntu MATE?

I am using 16.04 Beta 2

Do you have drivers installed?:

You can easily check your GPU by opening a terminal (Ctrl + Alt + t) and typing:


scroll down to the bottom of the list and you will find something like this:

Uh... I'm on the Rpi3, there is no PCI. This is the Raspberry Subforum.. Or am I wrong here.

Anyway, I tried what the other user said and install the codecs, didn't solve it. I mean mpv uses the ffmpeg library anyway doesn't it.. so theres no need for additional codecs to be installed, as far as I can tell, It's an issue with the MMAL thing of the Pi, the Video hardware decoder or however its handled.

Sorry but I didn’t notice the Raspi part! :frowning:

Have you tried a different player and is the problem still the same?.

Have you done a full system update?. :smiley:

I tried Kodi gives me libEGL errors. My system is always up to date. I can’t do a reset tho as I actively use it as a home server.

Do you have "Welcome" installed and have you tried the repair function out?:

Welcome > Software > Fixes:

I’ll have to re-enable the UI I’ll try it later. Unless you know the terminal commands that button does then I can just run those via SSH.

Run the top two commands in this pic:

sudo dpkg --configure -a

sudo apt-get --fix-broken install

Restart after if anything updates!. :smiley:

Oh so its just dpkg/apt package error fixing, well no, none of my packages have issues. It's something with the VideoCore GPU, MMAL and OpenMAX something arround that, maybe non existant library files or wrong ones or a softlink not being correct (all guessing)

Hi @DeadSix27,

try the following command as it may be a case of missing dependencies?, the following command will force any bits & pieces that are/may be missing!:

sudo apt-get update && sudo apt-get dist-upgrade -f

Encountering the same issue with the released Ubuntu Mate 16.04, did install ubuntu-restricted-extras.

ffplay -vcodec h264_mmal /srv/player/data/media/571b9c29-530c-4e41-aa42-050eac110004/media/apple-tv-b1-2.mp4
ffplay version 2.8.6-1ubuntu2+rpi1~xenial1.8 Copyright (c) 2003-2016 the FFmpeg developers
  built with gcc 5.3.1 (Ubuntu/Linaro 5.3.1-13ubuntu6) 20160407
  configuration: --prefix=/usr --extra-version='1ubuntu2+rpi1~xenial1.8' --build-suffix=-ffmpeg --toolchain=hardened --libdir=/usr/lib/arm-linux-gnueabihf --incdir=/usr/include/arm-linux-gnueabihf --cc=cc --cxx=g++ --enable-gpl --enable-shared --disable-stripping --disable-decoder=libopenjpeg --disable-decoder=libschroedinger --enable-avresample --enable-avisynth --enable-gnutls --enable-ladspa --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --enable-libcdio --enable-libflite --enable-libfontconfig --enable-libfreetype --enable-libfribidi --enable-libgme --enable-libgsm --enable-libmodplug --enable-libmp3lame --enable-libopenjpeg --enable-libopus --enable-libpulse --enable-librtmp --enable-libschroedinger --enable-libshine --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libssh --enable-libtheora --enable-libtwolame --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx265 --enable-libxvid --enable-libzvbi --enable-openal --enable-opengl --enable-x11grab --enable-mmal --enable-libdc1394 --enable-libiec61883 --enable-libzmq --enable-frei0r --enable-libx264
  WARNING: library configuration mismatch
  avcodec     configuration: --prefix=/usr --extra-version='1ubuntu2+rpi1~xenial1.8' --build-suffix=-ffmpeg --toolchain=hardened --libdir=/usr/lib/arm-linux-gnueabihf --incdir=/usr/include/arm-linux-gnueabihf --cc=cc --cxx=g++ --enable-gpl --enable-shared --disable-stripping --disable-decoder=libopenjpeg --disable-decoder=libschroedinger --enable-avresample --enable-avisynth --enable-gnutls --enable-ladspa --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --enable-libcdio --enable-libflite --enable-libfontconfig --enable-libfreetype --enable-libfribidi --enable-libgme --enable-libgsm --enable-libmodplug --enable-libmp3lame --enable-libopenjpeg --enable-libopus --enable-libpulse --enable-librtmp --enable-libschroedinger --enable-libshine --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libssh --enable-libtheora --enable-libtwolame --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx265 --enable-libxvid --enable-libzvbi --enable-openal --enable-opengl --enable-x11grab --enable-mmal --enable-libdc1394 --enable-libiec61883 --enable-libzmq --enable-frei0r --enable-libx264 --enable-version3 --disable-doc --disable-programs --disable-avdevice --disable-avfilter --disable-avformat --disable-avresample --disable-postproc --disable-swscale --enable-libopencore_amrnb --enable-libopencore_amrwb --enable-libvo_aacenc --enable-libvo_amrwbenc
  libavutil      54. 31.100 / 54. 31.100
  libavcodec     56. 60.100 / 56. 60.100
  libavformat    56. 40.101 / 56. 40.101
  libavdevice    56.  4.100 / 56.  4.100
  libavfilter     5. 40.101 /  5. 40.101
  libavresample   2.  1.  0 /  2.  1.  0
  libswscale      3.  1.101 /  3.  1.101
  libswresample   1.  2.101 /  1.  2.101
  libpostproc    53.  3.100 / 53.  3.100
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from '/srv/player/data/media/571b9c29-530c-4e41-aa42-050eac110004/media/apple-tv-b1-2.mp4':
    major_brand     : isom
    minor_version   : 512
    compatible_brands: isomiso2avc1mp41
    creation_time   : 2015-09-22 18:33:35
    encoder         : Lavf56.1.0
  Duration: 00:03:59.83, start: 0.000000, bitrate: 3755 kb/s
    Stream #0:0(und): Video: h264 (High) (avc1 / 0x31637661), yuv420p(tv, bt709), 1920x1080 [SAR 1:1 DAR 16:9], 3751 kb/s, 30 fps, 30 tbr, 30030 tbn, 60060 tbc (default)
      creation_time   : 2015-09-22 18:33:35
      handler_name    : VideoHandler
mmal: mmal_vc_port_enable: failed to enable port ENOMEM
mmal: mmal_port_enable: failed to enable port (ENOMEM)
mmal: mmal_port_disable: port is not enabled
Failed to open file '/srv/player/data/media/571b9c29-530c-4e41-aa42-050eac110004/media/apple-tv-b1-2.mp4' or configure filtergraph
    nan    :  0.000 fd=   0 aq=    0KB vq=    0KB sq=    0B f=0/0   

Any ideas?

Fixed it with gpu_mem=192 in /boot/config.txt

1 Like