Network Manager bug

Since the last two updates to network manager wifi signal strength is no longer displayed when hovering the cursor over the network icon. Just thought I would mention this.

Hi exploder,

If helpful, I created a bug report for this yesterday eve. :slight_smile:

1 Like

Thanks! I will keep an eye on the bug report and add to it if I can get logged on.

It might be down to the icon theme you are using?.

Mine shows the 5 step indicator so I can see the percentage anyway! (Mate icon set):

I am still using the stock icon set.

Also using default Ambiant-MATE icon theme.

As a test, just tried all other (included) MATE themes, each now shows an Ethernet connection instead of wireless signal strength notification.

As an aside, is Ambiant-MATE a translation slip which should read Ambient-MATE? :slight_smile:

This could be down to whether it’s using the indicator “version” or not.

One version clicks for all the option, the other hides options depending if it is left or right clicked.

Using a wireless connection you should be able to hover over the network icon and the connection strength should display. This worked perfectly until network manager was updated the few times now…

On my install of 16.04 (fully updated); I had a couple of fall-outs yesterday, I did this mornings updates and will wait and see if it has fixed itself!. :smiley:

[quote=“DaveB, post:2, topic:5010”]
Hi exploder,

If helpful, I created a bug report for this yesterday eve. :slight_smile:[/quote]

Oops! While about to add some helpful information, just realised I misinterpreted the original post, sorry @exploder!

In case helpful for anyone in the future, here’s the info anyway:

If you find (like I did) the issue covered in my bug report is still present after a clean 16.04 LTS installation, here’s how to fix it…

Control Centre -> Additional Drivers

* (while connected to the Internet) Locate the wireless driver in use, change it to Do not use the device
* Apply Changes
* Re-select the wireless driver and once again Apply Changes

Afterwards, wireless signal strength and Connected desktop notification should work as expected.

Found the bug issue is still present after clean 16.04 LTS install if option to install updates during installation is used.

Update: After few hours its returned to showing Panel Ethernet connection notification (instead of wireless signal strength), and Desktop notification showing Disconnected, while connected. :frowning:

Is this ever going to get fixed?

Hi @BenjaminNYC,

just keep updating and maybe it will get a fix!. :smiley:

Yup, understood. Has the bug even been acknowledged by the dev’s here?

I have two main machines, and oddly, it only effects one, which is the one I did a clean install on. The other machine I upgraded from 14.04, and it doesn’t happen on that one.

Is the issue related to selecting “install updates with initial install”? If so, I’ll be sure to uncheck that on any future installs.

Probably the better question is " the devs at Canonical", as this is an issue of the main Ubuntu 16.04 distribution that affects more or less all derived distros (like Ubuntu MATE 16.04, and apparently also Linux Mint 18).
I really hope they put some serious effort into fixing this, because for a supposedly stable LTS release this is quite the show-stopper.

1 Like

OK that makes sense. Thanks.

Quite disappointing on their part.

I’d need a specific bug report to understand what the issue is you’re having.

Hi Wimpy,

Still seeing same exact behaviour in my original bug report linked in this post.

Afterwards, others reported same issue in other bug reports, my bug report was marked as duplicate (not sure how something that came before, can be duplicate of something after? :slight_smile: Not to worry!). Became disheartened, seeing reports bug was fixed, people mentioned still having the same issue (this seemed to loop), bug still remains.

Would it be easier to fall-back to the previous network-manager version, seemed to function without issue providing correct wireless/Ethernet connection notification?

Thanks for your time.

In the meantime, the best workaround seems to be to restart network-manager. But since typing sudo systemctl restart network-manager.service over and over again is really annoying, I just made a simple alias for it, nmr. Then, to keep from having to enter my password each time, I added the following line to the sudoers file: %sudo ALL=(ALL) NOPASSWD: /bin/systemctl restart network-manager.service

I’d like to make it even simpler and add an applet to the panel that I could just click on to run this routine, but I don’t know how to do that for a command that needs sudo.

EDIT: Making an applet is easier than I thought. Just do Add to Panel > Custom Application Launcher and select Application in Terminal under Type. The command should be the same as above: sudo restart network-manager.service. One click on the applet causes a terminal to blink on and off and then network manager restarts.

1 Like

This is driving me crazy also. I have the problem when I bootup or start from sleep. It is a problem upstream I believe. I don’t know if MATE has fixed it yet or not.

I can still connect to the internet(I have the Dell XPS 13 DE) but it doesn’t show up in nm-applet. I found that restarting nm-applet in the terminal works better than restarting network-manager.servie for these types of case. In terminal, I type:

killall nm-applet; nohup nohup nm-applet &

I spoke to the Ubuntu Desktop Team Manager last week, a fix is coming…